[PATCH] gnu: Add emacs-mct.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andrew Tropin
  • Nicolas Goaziou
  • Protesilaos Stavrou
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 5 Feb 2022 18:19
(address . guix-patches@gnu.org)(name . Protesilaos Stavrou)(address . public@protesilaos.com)
87y22o8unq.fsf@trop.in
* gnu/packages/emacs-xyz.scm (emacs-mct): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 444b761116..3e4ea925e1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30090,3 +30090,27 @@ (define-public emacs-fennel-mode
"Fennel mode provides font-lock, indentation, navigation, and REPL for
Fennel code within Emacs.")
(license license:gpl3+)))
+
+(define-public emacs-mct
+ (package
+ (name "emacs-mct")
+ (version "0.4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/mct.git")
+ (commit version)))
+ (sha256
+ (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (license license:gpl3+)
+ (home-page "https://protesilaos.com/emacs/mct")
+ (synopsis "Enhancement of the default Emacs minibuffer completion UI.")
+ (description "Minibuffer and Completions in Tandem, also known as
+mct, or mct.el, is a package that enhances the default minibuffer and
+*Completions* buffer of Emacs 27 (or higher) so that they work
+together as part of a unified framework. The idea is to make the
+presentation and overall functionality be consistent with other
+popular, vertically aligned completion UIs while leveraging built-in
+functionality.")))
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmH/U8kPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wJGIP/3JCmxSWikzfl+ov9fN67VxSyT/CcbsNjTqU
cH/1N65iSAJ7VTBrbl7nhR1cy97XWdY2DopxRD7Gg8W8KZUCGqUCkKD3MCs6K9Hr
2Uoyi+KS/ncCVf/0BfZ+PJL3pbk0zGrlFUdEJi3XKhi6Uip8ifKrX3vCqWoUvQdc
5aNBSd3b6JAUMnhqY/gKGaabcJQgj7zEJwuyINPe6lgGpFxwG1RUb4Betxq6JzUT
ttBoC1nuumsDUN8IH8KqlWtWWuvlbK4oSC9AA5cpV3iFQGhsSrb5Y9NB6i4ZR5fu
O3LPhGABfFpDm0RGQKy5b5fhCokpBnxBaoqy2eBdgqgBfb5rbmFVDxwGnmGciXux
FvsZ35NJw/6wP8ni2ST9gjMeVQ3Gd9UIF7n2ZAXcvm6/SB3fc1Cx2jG1aRK+rrpY
FaQTIdV9Df7/upDUQNd5S/gE64zfKoUGzQdLCG7SoUJjoemmBMWnm9MP2TNiL0oJ
xW1NKip4HkKeCRBzxX++Ok3ScZjF+aijb0tXvAhiuyB/KUT3CLeJbvvFDgplkHpj
RoRkx3QQiARffschjZHFaj0Y90bvCykfvL+bGzBHwFfKlYVNJ3kLXP3kZxlTLgka
1n7Ie/MyR6T12Z+8fPsnBOnYK7bB+Pl//soT3v9dJdcrWB3RJc0WRNxwl3ZERGmn
+d1Zbyyu
=MoCH
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 6 Feb 2022 22:51
(name . Andrew Tropin)(address . andrew@trop.in)
878runhden.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-mct): New variable.

Thank you.

Toggle quote (17 lines)
> +(define-public emacs-mct
> + (package
> + (name "emacs-mct")
> + (version "0.4.2")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.com/protesilaos/mct.git")
> + (commit version)))
> + (sha256
> + (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (license license:gpl3+)
> + (home-page "https://protesilaos.com/emacs/mct")
> + (synopsis "Enhancement of the default Emacs minibuffer completion UI.")

Synopsis may not end with a period. You may want to run "guix lint" on
your package definition.

Toggle quote (8 lines)
> + (description "Minibuffer and Completions in Tandem, also known as
> +mct, or mct.el, is a package that enhances the default minibuffer and
> +*Completions* buffer of Emacs 27 (or higher) so that they work
> +together as part of a unified framework. The idea is to make the
> +presentation and overall functionality be consistent with other
> +popular, vertically aligned completion UIs while leveraging built-in
> +functionality.")))

Sentences in description should be separated with two spaces.

Nitpick: license field usually comes last.

Note that upstream mentions this is an Emacs 28+ package, and Guix
provides only Emacs 27.2. Would it be a bit early to provide this
package?

Regards,
--
Nicolas Goaziou
P
P
Protesilaos Stavrou wrote on 7 Feb 2022 05:21
(address . 53812@debbugs.gnu.org)
87k0e79uin.fsf@protesilaos.com
Hello Nicolas!

On 2022-02-06, 22:51 +0100, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (4 lines)
> Note that upstream mentions this is an Emacs 28+ package, and Guix
> provides only Emacs 27.2. Would it be a bit early to provide this
> package?

This used to be the case in earlier versions, though mct.el specifies
the following since its version 0.3.0:

;; Package-Requires: ((emacs "27.1"))

--
Protesilaos Stavrou
A
A
Andrew Tropin wrote on 7 Feb 2022 16:04
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
8735ku90qt.fsf@trop.in
On 2022-02-06 22:51, Nicolas Goaziou wrote:

Toggle quote (46 lines)
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-mct): New variable.
>
> Thank you.
>
>> +(define-public emacs-mct
>> + (package
>> + (name "emacs-mct")
>> + (version "0.4.2")
>> + (source (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://gitlab.com/protesilaos/mct.git")
>> + (commit version)))
>> + (sha256
>> + (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
>> + (file-name (git-file-name name version))))
>> + (build-system emacs-build-system)
>> + (license license:gpl3+)
>> + (home-page "https://protesilaos.com/emacs/mct")
>> + (synopsis "Enhancement of the default Emacs minibuffer completion UI.")
>
> Synopsis may not end with a period. You may want to run "guix lint" on
> your package definition.
>
>> + (description "Minibuffer and Completions in Tandem, also known as
>> +mct, or mct.el, is a package that enhances the default minibuffer and
>> +*Completions* buffer of Emacs 27 (or higher) so that they work
>> +together as part of a unified framework. The idea is to make the
>> +presentation and overall functionality be consistent with other
>> +popular, vertically aligned completion UIs while leveraging built-in
>> +functionality.")))
>
> Sentences in description should be separated with two spaces.
>
> Nitpick: license field usually comes last.
>
> Note that upstream mentions this is an Emacs 28+ package, and Guix
> provides only Emacs 27.2. Would it be a bit early to provide this
> package?
>
> Regards,

Attaching v2, seems all the issues and questions are addressed.
From b4878a8adcbae7dd988df4741a39b0e0c27fb92b Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Sat, 5 Feb 2022 20:19:52 +0300
Subject: [PATCH v2] gnu: Add emacs-mct.

* gnu/packages/emacs-xyz.scm (emacs-mct): New variable.
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 444b761116..d7faf6ea6f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30090,3 +30090,26 @@ (define-public emacs-fennel-mode
"Fennel mode provides font-lock, indentation, navigation, and REPL for
Fennel code within Emacs.")
(license license:gpl3+)))
+
+(define-public emacs-mct
+ (package
+ (name "emacs-mct")
+ (version "0.4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/mct.git")
+ (commit version)))
+ (sha256
+ (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://protesilaos.com/emacs/mct")
+ (synopsis "Enhancement of the default Emacs minibuffer completion UI")
+ (description "Minibuffer and Completions in Tandem, also known as mct, or
+mct.el, is a package that enhances the default minibuffer and *Completions*
+buffer of Emacs 27 (or higher) so that they work together as part of a unified
+framework. The idea is to make the presentation and overall functionality be
+consistent with other popular, vertically aligned completion UIs while
+leveraging built-in functionality.")
+ (license license:gpl3+)))
--
2.34.0
--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmIBNPoPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6w66EP/iAm67I4cu9d1IjmLvDpP0+WbqWdbgrdlK15
eTlCmdYQ6MPX6IjVY8kAJKQpI9jC933MtN5a2cNXJ7OBa6QYildd0Dq7nCzKSXbZ
QzmD67/T8O3X2cScva9fFz6wmpu0inM+CR7U2XKgjIZKVwotAbmY50Cki7Cua4hg
+4cob8AUky6d9/opmGh+XQcRdYt3JKv2EjHtNz5QPwW3EeFT+AYFgdGiG8/sWqCT
QQeslfNJoPyVBgbhgZh09lgkNduSwK+gcDd/AtOBvJDLCLUuaEV5AGUOeTdl5fJH
tUcTdjBmvr+NJz5xglPxiexY0W6nsGx/B09qtVJ3AKzj/o2ikv0zmiJYCFVj762D
UBNJb4zEV0roV06ApAuYi2QZtVhYZul+3ZcgtZvGJ10iQWfXMKWK9IHXqq0sa4aH
EAIvCwHbrpi/7jEElVbLp6GHZt5zwMcp1yjZzwWfUZgsdE+MDJ7ssaOOP6Yd2GEX
bB76Gg8yZv+BBtnltf//KtA9+DxbTp/LRijDKCrT/ViC4Y/Qq5BJz2GJDiZpoN2g
A+ATruzRw8fL92Ied1CjVf+tsCRuVzonweZvw05RjPehDYKkX/sOM/1+au1BfuVv
q8OIAGG2h+v3htPiuG3KHMFUm2nxzmif3WZFS2x7FY2PSV++GONkOKzTbWvPtnEf
pkkA2ziv
=w5/0
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 8 Feb 2022 01:11
(name . Andrew Tropin)(address . andrew@trop.in)
87zgn21akr.fsf@nicolasgoaziou.fr
Hello,

Andrew Tropin <andrew@trop.in> writes:

Toggle quote (2 lines)
> Subject: [PATCH v2] gnu: Add emacs-mct.

Thanks.

I removed ".git" suffix from source URL, removed reference to Emacs
version in the description, and pushed.

Regards,
--
Nicolas Goaziou
Closed
?