(address . guix-patches@gnu.org)(name . Protesilaos Stavrou)(address . public@protesilaos.com)
* gnu/packages/emacs-xyz.scm (emacs-mct): New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 444b761116..3e4ea925e1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30090,3 +30090,27 @@ (define-public emacs-fennel-mode
"Fennel mode provides font-lock, indentation, navigation, and REPL for
Fennel code within Emacs.")
(license license:gpl3+)))
+
+(define-public emacs-mct
+ (package
+ (name "emacs-mct")
+ (version "0.4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/mct.git")
+ (commit version)))
+ (sha256
+ (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (license license:gpl3+)
+ (home-page "https://protesilaos.com/emacs/mct")
+ (synopsis "Enhancement of the default Emacs minibuffer completion UI.")
+ (description "Minibuffer and Completions in Tandem, also known as
+mct, or mct.el, is a package that enhances the default minibuffer and
+*Completions* buffer of Emacs 27 (or higher) so that they work
+together as part of a unified framework. The idea is to make the
+presentation and overall functionality be consistent with other
+popular, vertically aligned completion UIs while leveraging built-in
+functionality.")))
--
2.34.0
-----BEGIN PGP SIGNATURE-----
iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmH/U8kPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wJGIP/3JCmxSWikzfl+ov9fN67VxSyT/CcbsNjTqU
cH/1N65iSAJ7VTBrbl7nhR1cy97XWdY2DopxRD7Gg8W8KZUCGqUCkKD3MCs6K9Hr
2Uoyi+KS/ncCVf/0BfZ+PJL3pbk0zGrlFUdEJi3XKhi6Uip8ifKrX3vCqWoUvQdc
5aNBSd3b6JAUMnhqY/gKGaabcJQgj7zEJwuyINPe6lgGpFxwG1RUb4Betxq6JzUT
ttBoC1nuumsDUN8IH8KqlWtWWuvlbK4oSC9AA5cpV3iFQGhsSrb5Y9NB6i4ZR5fu
O3LPhGABfFpDm0RGQKy5b5fhCokpBnxBaoqy2eBdgqgBfb5rbmFVDxwGnmGciXux
FvsZ35NJw/6wP8ni2ST9gjMeVQ3Gd9UIF7n2ZAXcvm6/SB3fc1Cx2jG1aRK+rrpY
FaQTIdV9Df7/upDUQNd5S/gE64zfKoUGzQdLCG7SoUJjoemmBMWnm9MP2TNiL0oJ
xW1NKip4HkKeCRBzxX++Ok3ScZjF+aijb0tXvAhiuyB/KUT3CLeJbvvFDgplkHpj
RoRkx3QQiARffschjZHFaj0Y90bvCykfvL+bGzBHwFfKlYVNJ3kLXP3kZxlTLgka
1n7Ie/MyR6T12Z+8fPsnBOnYK7bB+Pl//soT3v9dJdcrWB3RJc0WRNxwl3ZERGmn
+d1Zbyyu
=MoCH
-----END PGP SIGNATURE-----