[PATCH] gnu: Add emacs-app-launcher.

  • Done
  • quality assurance status badge
Details
3 participants
  • Demis Balbach
  • Maxime Devos
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Demis Balbach
Severity
normal
D
D
Demis Balbach wrote on 5 Feb 2022 12:20
(address . guix-patches@gnu.org)(name . Demis Balbach)(address . db@minikn.xyz)
20220205112019.31624-1-db@minikn.xyz
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 444b761116..4ce7525dee 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2615,6 +2615,33 @@ (define-public emacs-async
as a library for other Emacs packages.")
(license license:gpl3+)))
+(define-public emacs-app-launcher
+ (let ((commit "80a9ed37892ee6e21fe44487ed11f66a15e3f440")
+ (revision "1")
+ (version "0.1"))
+ (package
+ (name "emacs-app-launcher")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/SebastienWae/app-launcher")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ywhfx8604ifmvcy2397bmvq2wj03jyqnm0g7lmqqi5p97rjbdgc"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/SebastienWae/app-launcher")
+ (synopsis
+ "Use Emacs an app launcher")
+ (description
+ "app-launcher defines the app-launcher-run-app command which uses Emacs
+standard completion feature to select an application installed on your machine
+and launch it.")
+ (license license:gpl3+))))
+
(define-public emacs-auctex
(package
(name "emacs-auctex")
--
2.34.0
M
M
Maxime Devos wrote on 5 Feb 2022 13:05
a0b6cdf10a282a84a781d230b0368296fba3b3b3.camel@telenet.be
Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
Toggle quote (4 lines)
> +       "app-launcher defines the app-launcher-run-app command which uses Emacs
> +standard completion feature to select an application installed on your machine
> +and launch it.")

What does ‘launching’ mean here? Is ‘launching an application’
functionally the same as running it (with 'fork'+'exec' or 'system' or
whatever)? Does it have extra bells and whistles?

It's a super vague word, e.g. when Xiden has been announced on guix-
devel, one of the words that kept being repeated was 'launcher', but it
wasn't defined anywhere in its practically empty manual. (Nowadays
there's actually a manual and it does define launchers, but it didn't
use to.)

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf5oCRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7giaAP9Am+LjyMvoKkuzDVZBtRiXT6fH
rNo/w73XnSJrHE+ylgEA3CyNEg6tb9e5sauiwY0Or/0F1R1aoGL51v7wmVciMgg=
=mksh
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 5 Feb 2022 13:10
c0d9f960f010714d9e23d3c653b226c2cf65e7b0.camel@telenet.be
Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
Toggle quote (4 lines)
> +       "app-launcher defines the app-launcher-run-app command which uses Emacs
> +standard completion feature to select an application installed on your machine
> +and launch it.")

Looking at the source code, it appears to assume .desktop files,
so it doesn't work for arbitrary applications.

Additionally, the source code days 'Linux' .desktop applications
even though .desktop is not Linux-specific: unless something weird
is going on, they can be and are used on GNU/Hurd and Debian
GNU/kFreeBSD.

The latter is not a problem with the package definition though, just
something I noticed.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf5pNhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7jj8AQDJketm7vA7Y9k2HmXpVPKYausA
KRthAUiQgoobQbUQiwEApT6oPypyif17jglre/jr9lFoAhNpPAoXd2ykiy6X3wI=
=Ik6G
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 5 Feb 2022 13:12
d970bde33d3c9ce262ca94ea07f004df7ccd6d05.camel@telenet.be
Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
Toggle quote (4 lines)
> +  (let ((commit "80a9ed37892ee6e21fe44487ed11f66a15e3f440")
> +        (revision "1")
> +        (version "0.1"))

It's the first version in Guix, so revision should be "0."
Also, version "0.1" seems to be incorrect here, since there
aren't any releases at all. So I'd start at "0.0".

I could be wrong, but I don't think that the auto-updater
(guix refresh -u) understands let-bound versions (let-bound commits and
revisions are ok though), and you're only using the 'version' variable
in a single place, so I'd move it to the 'version' field of the package
record.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf5pyRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7levAP4uV4kLWNqJvWd1/zZDlzZpb67Z
lKuN0aHwH6Xp/HKURQD/b8FlROEV+05tE/J3DUeIjSV/LYXFWgqEmEX7x2Wo3QQ=
=y2ZC
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 5 Feb 2022 13:13
3e104d37639ad8725993b339fc636ec48d6df2cf.camel@telenet.be
Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
Toggle quote (2 lines)
> +       "Use Emacs an app launcher")

Seems ingrammatical, "Use Emacs as an app launcher" would be better
though still rather vague.

Greetings,
Maxime.
M
M
Maxime Devos wrote on 5 Feb 2022 13:14
322dbf86e0d5275843def9765f83c5fd7ac69a73.camel@telenet.be
Maxime Devos schreef op za 05-02-2022 om 13:12 [+0100]:
Toggle quote (4 lines)
> It's the first version in Guix, so revision should be "0."
> Also, version "0.1" seems to be incorrect here, since there
> aren't any releases at all.  So I'd start at "0.0".

Nevermind, I now see 'app-launcher.el' says Version: 0.1.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf5qOBccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7hpyAQC4NeVQ3bYptEXDGt1d6Q0i4Je9
/ONhF382bBSwO1cRpgEAwRtYId8wtQObx9VgqeY+9VtolGP6JYWOWppw4ZodLw0=
=iJC6
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 5 Feb 2022 13:16
6cb7ff5c33fee0fcde3dfb0ea77b5947f183120e.camel@telenet.be
Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
Toggle quote (2 lines)
> +(define-public emacs-app-launcher

app-launcher.el has (require 'xdg) (require 'cl-seq),
are these built-in to Emacs or do they need to be added to propagated-
inputs?

Greetings,
Maxime.
M
M
Maxime Devos wrote on 5 Feb 2022 13:20
9f7b5e46ede93da10a206537883963de04a2c7ea.camel@telenet.be
Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
Toggle quote (2 lines)
> +(define-public emacs-app-launcher

app-launcher.el says it includes code from the Counsel package by Oleh
Krehel and the counsel source files have "Copyright (C) YEARS Foo"
lines, but app-launcher.el doesn't have those.

IIRC, the GPL has a clause that says you need to preserve copyright
lines, so this looks like a violation of the license to me. Can they
be re-added upstream?

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf5rdhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7qM/AQCVgZjAN3h/hGUUinN6H0NpQFmb
0IQdy8iPlnmc/VNFsAEA6wgl2JGFA0y5PmRfSmVu6ZyQGjZfTmhuOpRpiUXmMwo=
=Wye1
-----END PGP SIGNATURE-----


D
D
Demis Balbach wrote on 6 Feb 2022 11:55
87sfswgt6y.fsf@minikn.xyz
On 2022-02-05 13:05, Maxime Devos wrote:

Toggle quote (18 lines)
> Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
>> +       "app-launcher defines the app-launcher-run-app command which uses Emacs
>> +standard completion feature to select an application installed on your machine
>> +and launch it.")
>
> What does ‘launching’ mean here? Is ‘launching an application’
> functionally the same as running it (with 'fork'+'exec' or 'system' or
> whatever)? Does it have extra bells and whistles?
>
> It's a super vague word, e.g. when Xiden has been announced on guix-
> devel, one of the words that kept being repeated was 'launcher', but it
> wasn't defined anywhere in its practically empty manual. (Nowadays
> there's actually a manual and it does define launchers, but it didn't
> use to.)
>
> Greetings,
> Maxime.

Hello. I don't know if that's what you wanted to hear but technically,
the script is a big wrapper around
`call-process-shell-command'. `app-launcher--action-function' can be set
to whatever function to execute on the selected candidate, by default
this is set to `app-launcher--action-function-default' which ultimately
runs `call-process-shell-command'. See:

Is this enough information?

--
Best regards / Mit freundlichen Grüßen,
Demis Balbach
-----BEGIN PGP SIGNATURE-----

iQJCBAEBCgAsFiEEz9zHmXzCRksxyCGU8X3bmMw8QFwFAmH/qTUOHGRiQG1pbmlr
bi54eXoACgkQ8X3bmMw8QFxtnA/9Fy8+sXxci8QiqbkNuYo0+VGU5rVCtmRQyppP
pjkCZ21V3agkCR/FnCj6LNTSQDJqbMKt9QHjT9bYFOWG1xzeJfCpBG6yZfNq9oPA
VNBiKBndMMTe7SZmHqCDAw7gNiLf0GD2WhMAv5F6F/ji+gmRrRfgoNKUAo5fmkDR
QgHUgjmKjwiZ2BuYkOQKYDlGU/5Gix5nNmP28jSg388QYSHfIITK7WbwAbwnnYSA
TkWKZC+nARQQSEuvuIH2eWeJhEveru6YQ0svMXY6x9AhwNtAIqKj8DkKtCimz0sn
OkFFcNiEe7qNk8EwwClsqYLg64kJE4PKzV/p/2Cy2Lj6V8fGp+LllWtDyt2vO6KP
5lHicLbEXCLRLmM4+lp7yUV+tGj4+/uU/BQh6hYpbucw1x8Qqj18gIA05zds5+PR
teVKaEnx86hqdS5ev4VvHvHwPSJDW7r/qLCWBsdZgQwTmxxnC/4RDfJClnGe7tz0
vzgcWEhsnQGifUWvhAlVaxu7dASza1DA4XY9CxDksMiD0Z9BAcnWrMjmlAjBflir
JfZTR/DoJNZKMOanHzwPWsyBsV/wxI66wOpRVsne1AtAQKjjvyZUgYeBGr7FP8qi
j7Au3yHhQVPTYX5aDUnxJnrEqUXhSmwuw7ceU9HS/DQZrlbFMLBp+1dSUaq3jwSA
4H64BbY=
=xf4C
-----END PGP SIGNATURE-----

D
D
Demis Balbach wrote on 6 Feb 2022 11:58
87pmo0gt1z.fsf@minikn.xyz
On 2022-02-05 13:13, Maxime Devos wrote:

Toggle quote (10 lines)
> Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
>> +       "Use Emacs an app launcher")
>
> Seems ingrammatical, "Use Emacs as an app launcher" would be better
> though still rather vague.
>
> Greetings,
> Maxime.
>

This is indeed a mistake. But please, if you have a better
synopsis/description in mind - share it. I'm always bad at these
things. Especially since the package itself doesn't provide a whole lot
of documentation since it's so simple.

--
Best regards / Mit freundlichen Grüßen,
Demis Balbach
-----BEGIN PGP SIGNATURE-----

iQJCBAEBCgAsFiEEz9zHmXzCRksxyCGU8X3bmMw8QFwFAmH/qegOHGRiQG1pbmlr
bi54eXoACgkQ8X3bmMw8QFzN6Q//ZngL2PUSFx2wRA1YDj0dczo74J/eW0BLJDNG
CjZ13i3AuwtZ9hzORO4BuXDcJvMzxEBfWCz2FdMHRf2YIn0WttQ6f74yDDQugANy
hAJdojW2bN1vc7xJ7crQrBeQ5N2sJPiGoVW0LW3y2tIFNyfVmxHRzBiz+a80861d
h+qyeM717zk73qBslPf22pEphuwL7OxSv/RilzQL6/s3zRgiGKA5Cdbgp5ZGnUi8
jNEHgBxkXnxt/+PE0SsMKTN7wZLBvfnOF3QPcHkT4o1eh5xDfe3bk80s69zIBKlS
wWvwoMBF8jHx0/JnsuhLfWQCwEXYlzNHyBx943m10fLWF2ca8SezPPeoK48KBki+
JRMP11LgcLrnbFG5lYrIh1IJpX81WsY4QCGnTpueUpypt5ltTdSRTlKO91L9RFE/
sAd7tuFLNRKNoKZfF3OEnrzSI3MJKynRqYmhMAv59+EFo8a9LvZeWokDGOspE/Es
nH+qGkxwHK5MCRDH+i0owe2tklHhdzUXuKVNmT9Ghqgh/Ek3B+yvjpgo8Rp4XXMK
YAcSU+YcYiui7s/zWsfn8WYZNCxIPqR7oKfP0EDRWbut8djE70OWMBk3f5YJMyx3
4lagrDVdZSWptiaNJeracG6V2fOk/ZHFG8HQXR5442jwGdyzeS3ZoaorwCaA9ntu
MvZJFJg=
=YgWS
-----END PGP SIGNATURE-----

D
D
Demis Balbach wrote on 6 Feb 2022 11:59
87mtj4gt0s.fsf@minikn.xyz
On 2022-02-05 13:16, Maxime Devos wrote:

Toggle quote (11 lines)
> Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
>> +(define-public emacs-app-launcher
>
> app-launcher.el has (require 'xdg) (require 'cl-seq),
> are these built-in to Emacs or do they need to be added to propagated-
> inputs?
>
> Greetings,
> Maxime.
>

I think they are built into emacs. I had no trouble with the package
definition.

--
Best regards / Mit freundlichen Grüßen,
Demis Balbach
-----BEGIN PGP SIGNATURE-----

iQJCBAEBCgAsFiEEz9zHmXzCRksxyCGU8X3bmMw8QFwFAmH/qhMOHGRiQG1pbmlr
bi54eXoACgkQ8X3bmMw8QFzWlw//R9z5rqkZOoAY4CHiSTPNnQl7dIg4QyEy5Z7D
5aL5FkzvXrEJD2/3rHkU4xe+uTHio7eUSCb0BXQ7P5py/1/mrfdN7e5o7TlO3lua
wmsNTZjZHmxvqQZR3jWOYpsy+A5j4HrR3iVCgvWnR4nKcWnqaoTdpCeJYA9LqCrj
50CWiB8XTDxLEYnhTtkmel2Fl6Z0nKehHT9HTKv66eLVe9GB4SzhLO15Kyre9Bm8
v2CiGphPnMdqdS6Uv7EY6q1Wdv8G2316oaxWHaiA+emD4NdTyvHjZAMzJZwprndC
q+c3AivH2o9KPjhID/sWjR98lVCembEAcUGiELsC1n5w4e612BViEQj5uU65ImXe
EF7WPewg9tTSK9nJN5lhwHjNyPLI88LXK1/CMifFxkfKlQ5eLIBHLI+Zxgorvhhc
RZekM6/+OdqO5b7/bIrXzQzro38n6RTREsLBM+J+5Tklm8K9rhJD9vaZbXTl+tLy
Kbkw38yGGrj1GlaAKex4KvOK2CdFqkwUxDS6Z3a3zuGafqFYpI0q/i5Mdc5FCn7/
c1baOm/v/s9DQFlCTs0kNYZMOa6uoKcQmdYu+/10lLubRWg+MLtAZK9XB3RSuB3a
RAvUQqqlohP4cu0Gpz2CvzKhwktKLgnash8bCHb7PDsi7IdVVbk8QHcWPBs1KmTu
r7MScsE=
=H3+L
-----END PGP SIGNATURE-----

D
D
Demis Balbach wrote on 6 Feb 2022 12:01
87k0e8gsxd.fsf@minikn.xyz
On 2022-02-05 13:20, Maxime Devos wrote:

Toggle quote (14 lines)
> Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
>> +(define-public emacs-app-launcher
>
> app-launcher.el says it includes code from the Counsel package by Oleh
> Krehel and the counsel source files have "Copyright (C) YEARS Foo"
> lines, but app-launcher.el doesn't have those.
>
> IIRC, the GPL has a clause that says you need to preserve copyright
> lines, so this looks like a violation of the license to me. Can they
> be re-added upstream?
>
> Greetings,
> Maxime.

I don't know if that's a violation sorry. Regarding adding it
upstream. I don't think so. At least judging by the activity of the
maintainer. See here:

There are open issues starting a year ago and the author hasn't replied
to any of them. But I could try my luck and contact them to add the
copyright notices.

--
Best regards / Mit freundlichen Grüßen,
Demis Balbach
-----BEGIN PGP SIGNATURE-----

iQJCBAEBCgAsFiEEz9zHmXzCRksxyCGU8X3bmMw8QFwFAmH/qo4OHGRiQG1pbmlr
bi54eXoACgkQ8X3bmMw8QFzpfA//eMH2A0ZQ2Hm3N95YvEjSebYxJtvAQPpoSWEO
DU3ijs5lhR+288ENqWIHCvF7gEsvyLL3i8h9q+jbyVyUlIAHSEgch4fEF6F4xHF1
+/rs4JffYk4YxlR2/mCqAyC5DZeYPFNTiCLq2dSEPfG3G/6xzLv2sdTELEi9PKXM
ouHwiFyo5Au2LgirhKajPeYSGxYY2uyRVaH5m7xo4iKGBY/sdcwo5TN0XCdi0JpI
uu7ZRXZmS4nZc+NHzeuIoQeGHZoEmJ6JwRZvieujkOgXDTf53hrN+rofvD4uEMFM
ZZc12z3IUklETxtS47zvG9XkaQMcBqbO+KEgqdpR4iCTEPnaRfQAQsN8ZMfNhGA8
dW2YFYH9qrG9gqczJOGrIZdswzEHNxBjuK0jBLNbjTGUoEupEzL78ZU0qDp4u5Yo
vlRJU/osGSvo6KCsQI7N0vq7XR/9kovns2UjFRlqPpJ4W+bS6QehmovLt2rkd3VK
DplON/KtZFQV3Gox5dClR4ZqZyxwlcJwX+83MFnzt0+JY1kiKlbJSHjToJSPmW4B
wcLH5oO4y5InPk1Oyz3b3jtXAYd1d0FbjTKmgvmx/jTw3xTmgetw/07sv5MTwc/n
8odlX20Tg7fh0srykzD9RqZ0dxeKGGDmSyd/pCbi+psE0j9r3iXsOU6mER90VpWK
/UvJzyU=
=ldWc
-----END PGP SIGNATURE-----

M
M
Maxime Devos wrote on 6 Feb 2022 12:44
a35a9d86ab5a71025a9c52fb51828a07a5af9cb1.camel@telenet.be
Demis Balbach schreef op zo 06-02-2022 om 12:01 [+0100]:
Toggle quote (10 lines)
> I don't know if that's a violation sorry. Regarding adding it
> upstream. I don't think so. At least judging by the activity of the
> maintainer. See here:
> https://github.com/SebastienWae/app-launcher/issues
>
> There are open issues starting a year ago and the author hasn't
> replied
> to any of them. But I could try my luck and contact them to add the
> copyright notices.

IANAL but it's such a minor and technical violation (the app-
launcher.el even acknowledges Oleh Krehel, it just didn't say
Copyright YEAR Oleh Krehel (or Copyright YEAR FSF, since it looks
like Counsel has some copyright assignement to the FSF going on))
that I would consider making a token effort to correct it upstream
sufficient.

If not, it could be patched (with an origin snippet or a patch)
in Guix.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf+0ihccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tLyAQCOEl6O9BZ/4z4rtNJr/cqohcwC
9UFe3K4u93lBqZCKggD+NXqX4Z3N9MWidyU3NL+d8qLWiGVVBilnqfSKnY31vAM=
=vIYP
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 6 Feb 2022 12:39
1591195edba38979e92786b35275bc0f7363afb6.camel@telenet.be
Demis Balbach schreef op zo 06-02-2022 om 11:58 [+0100]:
Toggle quote (16 lines)
> > Demis Balbach schreef op za 05-02-2022 om 12:20 [+0100]:
> > > +       "Use Emacs an app launcher")
> >
> > Seems ingrammatical, "Use Emacs as an app launcher" would be better
> > though still rather vague.
> >
> > Greetings,
> > Maxime.
> >
>
> This is indeed a mistake. But please, if you have a better
> synopsis/description in mind - share it. I'm always bad at these
> things. Especially since the package itself doesn't provide a whole
> lot
> of documentation since it's so simple.

I'm also bad at descriptions and synopses. How about

(synopsis "Start applications from Emacs")
(description "This package allows starting applications from within
Emacs with the @lisp{app-launcher-run-app} command. It supports
autocompletion. It cannot be used to start arbitrary software; it
assumes that the application has a .desktop file. This is the case
for most, but certainly not all, graphical software.")

?

‘Application’ in the synopsis is not really specific, but the
description explains what counts as ‘application’ to emacs-app-
launcher.

Greetings,
Maxime
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf+zVRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tt0AQC2EQCLcxk1O0WsQTI0jyb0M54s
SJz8YLavbitHfAxJlgEAll0ryR/qCzFDpG448TOnfNBjuwaWBP+OSWtKcRUdlQQ=
=4cvG
-----END PGP SIGNATURE-----


M
M
Maxime Devos wrote on 6 Feb 2022 12:40
9a89e90fae3d42fbbef0282cbc3f096863116a20.camel@telenet.be
Demis Balbach schreef op zo 06-02-2022 om 11:59 [+0100]:
Toggle quote (3 lines)
> I think they are built into emacs. I had no trouble with the package
> definition.

OK.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYf+zkhccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7nmGAQDNAqkZvQ8T/20KG2A9LLxquqy1
zq8LopcRTwOKtCndUgEA1a+6D2k1o4bxActk9/Lrj51zRza6ACjYLBzrKUABHg0=
=ersL
-----END PGP SIGNATURE-----


V
V
Vagrant Cascadian wrote on 2 Sep 2023 00:35
87ttsdr07j.fsf@wireframe
On 2022-02-05, Demis Balbach wrote:
Toggle quote (2 lines)
> +(define-public emacs-app-launcher

This was added in commit:

90174c77cf59fd9681eb7442a92015cd61c8495d gnu: Add emacs-app-launcher.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJnMAAKCRDcUY/If5cW
qmbtAQCzdHGKxRANszQxXSKQyoDG/HF5glflhxyOsSuW1NMdigEAwKBMay3ngB/h
6DFTXNll5Am5i0bRixjkQ5MCgwjTEgE=
=vkkd
-----END PGP SIGNATURE-----

Closed
?