Demis Balbach wrote 3 years ago
(address . guix-patches@gnu.org)(name . Demis Balbach)(address . db@minikn.xyz)
---
gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 444b761116..4ce7525dee 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2615,6 +2615,33 @@ (define-public emacs-async
as a library for other Emacs packages.")
(license license:gpl3+)))
+(define-public emacs-app-launcher
+ (let ((commit "80a9ed37892ee6e21fe44487ed11f66a15e3f440")
+ (revision "1")
+ (version "0.1"))
+ (package
+ (name "emacs-app-launcher")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/SebastienWae/app-launcher")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ywhfx8604ifmvcy2397bmvq2wj03jyqnm0g7lmqqi5p97rjbdgc"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/SebastienWae/app-launcher")
+ (synopsis
+ "Use Emacs an app launcher")
+ (description
+ "app-launcher defines the app-launcher-run-app command which uses Emacs
+standard completion feature to select an application installed on your machine
+and launch it.")
+ (license license:gpl3+))))
+
(define-public emacs-auctex
(package
(name "emacs-auctex")
--
2.34.0