[PATCH] add python-posix-ipc

  • Done
  • quality assurance status badge
Details
4 participants
  • Ian Ressa
  • Ludovic Courtès
  • Xinglu Chen
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Ian Ressa
Severity
normal
I
I
Ian Ressa wrote on 4 Feb 2022 05:53
(address . guix-patches@gnu.org)(name . Ian Ressa)(address . ian@eonn.xyz)
20220204045300.1985-1-ian@eonn.xyz
Adding python-posix-ipc to gnu/packages/python-xyz.scm

---
gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46419e8ace..53d5588564 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -116,6 +116,7 @@
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2022 Ian Ressa <ian@eonn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28926,3 +28927,34 @@ (define-public python-types-dataclasses
"This packages provides a collection of library stubs for Python, with
static types.")
(license license:asl2.0)))
+
+(define-public python-posix-ipc
+ (package
+ (name "python-posix-ipc")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "posix_ipc" version))
+ (sha256
+ (base32 "15wbxf67y17g04i3f3vjw9zjbvlvqqk9q1x0ya1y7apl5k7b3pbc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:modules ((guix build python-build-system)
+ ((guix build gnu-build-system) #:prefix gnu:)
+ (guix build utils))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'support-cross-compilation
+ (lambda _
+ (substitute* "prober.py"
+ (("cc") ,(cc-for-target)))
+ #t)))))
+ (home-page "http://semanchuk.com/philip/posix_ipc/")
+ (synopsis
+ "POSIX IPC primitives (semaphores, shared memory and message
+queues) for Python")
+ (description
+ "The Python extension module posix_ipc gives Python access to
+POSIX inter-process semaphores, shared memory and message queues on systems
+that support the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993.")
+ (license license:bsd-3)))
--
2.34.0
X
X
Xinglu Chen wrote on 9 Feb 2022 14:54
(name . Ian Ressa)(address . ian@eonn.xyz)
87o83gw3gj.fsf@yoctocell.xyz
Hi,

Ian schrieb am Freitag der 04. Februar 2022 um 04:53 GMT:

Toggle quote (38 lines)
> Adding python-posix-ipc to gnu/packages/python-xyz.scm
>
> ---
> gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
> 1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 46419e8ace..53d5588564 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -116,6 +116,7 @@
> ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
> ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
> ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
> +;;; Copyright © 2022 Ian Ressa <ian@eonn.xyz>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -28926,3 +28927,34 @@ (define-public python-types-dataclasses
> "This packages provides a collection of library stubs for Python, with
> static types.")
> (license license:asl2.0)))
> +
> +(define-public python-posix-ipc
> + (package
> + (name "python-posix-ipc")
> + (version "1.0.5")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "posix_ipc" version))
> + (sha256
> + (base32 "15wbxf67y17g04i3f3vjw9zjbvlvqqk9q1x0ya1y7apl5k7b3pbc"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:modules ((guix build python-build-system)
> + ((guix build gnu-build-system) #:prefix gnu:)
> + (guix build utils))

Nothing from (guix build gnu-build-system) seems to be used. I think
you can drop the ‘#:modules’ arguments all together.

Toggle quote (8 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (add-after 'unpack 'support-cross-compilation
> + (lambda _
> + (substitute* "prober.py"
> + (("cc") ,(cc-for-target)))
> + #t)))))

Phases no longer have to return #f.


Toggle quote (2 lines)
The page supports HTTPS too, so it should be used instead of plain HTTP.

Toggle quote (4 lines)
> + (synopsis
> + "POSIX IPC primitives (semaphores, shared memory and message
> +queues) for Python")

The things in parenthesis are also mentioned in the description, so I
think you can drop them to make the synopsis a bit shorter.

Toggle quote (8 lines)
> + (description
> + "The Python extension module posix_ipc gives Python access to
> +POSIX inter-process semaphores, shared memory and message queues on systems
> +that support the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993.")
> + (license license:bsd-3)))
> --
> 2.34.0

The rest LGTM!
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmIDx3wVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x53cUQAL1GdDI/KlOUjNu5lN15ldv4u6HG
LXaUOPVSaqf16JilcLYPWuPer9C0ISrbqRCMgHrAleveMhJn7eB4EYoBfUiHHOr+
sRQWzof7sXvYrdm4X6ANWfwl4/IlHcs99DaoKUYwVkueVFg+9Mgi0XO5ve2LxneM
yHP+eBB9tPXuXPVhFy9dN+HM0nTrYr4h4/Bsqaz13I6ecc9pQqPhUH6ygW8qSGgz
dq2ueMhZgqFxK/hntLkihH+/KnPDgyNNd32sS6PquStyQkl+ebAxkQy61RhmSm0I
4a7LbGaad1uscSwZydjCaP1gmGT7Rl6zUMkDMkwzx5F+jCs23ySqCTd539i3FyNp
u9W+/jWSKrHl7ccn8hl7vSqmY2tMuS62YzDfyUssmJ77FqIU1dZemd1+DSfcgEyl
S8bCC6W497uw631WW9pkL6U6li+2fP8K/8SsRMcKEApfMjCZId6ML0DOPgkIgJTt
enmgP1otX+A+iPOeiSLCyFewW6M4ifun+EkELT+oYmAw1h9p/OtVxDpnZmCYIW7o
F4IYJM1Z86ctS4VT5oUxz0tXGizCOSkLrPqG2Ybi57en5rBDl8DssflIag8D7Jke
mC3PjwdIB6iORBuf/XRtM+asDkonHw15HigvvPISkk3wEQ4M7+apXbJ8cbqieeV9
B5RfxPpWMiy9jh9z
=NFpE
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 6 Mar 2022 22:37
Re: bug#53777: [PATCH] add python-posix-ipc
(name . Ian Ressa)(address . ian@eonn.xyz)
871qzekbje.fsf_-_@gnu.org
Hello Ian,

Did you have a chance to address Xinglu’s comments below?

Thanks in advance!

Ludo’.

Xinglu Chen <public@yoctocell.xyz> skribis:

Toggle quote (76 lines)
> Hi,
>
> Ian schrieb am Freitag der 04. Februar 2022 um 04:53 GMT:
>
>> Adding python-posix-ipc to gnu/packages/python-xyz.scm
>>
>> ---
>> gnu/packages/python-xyz.scm | 32 ++++++++++++++++++++++++++++++++
>> 1 file changed, 32 insertions(+)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 46419e8ace..53d5588564 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -116,6 +116,7 @@
>> ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
>> ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
>> ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
>> +;;; Copyright © 2022 Ian Ressa <ian@eonn.xyz>
>> ;;;
>> ;;; This file is part of GNU Guix.
>> ;;;
>> @@ -28926,3 +28927,34 @@ (define-public python-types-dataclasses
>> "This packages provides a collection of library stubs for Python, with
>> static types.")
>> (license license:asl2.0)))
>> +
>> +(define-public python-posix-ipc
>> + (package
>> + (name "python-posix-ipc")
>> + (version "1.0.5")
>> + (source (origin
>> + (method url-fetch)
>> + (uri (pypi-uri "posix_ipc" version))
>> + (sha256
>> + (base32 "15wbxf67y17g04i3f3vjw9zjbvlvqqk9q1x0ya1y7apl5k7b3pbc"))))
>> + (build-system python-build-system)
>> + (arguments
>> + `(#:modules ((guix build python-build-system)
>> + ((guix build gnu-build-system) #:prefix gnu:)
>> + (guix build utils))
>
> Nothing from (guix build gnu-build-system) seems to be used. I think
> you can drop the ‘#:modules’ arguments all together.
>
>> + #:phases
>> + (modify-phases %standard-phases
>> + (add-after 'unpack 'support-cross-compilation
>> + (lambda _
>> + (substitute* "prober.py"
>> + (("cc") ,(cc-for-target)))
>> + #t)))))
>
> Phases no longer have to return #f.
>
>
>> + (home-page "http://semanchuk.com/philip/posix_ipc/")
>
> The page supports HTTPS too, so it should be used instead of plain HTTP.
>
>> + (synopsis
>> + "POSIX IPC primitives (semaphores, shared memory and message
>> +queues) for Python")
>
> The things in parenthesis are also mentioned in the description, so I
> think you can drop them to make the synopsis a bit shorter.
>
>> + (description
>> + "The Python extension module posix_ipc gives Python access to
>> +POSIX inter-process semaphores, shared memory and message queues on systems
>> +that support the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993.")
>> + (license license:bsd-3)))
>> --
>> 2.34.0
>
> The rest LGTM!
L
L
Ludovic Courtès wrote on 29 Mar 2022 11:52
control message for bug #53777
(address . control@debbugs.gnu.org)
87fsn12ihj.fsf@gnu.org
tags 53777 + moreinfo
quit
I
I
Ian Ressa wrote on 15 May 2022 05:30
[PATCH v2] gnu: Add python-posix-ipc
(address . 53777@debbugs.gnu.org)(name . Ian Ressa)(address . ian@eonn.xyz)
20220515033053.13824-1-ian@eonn.xyz
Sorry, I really dropped the ball on this one.
This patch is against a newer python-xyz.scm and fixes the issues listed.

---
gnu/packages/python-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 020f078dee..d6486291d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -121,6 +121,7 @@
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Ian Ressa <ian@eonn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31150,3 +31151,28 @@ (define-public python-deepmerge
"The @code{deep-merge} Python library provides a toolset to deeply merge
nested data structures in Python like lists and dictionaries.")
(license license:expat)))
+
+(define-public python-posix-ipc
+ (package
+ (name "python-posix-ipc")
+ (version "1.0.5")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "posix_ipc" version))
+ (sha256
+ (base32 "15wbxf67y17g04i3f3vjw9zjbvlvqqk9q1x0ya1y7apl5k7b3pbc"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'support-cross-compilation
+ (lambda _
+ (substitute* "prober.py"
+ (("cc") ,(cc-for-target))))))))
+ (home-page "https://semanchuk.com/philip/posix_ipc/")
+ (synopsis "POSIX IPC primitives for Python")
+ (description
+ "The Python extension module posix_ipc gives Python access to POSIX
+inter-process semaphores, shared memory and message queues on systems that
+support the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993.")
+ (license license:bsd-3)))
--
2.36.0
V
V
Vagrant Cascadian wrote on 2 Sep 2023 00:32
Re: [bug#53777] [PATCH] add python-posix-ipc
87wmx9r0cj.fsf@wireframe
On 2022-02-04, Ian Ressa wrote:
Toggle quote (2 lines)
> Adding python-posix-ipc to gnu/packages/python-xyz.scm

python-posix-ipc was added in:

b12da85668c40be322204e1ca04fb70b4d709411 gnu: Add python-posix-ipc.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJmfAAKCRDcUY/If5cW
qkZEAQCoNzT9bGsrx3cEvJeNS3sKBQTWdCsoPIXywuH6L8NZrgD+J4CM/tGrXtQO
ruJGJJyUGjRs47aANGNzxYIoUDIX6As=
=l15t
-----END PGP SIGNATURE-----

Closed
?