[PATCH] gnu: Add r-ggside.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mădălin Ionel Patrașcu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 3 years ago
(address . guix-patches@gnu.org)(name . Mădălin Ionel Patrașcu)(address . bi-admin@Guix-Ubuntu18.04)
20220203183803.16376-1-madalinionel.patrascu@mdc-berlin.de
From: Mădălin Ionel Patrașcu <bi-admin@Guix-Ubuntu18.04>

* gnu/packages/cran.scm (r-ggside): New variable.
---
gnu/packages/cran.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 80e2ca9021..c30aa8a0f0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Sandeep Subramanian <sandeepsubramanian94@gmail.com>
;;; Copyright © 2018 Charlie Ritter <chewzeirta@posteo.net>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2018, 2020, 2021 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2020, 2021, 2022 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Laura Lazzati <laura.lazzati.15@gmail.com>
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
@@ -796,6 +796,32 @@ (define-public r-ggpmisc
respecting the grammar of its graphics paradigm.")
(license license:gpl2+)))
+(define-public r-ggside
+ (package
+ (name "r-ggside")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "ggside" version))
+ (sha256
+ (base32
+ "1x505zizv7hf65pxp9j5v92c3bchhxh9dsrkk1m55kwqqnsl5nza"))))
+ (properties `((upstream-name . "ggside")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-glue r-gtable r-rlang r-scales))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=ggside")
+ (synopsis "Side grammar graphics that extends @code{ggplot2}")
+ (description
+ "The grammar of graphics as shown in @code{ggplot2} has provided an
+expressive API for users to build plots. This package @{ggside} extends
+@code{ggplot2} by allowing users to add graphical information about one of the
+main panel's axis using a familiar @code{ggplot2} style API with tidy data.
+This package is particularly useful for visualizing metadata on a discrete
+axis, or summary graphics on a continuous axis such as a boxplot or a density
+distribution.")
+ (license license:expat)))
+
(define-public r-gprofiler
(package
(name "r-gprofiler")
--
2.34.0
Ricardo Wurmus wrote 3 years ago
(address . 53754-done@debbugs.gnu.org)
874k4x4yer.fsf@elephly.net
Pushed it. Thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53754@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53754
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help