[PATCH staging 0/2] gnu: tbb: Fix build on AArch64; update to 2021.5.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Simon South
Owner
unassigned
Submitted by
Simon South
Severity
normal

Debbugs page

Simon South wrote 3 years ago
(address . guix-patches@gnu.org)
cover.1643812145.git.simon@simonsouth.net
These patches

- Allow the tbb package to build on AArch64 by backporting an upstream commit
that prevents one of the test cases from failing on that platform[0], and

- Update tbb itself to 2021.5.0.

On x86-64 the updated package and its 320 dependents build for me without any
new failures: only dealii-openmpi, python-dolfin-adjoint, python-vedo and
shogun fail, as they all do presently on the staging branch.

On AArch64 the updated package now builds fine and I'm in the (lengthy)
process of checking its dependencies, though an unrelated build failure in
ceres-solver and the lack of a Haskell compiler limit how far this will go
anyway.


--
Simon South
simon@simonsouth.net


Simon South (2):
gnu: tbb: Fix test on AArch64.
gnu: tbb: Update to 2021.5.0.

gnu/local.mk | 1 +
.../patches/tbb-fix-test-on-aarch64.patch | 35 +++++++++++++++++++
gnu/packages/tbb.scm | 8 +++--
3 files changed, 42 insertions(+), 2 deletions(-)
create mode 100644 gnu/packages/patches/tbb-fix-test-on-aarch64.patch


base-commit: 1a5302435ff0d2822b823f5a6fe01faa7a85c629
--
2.34.0
Simon South wrote 3 years ago
[PATCH staging 2/2] gnu: tbb: Update to 2021.5.0.
(address . 53724@debbugs.gnu.org)
feacdea9bb5d24670659769db0737794e5487069.1643812145.git.simon@simonsouth.net
* gnu/packages/tbb.scm (tbb): Update to 2021.5.0.
---
gnu/packages/tbb.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index ef92e6db69..e8fbc0f97e 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -31,7 +31,7 @@ (define-module (gnu packages tbb)
(define-public tbb
(package
(name "tbb")
- (version "2021.4.0")
+ (version "2021.5.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -40,7 +40,7 @@ (define-public tbb
(file-name (git-file-name name version))
(sha256
(base32
- "0ih727g802j9lvwkqhw021bk1wb7xlvfgd0vl1i6jng4am1wv7vq"))))
+ "1z0pqzfx63zrmyqdvvkk8vl5dc0i0n5cimdkrypd50ig4d4yi7sc"))
(patches (list
;; Backport an upstream commit that prevents the
;; "test_eh_thread" test failing on AArch64.
--
2.34.0
Simon South wrote 3 years ago
[PATCH staging 1/2] gnu: tbb: Fix test on AArch64.
(address . 53724@debbugs.gnu.org)
2b93c60ffb8c3ced234c023975a8e35f4bd3ba11.1643812145.git.simon@simonsouth.net
* gnu/packages/patches/tbb-fix-test-on-aarch64.patch: New file.
* gnu/local.mk: Add it.
* gnu/packages/tbb.scm (tbb)[source]: Apply it.
---
gnu/local.mk | 1 +
.../patches/tbb-fix-test-on-aarch64.patch | 35 +++++++++++++++++++
gnu/packages/tbb.scm | 4 +++
3 files changed, 40 insertions(+)
create mode 100644 gnu/packages/patches/tbb-fix-test-on-aarch64.patch

Toggle diff (70 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index dceaa53145..ab96d06a34 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1843,6 +1843,7 @@ dist_patch_DATA = \
%D%/packages/patches/tao-fix-parser-types.patch \
%D%/packages/patches/tar-remove-wholesparse-check.patch \
%D%/packages/patches/tar-skip-unreliable-tests.patch \
+ %D%/packages/patches/tbb-fix-test-on-aarch64.patch \
%D%/packages/patches/tcc-boot-0.9.27.patch \
%D%/packages/patches/tclxml-3.2-install.patch \
%D%/packages/patches/tcsh-fix-autotest.patch \
diff --git a/gnu/packages/patches/tbb-fix-test-on-aarch64.patch b/gnu/packages/patches/tbb-fix-test-on-aarch64.patch
new file mode 100644
index 0000000000..3a6003591e
--- /dev/null
+++ b/gnu/packages/patches/tbb-fix-test-on-aarch64.patch
@@ -0,0 +1,35 @@
+From 013035b4e9af39f506e87ae6b755c3363e768d4d Mon Sep 17 00:00:00 2001
+From: Vladislav Shchapov <phprus@gmail.com>
+Date: Thu, 23 Dec 2021 19:17:24 +0500
+Subject: [PATCH] Fix issue #687 (test_eh_thread) (#697)
+
+Signed-off-by: Vladislav Shchapov <phprus@gmail.com>
+---
+ test/tbb/test_eh_thread.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/test/tbb/test_eh_thread.cpp b/test/tbb/test_eh_thread.cpp
+index aa6d764d..af291f48 100644
+--- a/test/tbb/test_eh_thread.cpp
++++ b/test/tbb/test_eh_thread.cpp
+@@ -36,6 +36,7 @@
+ // TODO: enable limitThreads with sanitizer under docker
+ #if TBB_USE_EXCEPTIONS && !_WIN32 && !__ANDROID__
+
++#include <limits.h>
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
+@@ -73,7 +74,8 @@ public:
+ mValid = false;
+ pthread_attr_t attr;
+ // Limit the stack size not to consume all virtual memory on 32 bit platforms.
+- if (pthread_attr_init(&attr) == 0 && pthread_attr_setstacksize(&attr, 100*1024) == 0) {
++ std::size_t stacksize = utils::max(128*1024, PTHREAD_STACK_MIN);
++ if (pthread_attr_init(&attr) == 0 && pthread_attr_setstacksize(&attr, stacksize) == 0) {
+ mValid = pthread_create(&mHandle, &attr, thread_routine, /* arg = */ nullptr) == 0;
+ }
+ }
+--
+2.34.0
+
diff --git a/gnu/packages/tbb.scm b/gnu/packages/tbb.scm
index e5d8394f5f..ef92e6db69 100644
--- a/gnu/packages/tbb.scm
+++ b/gnu/packages/tbb.scm
@@ -41,6 +41,10 @@ (define-public tbb
(sha256
(base32
"0ih727g802j9lvwkqhw021bk1wb7xlvfgd0vl1i6jng4am1wv7vq"))))
+ (patches (list
+ ;; Backport an upstream commit that prevents the
+ ;; "test_eh_thread" test failing on AArch64.
+ (search-patch "tbb-fix-test-on-aarch64.patch")))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DTBB_STRICT=OFF"))) ;; Don't fail on warnings
--
2.34.0
Ludovic Courtès wrote 3 years ago
Re: bug#53724: [PATCH staging 0/2] gnu: tbb: Fix build on AArch64; update to 2021.5.0.
(name . Simon South)(address . simon@simonsouth.net)(address . 53724-done@debbugs.gnu.org)
87h79ekw2q.fsf@gnu.org
Hello,

Simon South <simon@simonsouth.net> skribis:

Toggle quote (16 lines)
> These patches
>
> - Allow the tbb package to build on AArch64 by backporting an upstream commit
> that prevents one of the test cases from failing on that platform[0], and
>
> - Update tbb itself to 2021.5.0.
>
> On x86-64 the updated package and its 320 dependents build for me without any
> new failures: only dealii-openmpi, python-dolfin-adjoint, python-vedo and
> shogun fail, as they all do presently on the staging branch.
>
> On AArch64 the updated package now builds fine and I'm in the (lengthy)
> process of checking its dependencies, though an unrelated build failure in
> ceres-solver and the lack of a Haskell compiler limit how far this will go
> anyway.

Perfect!

Toggle quote (3 lines)
> gnu: tbb: Fix test on AArch64.
> gnu: tbb: Update to 2021.5.0.

It’s slightly above the limit stated in the manual but I thought it
would be reasonable to have it on ‘master’, so I did that.

Thank you!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53724@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53724
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help