[PATCH 1/1] home: services: import i18n module.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jaming
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jaming
Severity
normal
J
J
Jaming wrote on 1 Feb 2022 21:25
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
wurElOHSDi7Ajm9gsAzczB7tKdedfgA8SwfCfwrecUKjUeZCoMoI82OoYiSTHXT9OCjmvuX9Et-zMfaeWy11rzX1x0NtzSzSUKrDVwVKgD0=@protonmail.com
From 713a7002c63ad86c36b03656cdd3ec9e350e7480 Mon Sep 17 00:00:00 2001
From: Justin Martin <jaming@protonmail.com>
Date: Tue, 1 Feb 2022 14:48:35 -0500
Subject: [PATCH 1/1] home: services: import i18n module.

* gnu/home/services.scm (%initialize-gettext): remove setlocale for guile scripts.
(compute-on-first-login-script): add module import for i18n.
(compute-on-change-gexp): add module import for i18n.
---
gnu/home/services.scm | 14 ++++++++------
1 file changed, 8 insertions(+), 6 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index 1c860d7b01..b7ea6f08dd 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -30,6 +30,7 @@ (define-module (gnu home services)
#:use-module (guix discovery)
#:use-module (guix diagnostics)
#:use-module (guix i18n)
+ #:use-module (guix modules)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match)

@@ -282,13 +283,13 @@ (define %initialize-gettext
#~(begin
(bindtextdomain %gettext-domain
(string-append #$guix "/share/locale"))
- (textdomain %gettext-domain)
- (setlocale LC_ALL "")))
+ (textdomain %gettext-domain)))

(define (compute-on-first-login-script _ gexps)
(program-file
"on-first-login"
- #~(begin
+ (with-imported-modules (source-module-closure '((guix i18n)))
+ #~(begin
(use-modules (guix i18n))
#$%initialize-gettext

@@ -309,7 +310,7 @@ (define (compute-on-first-login-script _ gexps)
(display (G_ "XDG_RUNTIME_DIR doesn't exists, on-first-login script
won't execute anything. You can check if xdg runtime directory exists,
XDG_RUNTIME_DIR variable is set to appropriate value and manually execute the
-script by running '$HOME/.guix-home/on-first-login'")))))))
+script by running '$HOME/.guix-home/on-first-login'"))))))))

(define (on-first-login-script-entry on-first-login)
"Return, as a monadic value, an entry for the on-first-login script
@@ -401,7 +402,8 @@ (define home-activation-service-type
;;;

(define (compute-on-change-gexp eval-gexps? pattern-gexp-tuples)
- #~(begin
+ (with-imported-modules (source-module-closure '((guix i18n)))
+ #~(begin
(use-modules (guix i18n))

#$%initialize-gettext
@@ -486,7 +488,7 @@ (define expressions-to-eval
(display (G_ "On-change gexps evaluation finished.\n\n")))
(display "\
On-change gexps won't be evaluated; evaluation has been disabled in the
-service configuration"))))
+service configuration")))))

(define home-run-on-change-service-type
(service-type (name 'home-run-on-change)
--
2.34.0
J
L
L
Ludovic Courtès wrote on 4 Feb 2022 22:50
Re: bug#53711: [PATCH 1/1] home: services: import i18n module.
(name . Jaming)(address . jaming@protonmail.com)(address . 53711-done@debbugs.gnu.org)
87h79emhcx.fsf@gnu.org
Hi,

Jaming <jaming@protonmail.com> skribis:

Toggle quote (9 lines)
>>From 713a7002c63ad86c36b03656cdd3ec9e350e7480 Mon Sep 17 00:00:00 2001
> From: Justin Martin <jaming@protonmail.com>
> Date: Tue, 1 Feb 2022 14:48:35 -0500
> Subject: [PATCH 1/1] home: services: import i18n module.
>
> * gnu/home/services.scm (%initialize-gettext): remove setlocale for guile scripts.
> (compute-on-first-login-script): add module import for i18n.
> (compute-on-change-gexp): add module import for i18n.

I added a “Fixes” line referencing the bug and committed it.

Thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53711@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53711
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch