[PATCH] (neovim): Update to 0.6.1

  • Done
  • quality assurance status badge
Details
3 participants
  • ceephax
  • ???
  • Vagrant Cascadian
Owner
unassigned
Submitted by
ceephax
Severity
normal
C
C
ceephax wrote on 1 Feb 2022 13:46
(address . guix-patches@gnu.org)(name . ceephax)(address . code@ceephax.com)
20220201124623.13839-1-code@ceephax.com
---
gnu/packages/vim.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d5667851a8..2cc75b5047 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -661,7 +661,7 @@ (define-public neovim-syntastic
(define-public neovim
(package
(name "neovim")
- (version "0.4.4")
+ (version "0.6.1")
(source
(origin
(method git-fetch)
@@ -670,7 +670,7 @@ (define-public neovim
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11zyj6jvkwas3n6w1ckj3pk6jf81z1g7ngg4smmwm7c27y2a6f2m"))))
+ (base32 "10p6lg5yv9n6wcwdprwvvi56dfcm4wsj54nm0invyx3mhf7374lx"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((srfi srfi-26)
--
2.35.1
?
(name . ceephax)(address . code@ceephax.com)(address . 53699@debbugs.gnu.org)
OSZP286MB1894835296E4FBD1D4F63EE5A3279@OSZP286MB1894.JPNP286.PROD.OUTLOOK.COM
ceephax <code@ceephax.com> writes:

Toggle quote (15 lines)
> ---
> gnu/packages/vim.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
> index d5667851a8..2cc75b5047 100644
> --- a/gnu/packages/vim.scm
> +++ b/gnu/packages/vim.scm
> @@ -661,7 +661,7 @@ (define-public neovim-syntastic
> (define-public neovim
> (package
> (name "neovim")
> - (version "0.4.4")
> + (version "0.6.1")

Hello, this failed for me with:
REQUIRED PACKAGE NOT FOUND
We could not find development headers for TreeSitter.


Look like we have to get https://issues.guix.gnu.org/49946in first.
V
V
Vagrant Cascadian wrote on 2 Sep 2023 00:23
Re: [bug#53699] [PATCH] (neovim): Update to 0.6.1
8734zxsfbo.fsf@wireframe
On 2022-02-01, ceephax wrote:
Toggle quote (11 lines)
> diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
> index d5667851a8..2cc75b5047 100644
> --- a/gnu/packages/vim.scm
> +++ b/gnu/packages/vim.scm
> @@ -661,7 +661,7 @@ (define-public neovim-syntastic
> (define-public neovim
> (package
> (name "neovim")
> - (version "0.4.4")
> + (version "0.6.1")

neovim has been updated to newer versions:

53b04339fe521f486d3017930a419d5ca8a6cffd gnu: neovim: Update to 0.6.1.
92d05b79e89ffa4635bf5d9eb49da3771c35c5e0 gnu: neovim: Update to 0.9.1.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJkawAKCRDcUY/If5cW
qhE+AQDgrPg+Yvp5EgsZKHm14A0Buw8/bRKgejwg/VwdrTRieAEAqXrF97JzkK5O
d1EH7MuO8eyuH+Y9P+iZ03/jNPC4+AQ=
=nP7b
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53699@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53699
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch