Add ghc-indexed-profunctors

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-10-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7a42a430d0..6af4076b65 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16324,3 +16324,22 @@ (define-public ghc-machines
empowering the machine to run its own monadic effects or delegating that
responsibility to a custom driver.")
(license license:bsd-3)))
+
+(define-public ghc-indexed-profunctors
+ (package
+ (name "ghc-indexed-profunctors")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "indexed-profunctors" version))
+ (sha256
+ (base32 "1cbccbvrx73drr1jf3yyw0rp1mcfv3jc1rvdcby5xxx4ja543fjs"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/indexed-profunctors")
+ (synopsis "Utilities for indexed profunctors")
+ (description
+ "This package contains basic definitions related to indexed profunctors.
+These are primarily intended as internal utilities to support the
+@code{optics} and @code{generic-lens} package families.")
+ (license license:bsd-3)))
--
2.34.0
?