Add ghc-lens-aeson

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-9-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index bf704abe85..7a42a430d0 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -6785,6 +6785,34 @@ (define-public ghc-lens
indexed variants.")
(license license:bsd-3)))
+(define-public ghc-lens-aeson
+ (package
+ (name "ghc-lens-aeson")
+ (version "1.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "lens-aeson" version))
+ (sha256
+ (base32 "05jyn6rn0anhgfmk754gmmpcy5jv3ki213z4v243n9jvdjdlg7ms"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-lens
+ ghc-vector
+ ghc-unordered-containers
+ ghc-attoparsec
+ ghc-aeson
+ ghc-scientific))
+ (arguments
+ `(#:cabal-revision
+ ("1" "0l1hkkpp4blkhmbpswl6lqww6wpfm327f8knq1lskhnisbnfmj2j")))
+ (home-page "http://github.com/lens/lens-aeson/")
+ (synopsis "Law-abiding lenses for aeson")
+ (description "The goal of @code{lens-aeson} is to provide traversals and
+ prisms for the @code{Aeson}library's Value type, while obeying
+the @code{Traversal/Prism} laws.")
+ (license license:expat)))
+
(define-public ghc-lens-family-core
(package
(name "ghc-lens-family-core")
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 53691@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53691
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch