Add ghc-concise

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-7-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d682b8ebe4..c820d5e585 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16230,3 +16230,27 @@ (define-public ghc-monad-time
"@code{MonadTime} type class for monads which carry the notion of
the current time.")
(license license:bsd-3)))
+
+(define-public ghc-concise
+ (package
+ (name "ghc-concise")
+ (version "0.1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "concise" version))
+ (sha256
+ (base32 "09crgc6gjfidlad6263253xx1di6wfhc9awhira21s0z7rddy9sw"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-lens))
+ (native-inputs
+ (list ghc-tasty
+ ghc-tasty-quickcheck
+ ghc-quickcheck
+ ghc-quickcheck-instances))
+ (home-page "https://github.com/frasertweedale/hs-concise")
+ (synopsis "Utilities for Control.Lens.Cons")
+ (description
+ "@code{concise} provides a handful of functions to extend what you
+can do with Control.Lens.Cons.")
+ (license license:bsd-3)))
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 53689@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53689
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch