Add ghc-monad-time

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-6-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a026024c4a..d682b8ebe4 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -16211,3 +16211,22 @@ (define-public ghc-tdigest
line accumulation of rank-based statistics such as quantiles and
trimmed means.")
(license license:bsd-3)))
+
+(define-public ghc-monad-time
+ (package
+ (name "ghc-monad-time")
+ (version "0.3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "monad-time" version))
+ (sha256
+ (base32 "0z30c0k5bqlz86vwajnm6kj26i09zx6dzqwd00z6ba8hqyzm1x0a"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/scrive/monad-time")
+ (synopsis
+ "Type class for monads which carry the notion of the current time.")
+ (description
+ "@code{MonadTime} type class for monads which carry the notion of
+the current time.")
+ (license license:bsd-3)))
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 53688@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53688
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch