Add ghc-pipes-bytestring

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-4-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (30 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 34648b9998..a7e4bffc8e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9720,6 +9720,23 @@ (define-public ghc-pipes-group
@end enumerate\n")
(license license:bsd-3)))
+(define-public ghc-pipes-bytestring
+ (package
+ (name "ghc-pipes-bytestring")
+ (version "2.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "pipes-bytestring" version))
+ (sha256
+ (base32 "0ch7145pv4f56601ysdj5gqqwsh5ag2zh34ydswg62fqi8z8cxvc"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-pipes ghc-pipes-group ghc-pipes-parse ghc-stringsearch))
+ (home-page "http://hackage.haskell.org/package/pipes-bytestring")
+ (synopsis "ByteString support for pipes")
+ (description "This library provides pipes utilities for ByteStrings")
+ (license license:bsd-3)))
+
(define-public ghc-pointedlist
(package
(name "ghc-pointedlist")
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 53686@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53686
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch