Add ghc-pipes-group

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-3-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 6a5f393fbb..34648b9998 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9692,6 +9692,34 @@ (define-public ghc-pipes-parse
@end enumerate\n")
(license license:bsd-3)))
+(define-public ghc-pipes-group
+ (package
+ (name "ghc-pipes-group")
+ (version "1.0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "pipes-group" version))
+ (sha256
+ (base32 "1issfj3syi6lfbcdn3bhlbnlh86s92ldsb04c4ac69xipsgyhwqk"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-free ghc-pipes ghc-pipes-parse))
+ (native-inputs (list ghc-lens-family-core ghc-doctest))
+ (arguments
+ `(#:cabal-revision
+ ("5" "0hkh6s4n1sv83a8fzhryz9l229g9d59sxkh60fcn04jp2431335h")))
+ (home-page "http://hackage.haskell.org/package/pipes-group")
+ (synopsis "Group streams into substreams")
+ (description
+ "@code{pipes-group} uses @code{FreeT} and lenses to group streams into
+sub-streams.
+Notable features include:
+@enumerate
+@item Perfect Streaming: Group elements without collecting them into memory
+@item Lens Support: Use lenses to simplify many common operations
+@end enumerate\n")
+ (license license:bsd-3)))
+
(define-public ghc-pointedlist
(package
(name "ghc-pointedlist")
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 53685@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53685
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch