Add ghc-tdigest

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-1-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a42baebde6..c778340473 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -30,6 +30,7 @@
;;; Copyright © 2020 Christine Lemmer-Webber <cwebber@dustycloud.org>
;;; Copyright © 2021 Alice BRENON <alice.brenon@ens-lyon.fr>
;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 WinterHound <winterhound@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -16084,3 +16085,31 @@ (define-public ghc-singleton-bool
"This package provides Type-level booleans.")
(license license:bsd-3)))
+(define-public ghc-tdigest
+ (package
+ (name "ghc-tdigest")
+ (version "0.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "tdigest" version))
+ (sha256
+ (base32 "1dvkf7cs8dcr13wza5iyq2qgvz75r33mzgfmhdihw62xzxsqb6d3"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-base-compat
+ ghc-reducers
+ ghc-semigroupoids
+ ghc-vector
+ ghc-vector-algorithms))
+ (native-inputs (list ghc-semigroups ghc-tasty ghc-tasty-quickcheck))
+ (arguments
+ `(#:cabal-revision
+ ("2" "0hcsjdd8km8dhydg4npc6mw6yy6bhv4f21zvm8is8h0ci4057asy")))
+ (home-page "https://github.com/phadej/haskell-tdigest#readme")
+ (synopsis "On-line accumulation of rank-based statistics")
+ (description
+ "This package provides a new data structure for accurate on
+line accumulation of rank-based statistics such as quantiles and
+trimmed means.")
+ (license license:bsd-3)))
--
2.34.0
?