Add ghc-pipes-parse

  • Open
  • quality assurance status badge
Details
One participant
  • WinterHound
Owner
unassigned
Submitted by
WinterHound
Severity
normal
W
W
WinterHound wrote on 1 Feb 2022 10:32
(address . guix-patches@gnu.org)(name . WinterHound)(address . winterhound@yandex.com)
20220201093211.6720-2-winterhound@yandex.com
---
gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c778340473..6a5f393fbb 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9667,6 +9667,31 @@ (define-public ghc-pipes
@end itemize")
(license license:bsd-3)))
+(define-public ghc-pipes-parse
+ (package
+ (name "ghc-pipes-parse")
+ (version "3.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "pipes-parse" version))
+ (sha256
+ (base32 "05cd0j1avkzmryf3869hfpvd9xmzbpz4kc65srswx36n06dkz5x3"))))
+ (build-system haskell-build-system)
+ (inputs (list ghc-pipes))
+ (home-page "http://hackage.haskell.org/package/pipes-parse")
+ (synopsis "Parsing infrastructure for the pipes ecosystem")
+ (description
+ "@code{pipes-parse} builds upon the @code{pipes} library to provide
+shared parsing idioms and utilities:
+@enumerate
+@item Leftovers: Save unused input for later consumption.
+@item Leftover propagation: Leftovers are propagated backwards perfectly.
+@item Connect and Resume: Use @code{StateT} to save unused input for later.
+@item Termination Safety: Detect and recover from end of input.
+@end enumerate\n")
+ (license license:bsd-3)))
+
(define-public ghc-pointedlist
(package
(name "ghc-pointedlist")
--
2.34.0
?