[PATCH] gnu: guile-fibers: Add version 1.1.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 3 years ago
(address . guix-patches@gnu.org)
20220201085326.1332-1-mail@cbaines.net
This release looks to break a few packages, so keep using fibers 1.0 to build
things, and provide the new version to allow switching to when packages are
compatible.

* gnu/packages/guile-xyz.scm (guile-fibers-1.1): New variable.
(guile-fibers): Inherit from guile-fibers-1.1.
(guile2.0-fibers): Rename to guile2.2-fibers, and inherit from
guile-fibers-1.1.
---
gnu/packages/guile-xyz.scm | 73 ++++++++++++++++++++++++++------------
1 file changed, 50 insertions(+), 23 deletions(-)

Toggle diff (104 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 38c6def1fc..f35ba43057 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -601,9 +601,55 @@ (define-public guile2.2-dsv
(inputs (list guile-2.2))
(propagated-inputs `(("guile-lib" ,guile2.2-lib)))))
-(define-public guile-fibers
+(define-public guile-fibers-1.1
(package
(name "guile-fibers")
+ (version "1.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/wingo/fibers/releases/download/v"
+ version "/fibers-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lqz39shlhif5fhpyv2wili0yzb0nhf5ciiv7mdqsq0vljirhrm0"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-after 'install 'mode-guile-objects
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; .go files are installed to "lib/guile/X.Y/cache".
+ ;; This phase moves them to "…/site-ccache".
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib/guile"))
+ (old (car (find-files lib "^ccache$"
+ #:directories? #t)))
+ (new (string-append (dirname old)
+ "/site-ccache")))
+ (rename-file old new)
+ #t))))))
+ (native-inputs
+ (list texinfo pkg-config))
+ (inputs
+ (list guile-3.0))
+ (synopsis "Lightweight concurrency facility for Guile")
+ (description
+ "Fibers is a Guile library that implements a a lightweight concurrency
+facility, inspired by systems like Concurrent ML, Go, and Erlang. A fiber is
+like a \"goroutine\" from the Go language: a lightweight thread-like
+abstraction. Systems built with Fibers can scale up to millions of concurrent
+fibers, tens of thousands of concurrent socket connections, and many parallel
+cores. The Fibers library also provides Concurrent ML-like channels for
+communication between fibers.
+
+Note that Fibers makes use of some Guile 2.1/2.2-specific features and
+is not available for Guile 2.0.")
+ (home-page "https://github.com/wingo/fibers")
+ (license license:lgpl3+)))
+
+(define-public guile-fibers
+ (package
+ (inherit guile-fibers-1.1)
(version "1.0.0")
(source (origin
(method url-fetch)
@@ -637,7 +683,6 @@ (define-public guile-fibers
(patches
;; fixes a resource leak that causes crashes in the tests
(search-patches "guile-fibers-destroy-peer-schedulers.patch"))))
- (build-system gnu-build-system)
(arguments
'(;; The code uses 'scm_t_uint64' et al., which are deprecated in 3.0.
#:configure-flags '("CFLAGS=-Wno-error=deprecated-declarations")
@@ -653,29 +698,11 @@ (define-public guile-fibers
(new (string-append (dirname old)
"/site-ccache")))
(rename-file old new)
- #t))))))
- (native-inputs
- (list texinfo pkg-config))
- (inputs
- (list guile-3.0))
- (synopsis "Lightweight concurrency facility for Guile")
- (description
- "Fibers is a Guile library that implements a a lightweight concurrency
-facility, inspired by systems like Concurrent ML, Go, and Erlang. A fiber is
-like a \"goroutine\" from the Go language: a lightweight thread-like
-abstraction. Systems built with Fibers can scale up to millions of concurrent
-fibers, tens of thousands of concurrent socket connections, and many parallel
-cores. The Fibers library also provides Concurrent ML-like channels for
-communication between fibers.
-
-Note that Fibers makes use of some Guile 2.1/2.2-specific features and
-is not available for Guile 2.0.")
- (home-page "https://github.com/wingo/fibers")
- (license license:lgpl3+)))
+ #t))))))))
-(define-public guile2.0-fibers
+(define-public guile2.2-fibers
(package
- (inherit guile-fibers)
+ (inherit guile-fibers-1.1)
(name "guile2.2-fibers")
(inputs (list guile-2.2))))
--
2.34.0
Ludovic Courtès wrote 3 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 53681@debbugs.gnu.org)
87sft2tmwc.fsf@gnu.org
Hi!

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (9 lines)
> This release looks to break a few packages, so keep using fibers 1.0 to build
> things, and provide the new version to allow switching to when packages are
> compatible.
>
> * gnu/packages/guile-xyz.scm (guile-fibers-1.1): New variable.
> (guile-fibers): Inherit from guile-fibers-1.1.
> (guile2.0-fibers): Rename to guile2.2-fibers, and inherit from
> guile-fibers-1.1.

LGTM!

I’m curious to see which ones break with 1.1, though.

Thanks,
Ludo’.
Christopher Baines wrote 3 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 53681-done@debbugs.gnu.org)
87czk5gle3.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (17 lines)
> Hi!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This release looks to break a few packages, so keep using fibers 1.0 to build
>> things, and provide the new version to allow switching to when packages are
>> compatible.
>>
>> * gnu/packages/guile-xyz.scm (guile-fibers-1.1): New variable.
>> (guile-fibers): Inherit from guile-fibers-1.1.
>> (guile2.0-fibers): Rename to guile2.2-fibers, and inherit from
>> guile-fibers-1.1.
>
> LGTM!
>
> I’m curious to see which ones break with 1.1, though.

Great, pushed as 1d07213d235fa097551cc68834db0237327435fb.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmH60LRfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XcHiQ/6A4CMglhrWCa67cn+CDzsZeqFPOJyoJc2
7fLP8gA5omVs26X8u1TBdP34zjV1dAtxY/8MuCVOKtalPuyAoRXwOhewfg+b1dQx
tHgl+rx0I7RA3M43uBa0fymYFSAGKP2dDPZXkcBjolQ6pu+mRFvrundDUxOqBwfn
6/WFuqnv+opCXInqSI/6WKaYtRdVpQ8aPuXqLqtfvtp+U8XRUqwIb/od/jLO32Mk
jmZXETPOFpCuib4CnFSLEdRL8JyAx0JWlLZYhkBUPcaN+k7vg/L2SoabMuU+t8Lt
VKZ/KvGdihbR1+J66zexE1vnLJbCdw8VOt/D44g1VhFTfHWTQQy3ARdlaktzx9Vk
KA3E3vGoNEU0DxMr7GwEq2kIJn86ToaHnkA4kfx18gBGH3rugYOlqokP1VG7urwB
qtn4KBd9ZlczCLxTw7bhRwd7yrIj5jYzQxV67vVWhsyN6GZ891k6eHD/LS62b9vD
bQ/CBR26ysvnyK5qIctCtbruKRiwS5jWhuII13dPlWPudl2Lj4vLtggvz0elmXyt
nuh2dzywCVZ+dgvGFa94KdNUT6OKC48Y+yB45z9XSH5rdULplMD49mV89kZRjz4t
JGaE9lcZeaoaI+ZJtKeil9tz+o9MNC/1v+B3sRlVgFV10DyUJfux9I7cKuaQCEl4
rRaxPEwaNqA=
=ny75
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53681@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53681
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help