[PATCH] gnu: fontmanager: depend on python3

  • Done
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Maxim Cournoyer
  • Ryan Sundberg
Owner
unassigned
Submitted by
Ryan Sundberg
Severity
normal

Debbugs page

Ryan Sundberg wrote 3 years ago
(address . guix-patches@gnu.org)(name . Ryan Sundberg)(address . ryan@arctype.co)
20220201055512.6391-1-ryan@arctype.co
This package requires python3 on the path to sucessfully build:

Program python found: NO
../source/meson.build:45:0: ERROR: python3 not found

* gnu/packages/fontutils.scm (fontmanager)[inputs]: Add python-3
---
gnu/packages/fontutils.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index bc082de3d3..5a92f752d1 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -906,6 +906,7 @@ (define-public fontmanager
("gtk+" ,gtk+)
("json-glib" ,json-glib)
("libsoup" ,libsoup-minimal-2)
+ ("python" ,python-3)
("sqlite" ,sqlite)
("webkitgtk" ,webkitgtk-with-libsoup2)))
(home-page "https://fontmanager.github.io/")
--
2.34.0
Julien Lepiller wrote 3 years ago
794D5F18-6369-4C17-9911-DEF294C6B6D0@lepiller.eu
Hi, I believe I fixed this very issue yesterday. Can you confirm?

Also, when adding a tool that is used during the build, you should use native-inputs instead, or cross-builds will fail.

On February 1, 2022 6:55:12 AM GMT+01:00, Ryan Sundberg via Guix-patches via <guix-patches@gnu.org> wrote:
Toggle quote (28 lines)
>This package requires python3 on the path to sucessfully build:
>
> Program python found: NO
> ../source/meson.build:45:0: ERROR: python3 not found
>
>* gnu/packages/fontutils.scm (fontmanager)[inputs]: Add python-3
>---
> gnu/packages/fontutils.scm | 1 +
> 1 file changed, 1 insertion(+)
>
>diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
>index bc082de3d3..5a92f752d1 100644
>--- a/gnu/packages/fontutils.scm
>+++ b/gnu/packages/fontutils.scm
>@@ -906,6 +906,7 @@ (define-public fontmanager
> ("gtk+" ,gtk+)
> ("json-glib" ,json-glib)
> ("libsoup" ,libsoup-minimal-2)
>+ ("python" ,python-3)
> ("sqlite" ,sqlite)
> ("webkitgtk" ,webkitgtk-with-libsoup2)))
> (home-page "https://fontmanager.github.io/")
>--
>2.34.0
>
>
>
>
Attachment: file
Maxim Cournoyer wrote 3 years ago
Re: bug#53679: [PATCH] gnu: fontmanager: depend on python3
(name . Julien Lepiller)(address . julien@lepiller.eu)
877d9lm0sz.fsf_-_@gmail.com
Hello,

Julien Lepiller <julien@lepiller.eu> writes:

Toggle quote (5 lines)
> Hi, I believe I fixed this very issue yesterday. Can you confirm?
>
> Also, when adding a tool that is used during the build, you should use
> native-inputs instead, or cross-builds will fail.

Works fine for me, after adding gsettings-desktop-schemas as an input in
45d0c82dcc7380e78472dd819981a5025f6157e5 (otherwise I'd get a error due
to a missing schema on my non-GNOME machine).

Closing.

Thanks!

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53679@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53679
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help