John Hamelink wrote 3 years ago
(address . guix-patches@gnu.org)
gnu/packages/elixir.scm (elixir)[arguments]: Keep G-expressions, but use
========================================================================
WHICH instead of SEARCH-INPUT-FILES.
Signed-off-by: John Hamelink <me@johnhame.link>
---
gnu/packages/elixir.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Hi there,
While following a tutorial, I found myself struggling to build
elixir. After discussing on #guix, and looking on the build server for
clues, it seems that the SEARCH-INPUT-FILE change in 3da297997d ("gnu:
elixir: Use G-expressions.") was the culprit. Within the
G-expression, I reverted to the use of WHICH for the "sh" binary,
while leaving the others as they are.
I do not understand the differences between these two functions or why
SEARCH-INPUT-FILE is preferential, so there may be additional caveats I'm not
aware of that SEARCH-INPUT-FILE addresses.
Thanks
John
Toggle diff (15 lines)
diff --git a/gnu/packages/elixir.scm b/gnu/packages/elixir.scm
index 3fb74a56a5..5df50902ce 100644
--- a/gnu/packages/elixir.scm
+++ b/gnu/packages/elixir.scm
@@ -68,7 +68,7 @@ (define-public elixir
(substitute* '("lib/mix/lib/mix/release.ex"
"lib/mix/lib/mix/tasks/release.init.ex")
(("#!/bin/sh")
- (string-append "#!" (search-input-file inputs "sh"))))
+ (string-append "#!" (which "sh"))))
(substitute* "bin/elixir"
(("^ERTS_BIN=$")
(string-append
--
2.35.1
-----BEGIN PGP SIGNATURE-----
iQJFBAEBCgAvFiEE+Yt/N+nvP8wO2AcVFT3f6aVKmkwFAmH3AHQRHG1lQGpvaG5o
YW1lLmxpbmsACgkQFT3f6aVKmkz0Zg//X3fqmssUTlK1YCLNWbtlHVQ33CynHeYJ
O//RHqFOcya5JqliKZelHADW+WE5zsTyUW6IbDqzg4fXFVqPHPJGMHNsIVrSCBKk
w0dgFPgAK955sTi/Iy/iXFujKQ0/qqR0FWn5urGV81VyDAJ6TT6SDi3vndUI3ue8
rV1GRNlHjSzF7wWaj8OFBgn+fFAQ161zpL7hzwZ0OToZlCwkmBpMm+/5NfV5zrCZ
t6kkmZO7SsNHLwe4eyybcF6gfscwYUe5y71Wx1BBvXKMi+Rx8YiV4e2ANBWHITM6
Wvq0YITyt2WuOxk2pwmL22UJiGjRLxs0Gp9lmE4Loa96xhETsTq0APsFM2GqKsWl
C6Xca59ud7GPj3vAbSeTaZlv3LlM013MYxguhTbOt9Oq0vEMNcH2Ikhp90iHvmLf
5guz84JYW3cI2ihF1zRe5vcYinLjhtZXavJbIfRBVoibnmRHo4onjg9/T+ghKolB
JxwF/oF698L9GLR5Q1rk55cVid5TyXakDnRFJF6btgPjf7Ys2GhS7RRG89ozIqWp
i2gp65NCg1+3XBGbV4rZOFuewKYyxyu9g3qTSI9gOknwzQL4r6GmatsBEII0M+Dj
n2VmbrANz9qYmRzxq50eWm/2qGAxBILHhyhEcCI1wtiQBUzj64El4sn4Gpr6cxur
yoBQWT+0NpE=
=XwwH
-----END PGP SIGNATURE-----