kiasoc5 wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
From 5770a42996530e431c5d88f24df296a05f33dffe Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Wed, 26 Jan 2022 22:43:44 -0500
Subject: [PATCH] gnu: httpie: Update to 3.0.2.
* gnu/packages/python-web.scm (httpie): Update to 3.0.2.
---
gnu/packages/python-web.scm | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)
Toggle diff (40 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 406c6cb51b..6a3fc27353 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -741,21 +741,27 @@ (define-public python2-httplib2
(define-public httpie
(package
(name "httpie")
- (version "2.3.0")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "httpie" version))
(sha256
(base32
- "15ngl3yc186gkgqdx8iav9bpj8gxjpzz26y32z92jwyhj4cmfh6m"))))
+ "16ay8mx2v1z3rywsszy055l5k50qjiwyc3pds5wxxzd1n9a79w97"))))
(build-system python-build-system)
(arguments
;; The tests attempt to access external web servers, so we cannot run them.
'(#:tests? #f))
(propagated-inputs
- (list python-colorama python-pygments python-requests
- python-requests-toolbelt))
+ (list python-colorama
+ python-pygments
+ python-requests
+ python-requests-toolbelt
+ python-pysocks
+ python-charset-normalizer
+ python-defusedxml
+ python-multidict))
(home-page "https://httpie.io")
(synopsis "cURL-like tool for humans")
(description
base-commit: 90a41fe388102d448b3f91a070e38a7680d2d568
--
2.35.0