[PATCH 0/2] Add harmony and dependency.

  • Done
  • quality assurance status badge
Details
One participant
  • dannym
Owner
unassigned
Submitted by
dannym
Severity
normal

Debbugs page

dannym wrote 3 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20220125180447.24242-1-dannym@scratchpost.org
From: Danny Milosavljevic <dannym@scratchpost.org>

Danny Milosavljevic (2):
gnu: Add python-librecaptcha.
gnu: Add python-harmony.

gnu/packages/messaging.scm | 45 ++++++++++++++++++++++++++++++++++++++
1 file changed, 45 insertions(+)

--
2.34.0
dannym wrote 3 years ago
[PATCH 1/2] gnu: Add python-librecaptcha.
(address . 53528@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20220125180956.25992-1-dannym@scratchpost.org
From: Danny Milosavljevic <dannym@scratchpost.org>

* gnu/packages/messaging.scm (python-librecaptcha): New variable.
---
gnu/packages/messaging.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (32 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 768642f119..00ce6c69e9 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3263,4 +3263,25 @@ (define-public weechat-wee-slack
for notification of events.")
(license license:expat)))
+(define-public python-librecaptcha
+ (package
+ (name "python-librecaptcha")
+ (version "0.7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taylordotfish/librecaptcha")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0r35ws6vdf31j01kpacvpjplddm254r0cgy0npmhgnfxd5kpjf3s"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-pillow python-requests python-esprima python-pygobject gobject-introspection gtk+))
+ (synopsis "Show CAPTCHA without running proprietary code.")
+ (description "This package shows CAPTCHA without running proprietary code.")
+ (home-page "https://github.com/taylordotfish/librecaptcha")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.34.0
dannym wrote 3 years ago
[PATCH 2/2] gnu: Add python-harmony.
(address . 53528@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20220125180956.25992-2-dannym@scratchpost.org
From: Danny Milosavljevic <dannym@scratchpost.org>

* gnu/packages/messaging.scm (python-harmony): New variable.
---
gnu/packages/messaging.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 00ce6c69e9..c2035cd949 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3284,4 +3284,28 @@ (define-public python-librecaptcha
(home-page "https://github.com/taylordotfish/librecaptcha")
(license license:gpl3+)))
+(define-public python-harmony
+ (package
+ (name "python-harmony")
+ (version "0.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/taylordotfish/harmony.git")
+ (commit version)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1bm9xcnzpnpj6rlhbrnl2abwclzl7ivgh1vb5644y9mnhcs489js"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-tox))
+ (inputs
+ (list python-librecaptcha python-keyring python-requests))
+ (synopsis "Discord account management")
+ (description "This package provides account management tools for
+Discord.")
+ (home-page "https://github.com/taylordotfish/harmony")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.34.0
Danny Milosavljevic wrote 3 years ago
Re: [PATCH 0/2] Add harmony and dependency.
(address . 53528-done@debbugs.gnu.org)
20220225171159.741d4519@scratchpost.org
Pushed python-librecaptcha as commit a751795551b8294bb7e49160a6b5a0720c3ab9b4
and python-harmony as commit ec0404fcc650ddcdd76a41aeee8afb1df72095b4
to master.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAmIY/88ACgkQ5xo1VCww
uqVnhQf+JQPNnEdWuyqJx9MQRdCo3ywvMHcGgDnSQICg1fGr5mmlrZLF1hPj4H3E
l5ue/byFKtuXRr1OZjwfV2rfdetAGnNA4PvrLcbgH2HyjVrVUsUNNS3jZhjN9UiV
5IUwHQlCjNeAKp/3lVdW76/zy+1ueMC8fZWjM6H22zNhaCKtakChACjRO52p8ose
Oyn3oihCyHmF6q8/8gLfE6J5ohttoYOyZSq9E/d3RvPoiMjdGuA9XGJaOFkpBp/N
38jucLBm3fW1B2Jcna2+yKAxcpdDTJqUPE4UUxxrGuzUxXsSgzmWvKfneSIjrkzA
BbAJJ9hHIyk6Tc6vdwTSnaMcioyp4A==
=O9Yo
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53528@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53528
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help