[PATCH] gnu: Add emacs-puni

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Niklas Eklund
Owner
unassigned
Submitted by
Niklas Eklund
Severity
normal
N
N
Niklas Eklund wrote on 25 Jan 2022 17:46
(address . guix-patches@gnu.org)
875yq7pxv4.fsf@posteo.net
Hi,

this patch adds the Emacs puni package.

/Niklas
From db8621385ed0b3b60f24396732dfb94800732822 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Tue, 25 Jan 2022 17:42:48 +0100
Subject: [PATCH] gnu: Add emacs-puni

---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 387f1b93fd..205b6d84c6 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -633,6 +633,29 @@ (define-public emacs-paredit
when typing parentheses directly or commenting out code line by line.")
(license license:gpl3+)))
+(define-public emacs-puni
+ ;; No tagged release upstream
+ (let ((commit "ed4a863460329a3019c286ff382e2ddc0ffdc9d7") (revision "0"))
+ (package
+ (name "emacs-puni")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AmaiKinono/puni")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14lcqf0qdkq2rklx12v12qpgfahz2bpqmnl3bzcz5myawgjjcphd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-with-editor))
+ (home-page "https://github.com/AmaiKinono/puni")
+ (synopsis "Parentheses Universalistic")
+ (description
+ "Structured editing (soft deletion, expression navigating & manipulating) that supports many major modes out of the box.")
+ (license license:gpl3+))))
+
(define-public emacs-project
(package
(name "emacs-project")
--
2.32.0
N
N
Nicolas Goaziou wrote on 25 Jan 2022 18:09
(name . Niklas Eklund)(address . niklas.eklund@posteo.net)(address . 53525@debbugs.gnu.org)
87a6fjbv4d.fsf@nicolasgoaziou.fr
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

Toggle quote (2 lines)
> Subject: [PATCH] gnu: Add emacs-puni

Thank you.

Toggle quote (4 lines)
> +(define-public emacs-puni
> + ;; No tagged release upstream
> + (let ((commit "ed4a863460329a3019c286ff382e2ddc0ffdc9d7") (revision "0"))

Nitpick: could you add a newline character between (commit ...) and
(revision ...)?

Toggle quote (3 lines)
> + (synopsis "Parentheses Universalistic")

This synopsis is not very useful. Could you expound it a bit?
Toggle quote (3 lines)
> + (description
> + "Structured editing (soft deletion, expression navigating & manipulating) that supports many major modes out of the box.")

Description are expected to consist of full sentences. I suggest:

Puni is an Emacs minor mode for structured editing: soft deletion,
expression navigating and manipulating. It supports many major modes
out of the box.

Could you send an updated patch?

Regards,
--
Nicolas Goaziou
N
N
Niklas Eklund wrote on 25 Jan 2022 18:18
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 53525@debbugs.gnu.org)
874k5rlooa.fsf@posteo.net
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (15 lines)
> Hello,
>
> Niklas Eklund <niklas.eklund@posteo.net> writes:
>
>> Subject: [PATCH] gnu: Add emacs-puni
>
> Thank you.
>
>> +(define-public emacs-puni
>> + ;; No tagged release upstream
>> + (let ((commit "ed4a863460329a3019c286ff382e2ddc0ffdc9d7") (revision "0"))
>
> Nitpick: could you add a newline character between (commit ...) and
> (revision ...)?

Oops, how did that end up there, of course!

Toggle quote (5 lines)
>> + (synopsis "Parentheses Universalistic")
>
> This synopsis is not very useful. Could you expound it a bit?

Will give it a go :)

Toggle quote (15 lines)
>> + (description
>> + "Structured editing (soft deletion, expression navigating & manipulating) that supports many major modes out of the box.")
>
> Description are expected to consist of full sentences. I suggest:
>
> Puni is an Emacs minor mode for structured editing: soft deletion,
> expression navigating and manipulating. It supports many major modes
> out of the box.
>
> Could you send an updated patch?
>
> Regards,
> --
> Nicolas Goaziou

Absolutely, thanks for the feedback :)

Here is an updated patch.

Best regards,

Niklas
From 7c1a30a2567d85bd10d6a767358bafa67f8fc610 Mon Sep 17 00:00:00 2001
From: Niklas Eklund <niklas.eklund@posteo.net>
Date: Tue, 25 Jan 2022 17:42:48 +0100
Subject: [PATCH] gnu: Add emacs-puni

---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 387f1b93fd..9d9adbb1e5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -633,6 +633,32 @@ (define-public emacs-paredit
when typing parentheses directly or commenting out code line by line.")
(license license:gpl3+)))
+(define-public emacs-puni
+ ;; No tagged release upstream
+ (let ((commit "ed4a863460329a3019c286ff382e2ddc0ffdc9d7")
+ (revision "0"))
+ (package
+ (name "emacs-puni")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AmaiKinono/puni")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14lcqf0qdkq2rklx12v12qpgfahz2bpqmnl3bzcz5myawgjjcphd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-with-editor))
+ (home-page "https://github.com/AmaiKinono/puni")
+ (synopsis "Emacs minor mode for structured editing")
+ (description
+ "Puni is an Emacs minor mode for structured editing: soft deletion,
+expression navigating and manipulating. It supports many major modes
+out of the box.")
+ (license license:gpl3+))))
+
(define-public emacs-project
(package
(name "emacs-project")
--
2.32.0
N
N
Nicolas Goaziou wrote on 25 Jan 2022 21:53
(name . Niklas Eklund)(address . niklas.eklund@posteo.net)(address . 53525-done@debbugs.gnu.org)
87wnina663.fsf@nicolasgoaziou.fr
Hello,

Niklas Eklund <niklas.eklund@posteo.net> writes:

Toggle quote (2 lines)
> Here is an updated patch.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?