[PATCH 0/3] Fix/Update a couple scheme things

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Oleg Pykhalov
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)
DM5PR03MB3163BA0C9C1C90A7789BC8CFC55C9@DM5PR03MB3163.namprd03.prod.outlook.com
[PATCH 1/3] gnu: scm: Fix build
[PATCH 2/3] gnu: slib: Update to 3b6.
[PATCH 3/3] gnu: jacal: Update to 1c7.
Morgan.J.Smith wrote 3 years ago
[PATCH 1/3] gnu: scm: Fix build
(address . 53433@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB3163FDE651B17850EE27EE5FC55C9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/scheme.scm (scm)[arguments]: Add trailing slashes where needed
---
gnu/packages/scheme.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 639896bb85..abce9a2aae 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -621,7 +621,7 @@ (define-public scm
(replace 'build
(lambda* (#:key inputs outputs #:allow-other-keys)
(setenv "SCHEME_LIBRARY_PATH"
- (search-input-directory inputs "lib/slib"))
+ (string-append (search-input-directory inputs "lib/slib/")))
(invoke "make" "scmlit" "CC=gcc")
(invoke "make" "all")))
(add-after 'install 'post-install
@@ -631,7 +631,7 @@ (define-public scm
(delete-file req)
(format (open req (logior O_WRONLY O_CREAT))
"(define (library-vicinity) ~s)\n"
- (search-input-directory inputs "lib/slib"))
+ (search-input-directory inputs "lib/slib/"))
;; We must generate the slibcat file.
(invoke (string-append out "/bin/scm")
--
2.34.0
Morgan.J.Smith wrote 3 years ago
[PATCH 2/3] gnu: slib: Update to 3b6.
(address . 53433@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB316363CCC274DB30657D8648C55C9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/scheme.scm (slib): Update to 3b6.
---
gnu/packages/scheme.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index abce9a2aae..8aefa2efec 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -560,14 +560,14 @@ (define-public scheme48-rx
(define-public slib
(package
(name "slib")
- (version "3b5")
+ (version "3b6")
(source (origin
(method url-fetch)
(uri (string-append "http://groups.csail.mit.edu/mac/ftpdir/scm/slib-"
version ".zip"))
(sha256
(base32
- "0q0p2d53p8qw2592yknzgy2y1p5a9k7ppjx0cfrbvk6242c4mdpq"))))
+ "137dn2wwwwg0qbifgxfckjhzj4m4820crpg9kziv402l7f2b931f"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; There is no check target.
--
2.34.0
Morgan.J.Smith wrote 3 years ago
[PATCH 3/3] gnu: jacal: Update to 1c7.
(address . 53433@debbugs.gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
DM5PR03MB31637F7A008C1958093CBE20C55C9@DM5PR03MB3163.namprd03.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/maths.scm (jacal): Update to 1c7.
---
gnu/local.mk | 1 -
gnu/packages/maths.scm | 9 +-
gnu/packages/patches/jacal-fix-texinfo.patch | 92 --------------------
3 files changed, 4 insertions(+), 98 deletions(-)
delete mode 100644 gnu/packages/patches/jacal-fix-texinfo.patch

Toggle diff (144 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 26da4fc0a7..7d45129743 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1296,7 +1296,6 @@ dist_patch_DATA = \
%D%/packages/patches/json-c-0.13-CVE-2020-12762.patch \
%D%/packages/patches/json-c-0.12-CVE-2020-12762.patch \
%D%/packages/patches/jsoncpp-pkg-config-version.patch \
- %D%/packages/patches/jacal-fix-texinfo.patch \
%D%/packages/patches/jami-fix-crash-on-quit.patch \
%D%/packages/patches/jamvm-1.5.1-aarch64-support.patch \
%D%/packages/patches/jamvm-1.5.1-armv7-support.patch \
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4dd501a770..9ccfc48644 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5779,15 +5779,14 @@ (define-public reducelcs
(define-public jacal
(package
(name "jacal")
- (version "1c4")
+ (version "1c7")
(source (origin
(method url-fetch)
(uri (string-append
"http://groups.csail.mit.edu/mac/ftpdir/scm/jacal-"
version ".zip"))
- (sha256 (base32
- "055zrn12a1dmy0dqkwrkq3fklbhg3yir6vn0lacp4mvbg8573a3q"))
- (patches (search-patches "jacal-fix-texinfo.patch"))))
+ (sha256
+ (base32 "06a5sx9ikd62bpnd898g3yk818b020b1a27mk7dbfla2zizib4xz"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -5813,7 +5812,7 @@ (define-public jacal
(chmod wrapper #o555))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (invoke "./configure"
+ (invoke "sh" "configure"
(string-append "--prefix="
(assoc-ref outputs "out"))))))))
(inputs (list scm))
diff --git a/gnu/packages/patches/jacal-fix-texinfo.patch b/gnu/packages/patches/jacal-fix-texinfo.patch
deleted file mode 100644
index 83e44a3164..0000000000
--- a/gnu/packages/patches/jacal-fix-texinfo.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-Fix the broken Texinfo in the Jacal package documentation
-
---- jacal/jacal.texi,orig 2017-02-23 20:35:55.303980444 +0100
-+++ jacal/jacal.texi 2017-02-23 20:53:14.539024674 +0100
-@@ -343,7 +343,7 @@
-
- With the standard input grammar, the precedence of @samp{-} as a prefix
- behaves strangely. @code{a^-b*c} becomes @code{a^(-b*c)} while
--@code{@result{a^b*c} (a^b)*c}.
-+@code{a^b*c @result{} (a^b)*c}.
-
- Using @code{divide} to divide a polynomial by an integer does not work.
-
-@@ -675,8 +675,9 @@
- e1: ---------
- a
- @end example
-+@end deffn
-
--@deffnx Command suchthat var exp
-+@deffn Command suchthat var exp
-
- If an expression rather than an equation is given to @code{suchthat}, it
- is as though the equation @code{@var{exp}=0} was given.
-@@ -688,8 +689,9 @@
- e2: ---------
- a
- @end example
-+@end deffn
-
--@deffnx Operator | var exp_or_eqn
-+@deffn Operator | var exp_or_eqn
-
- An alternative infix notation is also available for @code{suchthat}.
-
-@@ -857,8 +859,9 @@
-
- Returns the degree of polynomial or equation @var{poly} in variable
- @var{var}.
-+@end deffn
-
--@deffnx Operator degree poly
-+@deffn Operator degree poly
-
- Returns the total-degree, the degree of its highest degree monomial,
- of polynomial or equation @var{poly}.
-@@ -1016,10 +1019,12 @@
- Returns @var{poly1} reduced with respect to @var{poly2} (or @var{eqn})
- and @var{var}. If @var{poly2} is univariate, the third argument is not
- needed.
-+@end deffn
-
--@deffnx Command mod poly1 n
-+@deffn Command mod poly1 n
- Returns @var{poly1} with all the coefficients taken modulo @var{n}.
--@deffnx Command mod poly1
-+@end deffn
-+@deffn Command mod poly1
- Returns @var{poly1} with all the coefficients taken modulo the
- current modulus.
-
-@@ -1220,8 +1225,9 @@
- e1: -1 2 3 5
- @end group
- @end example
-+@end deffn
-
--@deffnx Command factor polyratio
-+@deffn Command factor polyratio
- Given a univariate ratio of polynomials @var{polyratio}, returns a
- matrix of factors and exponents.
-
-@@ -2028,7 +2034,7 @@
- formed from the pair-wise products of components of the inputs. For
- example, for the input tensors @code{x[a,b]} and @code{y[c]}
- @example
--@result{z:tmult(x,y);} z[a,b,c] = x[a,b]*y[c]
-+z:tmult(x,y); @result{} z[a,b,c] = x[a,b]*y[c]
- @end example
-
- With an additional argument, @code{tmult} will produce the inner product
-@@ -2464,8 +2470,9 @@
- If you do not wish to return to Jacal but really want to terminate the
- session and return to the operating system, then after typing
- @code{qed();}, type @code{(slib:exit)} or use @code{quit}.
-+@end deffn
-
--@deffnx Command quit
-+@deffn Command quit
- Exit directly from Jacal to the operating system. You will not be able
- to continue your Jacal session.
-
--
2.34.0
Oleg Pykhalov wrote 3 years ago
Re: [bug#53433] [PATCH 1/3] gnu: scm: Fix build
(address . Morgan.J.Smith@outlook.com)(address . 53433-done@debbugs.gnu.org)
87czkkuof5.fsf@gmail.com
Hi,

Morgan.J.Smith@outlook.com writes:

Pushed to master with the following change, a copyright for you, and
modified commit message for "gnu: jacal: Update to 1c7." patch.
Toggle snippet (15 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index abce9a2aae..ffe6d1356d 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -621,7 +621,7 @@ (define-public scm
(replace 'build
(lambda* (#:key inputs outputs #:allow-other-keys)
(setenv "SCHEME_LIBRARY_PATH"
- (string-append (search-input-directory inputs "lib/slib/")))
+ (search-input-directory inputs "lib/slib/"))
(invoke "make" "scmlit" "CC=gcc")
(invoke "make" "all")))
(add-after 'install 'post-install

Thanks,
Oleg.
-----BEGIN PGP SIGNATURE-----

iQJIBAEBCgAyFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAmHryd4UHGdvLndpZ3Vz
dEBnbWFpbC5jb20ACgkQFn+OpQAa+px8dBAAknpxGHEdDp2/Wf2wryVRcEsn7u0K
lKzywDoJgk635wiQjWV8Y6fW+o7zk0FQf7G9jp/lXtHSwm2kdyV9/a6bZqYHtpEG
b0ALrRnHe04paUSakKpHH6lGPFe5CDGb4rDyMOixgIpozbldMM0lTEoX+Xyl5RKQ
P8TaeYPmNtEvDQKAflhH9ZaW6M8hmOvV5LX24sYOrYOSxkuW4Wak425XfRhhrR7/
1y2lJ0oDwL3GgmO3Qe+ySG3is2gNlU0vbzmoNhLlnJ6lTZQ/dX2pJ/E7CpnjrHeA
vv/A4UQm3EjfzrGUqAFa7hdfLd4vPa8cLIQu7Va9Qin4Lpgr129rxFzfaxZTL+6H
aLOWMbi42yFBImeAcwHD0No5oDAM/B7z5iKhXeQ2UfADfBLtdPgELQmUzUzz4ak3
GO8NDd0WOX+cfFecPJU6slCmwDTdJ8SVygVRxP6KJ1BrT6CM3dQ0m0kQcyCWgWXj
Od9G7gmaZm2lhkxLy5jwY/YvTJqdN9Eij7AF0Sipwk2auT/cfojntObcHp2TDacG
PhvdwlUEZ/2qon2sXhaesvXxE+K3LRMVk5I4e+oEjY4J8FyjH+6zTM60s1Ex+RDQ
mvJ/wzTsRx5bNzk2H3jHQ3ooXms6Qnn7gv5zeV1yHVpJisDffuLiQibR25FwqRBO
Mbk8wn/IC8Qh43M=
=y9uH
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53433@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53433
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help