nncp: Fails to build (renamed file not found)

  • Open
  • quality assurance status badge
Details
4 participants
  • Alan & Kim Zimmerman
  • Ivan Vilata i Balaguer
  • Sharlatan Hellseher
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Ivan Vilata i Balaguer
Severity
normal
I
I
Ivan Vilata i Balaguer wrote on 21 Jan 2022 21:58
(address . bug-guix@gnu.org)
YesekBHlEHXeIojX@sax.terramar.selidor.net
Hi! When trying to upgrade package `nncp 7.5.0` from Guix commit `404f6953`
to that of commit `4a943cfd`, the build fails showing this error:

```
phase `unpack' succeeded after 0.1 seconds
starting phase `go-unpack'
i/o error: src: No such file or directory
error: in phase 'go-unpack': uncaught exception:
system-error "rename-file" "~A" ("No such file or directory") (2)
phase `go-unpack' failed after 0.0 seconds
Backtrace:
10 (primitive-load "/gnu/store/lm25qs8vcxx69hn1rj47pjypc9m…")
In guix/build/gnu-build-system.scm:
904:2 9 (gnu-build #:source _ #:outputs _ #:inputs _ #:phases . #)
In ice-9/boot-9.scm:
1752:10 8 (with-exception-handler _ _ #:unwind? _ # _)
In srfi/srfi-1.scm:
634:9 7 (for-each #<procedure 7ffff4889300 at guix/build/gnu-b…> …)
In ice-9/boot-9.scm:
1752:10 6 (with-exception-handler _ _ #:unwind? _ # _)
In guix/build/gnu-build-system.scm:
925:23 5 (_)
In ice-9/eval.scm:
619:8 4 (_ #(#(#<directory (guile-user) 7ffff5fdbc80>) "/gnu/…"))
In ice-9/boot-9.scm:
260:13 3 (for-each #<procedure 7ffff490c280 at ice-9/eval.scm:3…> …)
In unknown file:
2 (rename-file "src/vendor/go.cypherpunks.ru/balloon" "..…")
In ice-9/boot-9.scm:
1685:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure rename-file: No such file or directory

Some deprecated features have been used. Set the environment
variable GUILE_WARN_DEPRECATED to "detailed" and rerun the
program to get more information. Set it to "no" to suppress
this message.
```

Looks like some bundled dependency is no longer there? Attaching the whole
`/var/log/guix/drvs/rq/p7xarf62882g2n31mgq3z2g616i5hy-nncp-7.5.0.drv.bz2`.

Thanks a lot!

--
Ivan Vilata i Balaguer -- https://elvil.net/
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEHpvwBPZcchIQr6TuPezBBfXdI4IFAmHrHooACgkQPezBBfXd
I4K0Jw//Vmfu4/WOza+JfUR5Fslxm8xX9ddFhnN4i3pdYT33zrfu2jKsZ3ldX1rq
FW4L27DfLAEbSfPHHKzVxQJLsJh/7WK/7UKONu8KH14ZkV3itODcg6wzpC11m2F/
SFLbMyLXUJhfkP10zgU7VTpC88plVS0KwufgKt01YjPqV63Q6NbgfZxB0iI1Ajbr
fQshRLJlErYg0pg/uihnyVZ4mWCU8kE7avtXGWIq4KufbK7F9L9AANgDw4P3NQqK
w5vMAcyWlLd9xJR43zlA3BJq7aKviMa3DvgzjcuEsal/+KiAJghudGV2vOZqqpkp
wEIp/wofbsoT5JuGdCSWHh9DkreBMnX8V3brRnipXs9bKNysRDt8/UYXeLSu0ZlT
0U0iKxzBXtfQSJjDr2t3oEKhoPVD9oL9phNnI7u5gJcTTCXamqy6MaPk4uNICnnE
8+Pfqzc43UOE0a5rjh8lvRLdjAzjQisdG7piHWh7cdRnFSgD6k/o78OH3mLzI9ZF
ESgtx2Jj+8Xl5HNcVXDzYYlnQIib+FMMDNEemADhFdqq46Mqsga/IY8ftNn2tQp7
YDIUlCsILPNDVKOm5H7tThQ9jl77caouAvFyvEQTEy333LIrJrLM0O6yj/DzCUEV
GGWt/P5Av6RG5c6jwSEGnp/btVqVGiSMpYcAJ3AOzrX3laT5Kgk=
=+SfP
-----END PGP SIGNATURE-----


A
A
Alan & Kim Zimmerman wrote on 24 Jun 2023 13:04
(address . 53423@debbugs.gnu.org)
CANma=H8K+5x2y7+z4d72rueZdCapNQ+kUpiXOHbjtooVB5c5kg@mail.gmail.com
I took a look at this, and the problem seems to be that the cwd ends up
different from before, so all the file operations fail.

It needs (chdir "../nncp-7.5.0") in the 'go-unpack section.

Attached is a patch that does this, if it works via gmail.

Alan
Attachment: file
From f2cc08e9cd657717049936938077a210773ab193 Mon Sep 17 00:00:00 2001
Message-Id: <f2cc08e9cd657717049936938077a210773ab193.1687601540.git.alan.zimm@gmail.com>
From: Alan Zimmerman <alan.zimm@gmail.com>
Date: Fri, 23 Jun 2023 23:57:48 +0100
Subject: [PATCH] nncp: set directory so build succeeds

---
gnu/packages/uucp.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
index e10de59aa2..65e71c1b1a 100644
--- a/gnu/packages/uucp.scm
+++ b/gnu/packages/uucp.scm
@@ -98,6 +98,7 @@ (define-public nncp
(assoc-ref go:%standard-phases 'setup-go-environment))
(add-after 'unpack 'go-unpack
(lambda* (#:key source #:allow-other-keys)
+ (chdir "../nncp-7.5.0")
;; Copy source to GOPATH.
(copy-recursively "src" "../src/go.cypherpunks.ru/nncp/v7")
;; Move bundled dependencies to GOPATH.

base-commit: f25529b08e356f89ca7cecc44295085531a8faba
--
2.40.1
V
V
Vagrant Cascadian wrote on 8 Feb 04:20 +0100
(name . Alan & Kim Zimmerman)(address . alan.zimm@gmail.com)
878r3vprop.fsf@wireframe
On 2023-06-24, Alan & Kim Zimmerman wrote:
Toggle quote (7 lines)
> I took a look at this, and the problem seems to be that the cwd ends up
> different from before, so all the file operations fail.
>
> It needs (chdir "../nncp-7.5.0") in the 'go-unpack section.
>
> Attached is a patch that does this, if it works via gmail.

Thanks for the patch! Miraculously, it still applies after all this
time, and it does allow the build to proceed further, but still fails in
tests:

starting phase `check'
do test
# _/tmp/guix-build-nncp-7.5.0.drv-0/nncp-7.5.0/src/cmd/nncp-cfgdir
cmd/nncp-cfgdir/main.go:91:4: unknown field 'AllowMinusZero' in struct literal of type hjson.EncoderOptions
ok _/tmp/guix-build-nncp-7.5.0.drv-0/nncp-7.5.0/src 37.407s ? _/tmp/guix-build-nncp-7.5.0.drv-0/nncp-7.5.0/src/cmd/nncp-bundle [no test files]
? _/tmp/guix-build-nncp-7.5.0.drv-0/nncp-7.5.0/src/cmd/nncp-call [no test files]
? _/tmp/guix-build-nncp-7.5.0.drv-0/nncp-7.5.0/src/cmd/nncp-caller [no test files]
do: test: got exit code 2
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "contrib/do" arguments: ("-c" "test") exit-status: 1 term-signal: #f stop-signal: #f>
phase `check' failed after 44.5 seconds
command "contrib/do" "-c" "test" failed with status 1

CCed the members of the go team who may have a better idea of, well,
packaging go programs. :)

live well,
vagrant

Toggle quote (26 lines)
> From f2cc08e9cd657717049936938077a210773ab193 Mon Sep 17 00:00:00 2001
> Message-Id: <f2cc08e9cd657717049936938077a210773ab193.1687601540.git.alan.zimm@gmail.com>
> From: Alan Zimmerman <alan.zimm@gmail.com>
> Date: Fri, 23 Jun 2023 23:57:48 +0100
> Subject: [PATCH] nncp: set directory so build succeeds
>
> ---
> gnu/packages/uucp.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/uucp.scm b/gnu/packages/uucp.scm
> index e10de59aa2..65e71c1b1a 100644
> --- a/gnu/packages/uucp.scm
> +++ b/gnu/packages/uucp.scm
> @@ -98,6 +98,7 @@ (define-public nncp
> (assoc-ref go:%standard-phases 'setup-go-environment))
> (add-after 'unpack 'go-unpack
> (lambda* (#:key source #:allow-other-keys)
> + (chdir "../nncp-7.5.0")
> ;; Copy source to GOPATH.
> (copy-recursively "src" "../src/go.cypherpunks.ru/nncp/v7")
> ;; Move bundled dependencies to GOPATH.
>
> base-commit: f25529b08e356f89ca7cecc44295085531a8faba
> --
> 2.40.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZcRIlgAKCRDcUY/If5cW
qreEAQCzA3pmxNoQiItEOH/OpF56+oxiTedGSCUOlDMue+apZgD9HTrSnZHubtVr
qCoyRu4Ky8G6X2e3yJnN2QUpUhOv0QY=
=1oTo
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 8 Feb 04:36 +0100
(name . Alan & Kim Zimmerman)(address . alan.zimm@gmail.com)
875xyzpqy9.fsf@wireframe
On 2024-02-07, Vagrant Cascadian wrote:
Toggle quote (8 lines)
> On 2023-06-24, Alan & Kim Zimmerman wrote:
>> I took a look at this, and the problem seems to be that the cwd ends up
>> different from before, so all the file operations fail.
>>
>> It needs (chdir "../nncp-7.5.0") in the 'go-unpack section.
>>
>> Attached is a patch that does this, if it works via gmail.

FWIW, nncp appears to be quite out of date in guix; might be good
to explore getting current upstream working...

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZcRMTgAKCRDcUY/If5cW
qmebAP4/UMg19gjk/94U+RMrMExnL5Vs0WDLk3MjxY0VE8OUJwD/R+tvXiI8z/i7
DNJV8IaCu1vrt9gJqySbAVd3qGOJFAY=
=0es8
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 8 Feb 12:37 +0100
nncp: Fails to build (renamed file not found)
(address . 53423@debbugs.gnu.org)(name . Vagrant Cascadian)(address . vagrant@debian.org)
87h6ijuqyn.fsf@gmail.com
Hi Vagrant,

Thank you for the ping on this issue.

It was on my radar to update nncp as the package was failed to build for
a long time and quite dated.

It looks like the current version is not compatible with versions of
golang packages available in Guix anymore. I have a chance to bump it to
the 8.0.0 to check if it may fix the build but it did not work any more and
the whole package need proper refactoring.

I'll place upgrading it to my TODO list.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmXEvQAACgkQdtcnv/Ys
0rWPGw/+NhiqHUIZGQ3/0IBFR60ZZoSljA/+M7FkEKkwqlL7j7tEa6yBaAoe9D2/
rR775hNEANq5kCuAhIiHLajQJdRNUlKTRqh9vmTapLvIFSH4A5eo7s6K1uWw+AJd
c0tU8gzm+W6E7wHYZCEZt6pF+IVebhrzFrpvVJ9bsc4HVSihv72Vjy58aay16vJB
0vTOnLWHC+9p+QCk9nzePU8V/BbpTTBtHRg7/KhGIxr9bZSD7qNinbqo0kX/C6az
IO3b5NTi06Y5aLDCWyfE0d4z5JupBmYdCbcB8aHYZSOqHEXePiRur5Uc8HAMrfvt
mCTJoNdxKWQl+HKOZVb4ydfFOgGR5Qlui2BDzkpbNmpSy1ZzPuBEbirXh9njn5+v
udHnFPqiqaF2++305y+Q5X6GIWdhrqz4NKEBTjCZiZKklKtdbZr1Y3dYN2igxA+3
dTb+cpqvgfEwSte9N5rGyd9WBLSsS6zHJeM3I3ft7mS+Uc1m4U0o3Ksm+6wKajNk
c1yMSS9GNgQZtkZ/b63qgH8VrtLT2eE8PLB23zLHhe0Tlb/nW9E7K96bTgWMDL0K
FEtXR+HA4nm6tjGYy69EypdIewX4qxacK257ncRS3P6/zZpDxlKGbwme91FvrxRW
21Od/xAP3Eh5DAStxyhXxP59YtT4PfjS2jLwRY0DUeqjBVPxgVs=
=W+6a
-----END PGP SIGNATURE-----

?