John Kehayias wrote 3 years ago
(name . Guix-patches)(address . guix-patches@gnu.org)
This fixes the tests failing due to change in Meson not propagating python. Same as other fixes, e.g. 65b2b142358f8d38cf993855fcc4ce0b9ef107eb
From 13dedd496eb6f7e944348f4c76831e8cec27af41 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 19 Jan 2022 14:07:13 -0500
Subject: [PATCH] gnu: libratbag: Add python to native inputs.
Since commit 5d20d7e1369fc7d93de19c0bd219937d697ceae6, meson no longer
propagates Python.
* gnu/packages/gnome.scm (libratbag)[native-inputs]: Add python.
---
gnu/packages/gnome.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Toggle diff (15 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ecec55942d..5f09c17112 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12055,7 +12055,7 @@ (define-public libratbag
python-wrap)
#t))))))
(native-inputs
- (list check pkg-config swig valgrind))
+ (list check pkg-config python swig valgrind))
(inputs
`(("glib" ,glib)
("json-glib" ,json-glib)
--
2.34.0