[PATCH 00/28] Cleanup python2 packages in sphinx.scm and python-web.scm

  • Done
  • quality assurance status badge
Details
2 participants
  • Vinicius Monego
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 19 Jan 2022 15:07
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140714.41029-1-monego@posteo.net
Vinicius Monego (28):
gnu: Remove python2-sphinxcontrib-programoutput.
gnu: Remove python2-sphinx-me.
gnu: Remove python2-sphinx-repoze-autointerface.
gnu: Remove python2-sphinx-cloud-sptheme.
gnu: Remove python2-guzzle-sphinx-theme.
gnu: Remove python2-sphinx-rtd-theme.
gnu: Remove python2-html2text.
gnu: Remove python2-html5-parser.
gnu: Remove python2-openid.
gnu: Remove python2-cssutils.
gnu: Remove python2-css-parser.
gnu: Remove python2-cssselect.
gnu: Remove python2-openid-cla.
gnu: Remove python2-openid-teams.
gnu: Remove python2-ndg-httpsclient.
gnu: Remove python2-webtest.
gnu: Remove python2-url.
gnu: Remove python2-betamax-matchers.
gnu: Remove python2-s3transfer.
gnu: Remove python2-htmlmin.
gnu: Remove python2-cssmin.
gnu: Remove python2-elasticsearch.
gnu: Remove python2-publicsuffix.
gnu: Remove python2-publicsuffix2.
gnu: Remove python2-pastescript.
gnu: Remove python2-paste.
gnu: Add python-urlgrabber.
gnu: Remove python2-urlgrabber.

gnu/packages/python-web.scm | 142 ++++++------------------------------
gnu/packages/sphinx.scm | 20 +----
2 files changed, 23 insertions(+), 139 deletions(-)


base-commit: 36f4745dc10e5d0e8b2a62cd2c8439629debae4f
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 01/28] gnu: Remove python2-sphinxcontrib-programoutput.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-1-monego@posteo.net
* gnu/packages/sphinx.scm (python2-sphinxcontrib-programoutput): Remove variable.
---
gnu/packages/sphinx.scm | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index c6c4b572bf..0e6a81d040 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
@@ -406,9 +406,6 @@ commands into documents, helping you to keep your command examples up to date.")
(home-page "https://github.com/NextThought/sphinxcontrib-programoutput")
(license license:bsd-2)))
-(define-public python2-sphinxcontrib-programoutput
- (package-with-python2 python-sphinxcontrib-programoutput))
-
(define-public python-sphinxcontrib-qthelp
(package
(name "python-sphinxcontrib-qthelp")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 02/28] gnu: Remove python2-sphinx-me.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-2-monego@posteo.net
* gnu/packages/sphinx.scm (python2-sphinx-me): Remove variable.
---
gnu/packages/sphinx.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 0e6a81d040..3c319b03de 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -572,9 +572,6 @@ meta data such as the project name, author and version from your project for
use in your Sphinx docs.")
(license license:bsd-2)))
-(define-public python2-sphinx-me
- (package-with-python2 python-sphinx-me))
-
(define-public python-sphinx-repoze-autointerface
(package
(name "python-sphinx-repoze-autointerface")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 03/28] gnu: Remove python2-sphinx-repoze-autointerface.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-3-monego@posteo.net
* gnu/packages/sphinx.scm (python2-sphinx-repoze-autointerface): Remove
variable.
---
gnu/packages/sphinx.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 3c319b03de..0add590db9 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -593,9 +593,6 @@ introspection of @code{zope.interface} instances in code.")
(home-page "https://github.com/repoze/repoze.sphinx.autointerface")
(license license:repoze)))
-(define-public python2-sphinx-repoze-autointerface
- (package-with-python2 python-sphinx-repoze-autointerface))
-
(define-public python-sphinx-prompt
(package
(name "python-sphinx-prompt")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 04/28] gnu: Remove python2-sphinx-cloud-sptheme.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-4-monego@posteo.net
* gnu/packages/sphinx.scm (python2-sphinx-cloud-sptheme): Remove variable.
---
gnu/packages/sphinx.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 0add590db9..0d5bc63f13 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -688,9 +688,6 @@ argparse commands and options")
related extensions.")
(license license:bsd-3)))
-(define-public python2-sphinx-cloud-sptheme
- (package-with-python2 python-sphinx-cloud-sptheme))
-
(define-public python-guzzle-sphinx-theme
(package
(name "python-guzzle-sphinx-theme")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 05/28] gnu: Remove python2-guzzle-sphinx-theme.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-5-monego@posteo.net
* gnu/packages/sphinx.scm (python2-guzzle-sphinx-theme): Remove variable.
---
gnu/packages/sphinx.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 0d5bc63f13..7fa52c064a 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -709,9 +709,6 @@ Sphinx documentation system, used by @uref{http://docs.guzzlephp.org, Guzzle}
and several other projects.")
(license license:expat)))
-(define-public python2-guzzle-sphinx-theme
- (package-with-python2 python-guzzle-sphinx-theme))
-
(define-public python-sphinx-rtd-theme
(package
(name "python-sphinx-rtd-theme")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 06/28] gnu: Remove python2-sphinx-rtd-theme.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-6-monego@posteo.net
* gnu/packages/sphinx.scm (python2-sphinx-rtd-theme): Remove variable.
---
gnu/packages/sphinx.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index 7fa52c064a..19dee877f2 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -729,9 +729,6 @@ and several other projects.")
(description "A theme for Sphinx used by ReadTheDocs.org.")
(license license:expat)))
-(define-public python2-sphinx-rtd-theme
- (package-with-python2 python-sphinx-rtd-theme))
-
(define-public python-breathe
(package
(name "python-breathe")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 08/28] gnu: Remove python2-html5-parser.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-8-monego@posteo.net
* gnu/packages/python-web.scm (python2-html5-parser): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b46e6e0bd1..8f1b16f9f1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1231,9 +1231,6 @@ C, yielding parse times that can be a thirtieth of the html5lib parse times.")
;; indicate ASL2.0, including the LICENSE file for the whole project.
(license (list license:asl2.0 license:gpl3))))
-(define-public python2-html5-parser
- (package-with-python2 python-html5-parser))
-
(define-public python-minio
(package
(name "python-minio")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 07/28] gnu: Remove python2-html2text.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-7-monego@posteo.net
* gnu/packages/python-web.scm (python2-html2text): Remove variable.
---
gnu/packages/python-web.scm | 15 +--------------
1 file changed, 1 insertion(+), 14 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 708528983c..b46e6e0bd1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -37,7 +37,7 @@
;;; Copyright © 2020 Holger Peters <holger.peters@posteo.de>
;;; Copyright © 2020 Noisytoot <noisytoot@gmail.com>
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
-;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
@@ -728,19 +728,6 @@ which is also valid markdown. html2text was originally written by Aaron
Swartz.")
(license license:gpl3+)))
-(define-public python2-html2text
- (let ((base (package-with-python2 python-html2text)))
- (package
- (inherit base)
- ;; This is the last version with support for Python 2.
- (version "2019.8.11")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "html2text" version))
- (sha256
- (base32
- "0ppgjplg06kmv9sj0x8p7acczcq2mcfgk1jdjwm4w5w40b0vj5pm")))))))
-
(define-public python-jose
(package
(name "python-jose")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 09/28] gnu: Remove python2-openid.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-9-monego@posteo.net
* gnu/packages/python-web.scm (python2-openid): Remove variable.
---
gnu/packages/python-web.scm | 23 -----------------------
1 file changed, 23 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8f1b16f9f1..93e1bc31a5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1371,29 +1371,6 @@ is Python’s.")
for clients and servers.")
(license license:asl2.0)))
-(define-public python2-openid
- (package
- (name "python2-openid")
- (version "2.2.5")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "python-openid" version))
- (sha256
- (base32
- "1vvhxlghjan01snfdc4k7ykd80vkyjgizwgg9bncnin8rqz1ricj"))))
- (build-system python-build-system)
- (arguments
- ;; Python 3 support is in `python3-openid`, a separate package.
- `(#:python ,python-2
- ;; Tests aren't initialized correctly.
- #:tests? #f))
- (home-page "https://github.com/openid/python-openid")
- (synopsis "OpenID support for servers and consumers")
- (description "This library provides OpenID authentication for Python, both
-for clients and servers.")
- (license license:asl2.0)))
-
(define-public python-cssutils
(package
(name "python-cssutils")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 10/28] gnu: Remove python2-cssutils.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-10-monego@posteo.net
* gnu/packages/python-web.scm (python2-cssutils): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 93e1bc31a5..5d8c2d8737 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1396,9 +1396,6 @@ Cascading Style Sheets. Currently it provides a DOM only and no rendering
options.")
(license license:lgpl3+)))
-(define-public python2-cssutils
- (package-with-python2 python-cssutils))
-
(define-public python-css-parser
(package
(inherit python-cssutils)
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:08
[PATCH 11/28] gnu: Remove python2-css-parser.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-11-monego@posteo.net
* gnu/packages/python-web.scm (python2-css-parser): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5d8c2d8737..4154701753 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1418,9 +1418,6 @@ It's a fork of cssutils 1.0.2, updated and modified for parsing ebooks, due to
cssutils not receiving updates as of 1.0.2.")
(license license:lgpl3+)))
-(define-public python2-css-parser
- (package-with-python2 python-css-parser))
-
(define-public python-cssselect
(package
(name "python-cssselect")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 12/28] gnu: Remove python2-cssselect.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-12-monego@posteo.net
* gnu/packages/python-web.scm (python2-cssselect): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4154701753..19a9e28c45 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1448,9 +1448,6 @@ them to XPath 1.0 expressions. Such expressions can be used in lxml or
another XPath engine to find the matching elements in an XML or HTML document.")
(license license:bsd-3)))
-(define-public python2-cssselect
- (package-with-python2 python-cssselect))
-
(define-public python-databricks-cli
(package
(name "python-databricks-cli")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 13/28] gnu: Remove python2-openid-cla.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-13-monego@posteo.net
* gnu/packages/python-web.scm (python2-openid-cla): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 19a9e28c45..07fcd513fe 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1501,9 +1501,6 @@ Databricks REST APIs.")
contributor license agreement extension for python-openid.")
(license license:bsd-3)))
-(define-public python2-openid-cla
- (package-with-python2 python-openid-cla))
-
(define-public python-openid-teams
(package
(name "python-openid-teams")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 14/28] gnu: Remove python2-openid-teams.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-14-monego@posteo.net
* gnu/packages/python-web.scm (python2-openid-teams): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 07fcd513fe..b6048bfd32 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1521,9 +1521,6 @@ contributor license agreement extension for python-openid.")
teams extension for python-openid.")
(license license:bsd-3)))
-(define-public python2-openid-teams
- (package-with-python2 python-openid-teams))
-
(define-public python-priority
(package
(name "python-priority")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 15/28] gnu: Remove python2-ndg-httpsclient.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-15-monego@posteo.net
* gnu/packages/python-web.scm (python2-ndg-httpsclient): Remove variable.
---
gnu/packages/python-web.scm | 11 -----------
1 file changed, 11 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b6048bfd32..473be0e785 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2346,17 +2346,6 @@ verification of the SSL peer.")
(home-page "https://github.com/cedadev/ndg_httpsclient/")
(license license:bsd-3)))
-;; python2-openssl requires special care, so package-with-python2 is
-;; insufficient.
-(define-public python2-ndg-httpsclient
- (package/inherit python-ndg-httpsclient
- (name "python2-ndg-httpsclient")
- (arguments
- (substitute-keyword-arguments (package-arguments python-ndg-httpsclient)
- ((#:python _) python-2)))
- (propagated-inputs
- `(("python2-pyopenssl" ,python2-pyopenssl)))))
-
(define-public python-websocket-client
(package
(name "python-websocket-client")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 16/28] gnu: Remove python2-webtest.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-16-monego@posteo.net
* gnu/packages/python-web.scm (python2-webtest): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 473be0e785..79bee975c8 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2871,9 +2871,6 @@ without starting an HTTP server. It supports anything that supports the
minimum of WSGI.")
(license license:expat)))
-(define-public python2-webtest
- (package-with-python2 python-webtest))
-
(define-public python-flask
(package
(name "python-flask")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 17/28] gnu: Remove python2-url.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-17-monego@posteo.net
* gnu/packages/python-web.scm (python2-url): Remove variable.
* gnu/packages/python-web.scm (python2-url)[properties]: Remove field.
---
gnu/packages/python-web.scm | 9 +--------
1 file changed, 1 insertion(+), 8 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 79bee975c8..0a49887b78 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3143,14 +3143,7 @@ provide an easy-to-use Python interface for building OAuth1 and OAuth2 clients."
(home-page "https://github.com/seomoz/url-py")
(synopsis "URL Parsing")
(description "Library for parsing urls.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-url))))))
-
-(define-public python2-url
- (let ((base (package-with-python2 (strip-python2-variant python-url))))
- (package/inherit base
- (propagated-inputs
- `(("python2-publicsuffix" ,python2-publicsuffix))))))
+ (license license:expat)))
(define-public python-cachecontrol
(package
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 18/28] gnu: Remove python2-betamax-matchers.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-18-monego@posteo.net
* gnu/packages/python-web.scm (python2-betamax-matchers): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0a49887b78..e4c01d53d6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3232,9 +3232,6 @@ replay them during future tests. It is designed to work with python-requests.")
Betamax.")
(license license:asl2.0)))
-(define-public python2-betamax-matchers
- (package-with-python2 python-betamax-matchers))
-
(define-public python-betamax-serializers
(package
(name "python-betamax-serializers")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 19/28] gnu: Remove python2-s3transfer.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-19-monego@posteo.net
* gnu/packages/python-web.scm (python2-s3transfer): Remove variable.
* gnu/packages/python-web.scm (python-s3transfer)[properties]: Remove field.
---
gnu/packages/python-web.scm | 10 +---------
1 file changed, 1 insertion(+), 9 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e4c01d53d6..8232c1d5e2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3279,15 +3279,7 @@ Betamax that may possibly end up in the main package.")
(description "S3transfer is a Python library for managing Amazon S3
transfers.")
(home-page "https://github.com/boto/s3transfer")
- (license license:asl2.0)
- (properties `((python2-variant . ,(delay python2-s3transfer))))))
-
-(define-public python2-s3transfer
- (let ((base (package-with-python2 (strip-python2-variant python-s3transfer))))
- (package/inherit base
- (native-inputs
- `(("python2-futures" ,python2-futures)
- ,@(package-native-inputs base))))))
+ (license license:asl2.0)))
(define-public python-slimit
(package
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 20/28] gnu: Remove python2-htmlmin.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-20-monego@posteo.net
* gnu/packages/python-web.scm (python2-htmlmin): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8232c1d5e2..446af4db2e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3485,9 +3485,6 @@ specs from your Flask-Restful projects.")
It comes with safe defaults and easily configurable options.")
(license license:bsd-3)))
-(define-public python2-htmlmin
- (package-with-python2 python-htmlmin))
-
(define-public python-flask-htmlmin
(package
(name "python-flask-htmlmin")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 21/28] gnu: Remove python2-cssmin.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-21-monego@posteo.net
* gnu/packages/python-web.scm (python2-cssmin): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 446af4db2e..bf4e151229 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3659,9 +3659,6 @@ CSS tidy. Also supports URL rewriting in CSS files.")
(description "Python port of the YUI CSS Compressor.")
(license (list license:expat license:bsd-3))))
-(define-public python2-cssmin
- (package-with-python2 python-cssmin))
-
(define-public python-elasticsearch
(package
(name "python-elasticsearch")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 22/28] gnu: Remove python2-elasticsearch.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-22-monego@posteo.net
* gnu/packages/python-web.scm (python2-elasticsearch): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bf4e151229..cb36e0d686 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3683,9 +3683,6 @@ provide common ground for all Elasticsearch-related code in Python; because of
this it tries to be opinion-free and very extendable.")
(license license:expat)))
-(define-public python2-elasticsearch
- (package-with-python2 python-elasticsearch))
-
(define-public python-engineio
(package
(name "python-engineio")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 23/28] gnu: Remove python2-publicsuffix.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-23-monego@posteo.net
* gnu/packages/python-web.scm (python2-publicsuffix): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cb36e0d686..05590be8b1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3869,9 +3869,6 @@ Templates.")
List.")
(license license:expat)))
-(define-public python2-publicsuffix
- (package-with-python2 python-publicsuffix))
-
(define-public python-publicsuffix2
(package
(name "python-publicsuffix2")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 24/28] gnu: Remove python2-publicsuffix2.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-24-monego@posteo.net
* gnu/packages/python-web.scm (python2-publicsuffix2): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 05590be8b1..807394273a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3898,9 +3898,6 @@ List.")
List. Forked from and using the same API as the publicsuffix package.")
(license (list license:expat license:mpl2.0))))
-(define-public python2-publicsuffix2
- (package-with-python2 python-publicsuffix2))
-
(define-public python-werkzeug
(package
(name "python-werkzeug")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 25/28] gnu: Remove python2-pastescript.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-25-monego@posteo.net
* gnu/packages/python-web.scm (python2-pastescript): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 807394273a..d6dc11ccd2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4083,9 +4083,6 @@ variety of features, from launching web applications to bootstrapping project
layouts.")
(license license:expat)))
-(define-public python2-pastescript
- (package-with-python2 python-pastescript))
-
(define-public python2-urlgrabber
(package
(name "python2-urlgrabber")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 26/28] gnu: Remove python2-paste.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-26-monego@posteo.net
* gnu/packages/python-web.scm (python2-paste): Remove variable.
---
gnu/packages/python-web.scm | 3 ---
1 file changed, 3 deletions(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d6dc11ccd2..b29be2dc5a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4047,9 +4047,6 @@ can be nested together to build web applications. Paste's design closely
follows ideas flowing from WSGI (Web Standard Gateway Interface).")
(license license:expat)))
-(define-public python2-paste
- (package-with-python2 python-paste))
-
(define-public python-pastescript
(package
(name "python-pastescript")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 27/28] gnu: Add python-urlgrabber.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-27-monego@posteo.net
* gnu/packages/python-web.scm (python-urlgrabber): New variable.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b29be2dc5a..36c77f35ef 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4080,6 +4080,35 @@ variety of features, from launching web applications to bootstrapping project
layouts.")
(license license:expat)))
+(define-public python-urlgrabber
+ (package
+ (name "python-urlgrabber")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "urlgrabber" version))
+ (sha256
+ (base32 "0fg16zlw49cw7pjq9dhpc5vd35d5zz1mlki55m464qxfmfpzhnh7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" "test/runtests.py")))))))
+ (propagated-inputs
+ (list python-pycurl python-setuptools python-six))
+ (home-page "http://urlgrabber.baseurl.org/") ; no HTTPS
+ (synopsis "High-level cross protocol url-grabber")
+ (description
+ "@code{urlgrabber} is a library that unifies access to files available on
+the web, FTP or locally. It supports HTTP, FTP and file:// protocols, it
+supports features like HTTP keep-alive, reget, throttling and more.")
+ (license license:lgpl2.1+)))
+
(define-public python2-urlgrabber
(package
(name "python2-urlgrabber")
--
2.30.2
V
V
Vinicius Monego wrote on 19 Jan 2022 15:09
[PATCH 28/28] gnu: Remove python2-urlgrabber.
(address . 53364@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
20220119140916.41578-28-monego@posteo.net
* gnu/packages/python-web.scm (python2-urlgrabber): Remove variable.
---
gnu/packages/python-web.scm | 20 --------------------
1 file changed, 20 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 36c77f35ef..502a91a04e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4109,26 +4109,6 @@ the web, FTP or locally. It supports HTTP, FTP and file:// protocols, it
supports features like HTTP keep-alive, reget, throttling and more.")
(license license:lgpl2.1+)))
-(define-public python2-urlgrabber
- (package
- (name "python2-urlgrabber")
- (version "3.10.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "urlgrabber" version))
- (sha256
- (base32 "0w1h7hlsq406bxfy2pn4i9bd003bwl0q9b7p03z3g6yl0d21ddq5"))))
- (build-system python-build-system)
- (arguments `(#:python ,python-2)) ; urlgrabber supports python2 only
- (home-page "http://urlgrabber.baseurl.org")
- (synopsis "High-level cross protocol url-grabber")
- (description "@code{urlgrabber} is Python2 library that unifies access to
-files available on web, FTP or locally. It supports HTTP, FTP and file://
-protocols, it supports features like HTTP keep-alive, reget, throttling and
-more.")
- (license license:lgpl2.1+)))
-
(define-public python-pycares
(package
(name "python-pycares")
--
2.30.2
M
M
Mathieu Othacehe wrote on 20 Jan 2022 14:34
Re: bug#53364: [PATCH 00/28] Cleanup python2 packages in sphinx.scm and python-web.scm
(name . Vinicius Monego)(address . monego@posteo.net)(address . 53364-done@debbugs.gnu.org)
87fspi34zr.fsf_-_@gnu.org
Toggle quote (2 lines)
> * gnu/packages/sphinx.scm (python2-sphinxcontrib-programoutput): Remove variable.

Pushed the whole series.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53364@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53364
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch