[PATCH] gnu: expat: Add replacement for [security fixes].

  • Done
  • quality assurance status badge
Details
One participant
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 16 Jan 2022 01:00
(address . guix-patches@gnu.org)
20220116000004.2398-1-me@tobias.gr
Fixes CVE-2021-45960, CVE-2021-46143, and CVE-2022-22822…22827.

* gnu/packages/xml.scm (expat/fixed): New variable.
(expat)[replacement]: Use it.
---
gnu/packages/xml.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index b89115a051..771c577618 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -119,6 +119,7 @@ (define-public expat
(package
(name "expat")
(version "2.4.1")
+ (replacement expat/fixed)
(source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
(origin
(method url-fetch)
@@ -154,6 +155,23 @@ (define-public expat
things the parser might find in the XML document (like start tags).")
(license license:expat)))
+(define expat/fixed
+ (package
+ (inherit expat)
+ (version "2.4.3")
+ (source (let ((dot->underscore (lambda (c) (if (char=? #\. c) #\_ c))))
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "mirror://sourceforge/expat/expat/"
+ version "/expat-" version ".tar.xz")
+ (string-append
+ "https://github.com/libexpat/libexpat/releases/download/R_"
+ (string-map dot->underscore version)
+ "/expat-" version ".tar.xz")))
+ (sha256
+ (base32
+ "12kp4h40cpyqqpjqaldag0xq4ig1ljzpkzy9i2marc7blnqz3ydi")))))))
+
(define-public libebml
(package
(name "libebml")
--
2.34.0
T
T
Tobias Geerinckx-Rice wrote on 19 Jan 2022 19:08
(address . 53335-done@debbugs.gnu.org)
87h79zwq1o.fsf@nckx
Pushed as 2045852b096131a714409aa0cc4fe17938f60b15.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCYehVIw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15mCYBANMljY2iPUdWQ2JNkqfI6WBBtNJuoSSQvrNp1P2W
9nQlAQD8B7OVKS+r+kRuEDab/V7BvFygbki+5PfzpcUXMA41CQ==
=BXS7
-----END PGP SIGNATURE-----

Closed
?