[PATCH 0/3] deluge: update to 2.0.5

  • Done
  • quality assurance status badge
Details
2 participants
  • Brice Waegeneire
  • Leo Famulari
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 16 Jan 2022 22:35
(address . guix-patches@gnu.org)
20220116213547.5128-1-brice@waegenei.re
In addition to updating deluge and the using the new style this add an
explanation requested by Leo in https://issues.guix.gnu.org/52486#7.

Brice Waegeneire (3):
gnu: deluge: Update to 2.0.5.
gnu: deluge: Adjust style.
gnu: deluge: Add explanation about wrap phase.

gnu/packages/bittorrent.scm | 49 ++++++++++++++++++-------------------
1 file changed, 24 insertions(+), 25 deletions(-)


base-commit: 27914cb4b72142e2cc99172996c83709e9491437
--
2.34.0
B
[PATCH] deluge: update to 2.0.5 (patchs attached)
(address . 53308@debbugs.gnu.org)
73e1-61e5c480-17-7174f300@268230919
I had issue submitting the actual patches for the issue, so this time I'm trying to send them as attachment. I hope it works this time.

--
bricewge ~ 8929 BBC5 73CD 9206 3DDD 979D 3D36 CAA0 116F 0F99
From 6d3b58e2d1b26d957d6d23f15e7a2ca942658f45 Mon Sep 17 00:00:00 2001
From: Brice Waegeneire <brice@waegenei.re>
Date: Sun, 16 Jan 2022 21:57:07 +0100
Subject: [PATCH 2/3] gnu: deluge: Adjust style.

* gnu/packages/bittorrent.scm (deluge)[inputs]: Add bash-minimal.
[propagated-inputs]: Remove lablels.
---
gnu/packages/bittorrent.scm | 34 ++++++++++++++++++----------------
1 file changed, 18 insertions(+), 16 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index e627cf1be6..ca0cc0dc5b 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -45,6 +45,7 @@ (define-module (gnu packages bittorrent)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
@@ -533,23 +534,24 @@ (define-public deluge
(base32
"1n15dzfnz1gvb4cf046yhi404i3gs933qgz0ichna6r1znmh9gf4"))))
(build-system python-build-system)
+ (inputs (list bash-minimal))
(propagated-inputs
- `(("gtk+" ,gtk+)
- ("libtorrent" ,libtorrent-rasterbar)
- ("python-pycairo" ,python-pycairo)
- ("python-chardet" ,python-chardet)
- ("python-dbus" ,python-dbus)
- ("python-mako" ,python-mako)
- ("python-pygobject" ,python-pygobject)
- ("python-pillow" ,python-pillow)
- ("python-pyopenssl" ,python-pyopenssl)
- ("python-pyxdg" ,python-pyxdg)
- ("python-rencode" ,python-rencode)
- ("python-service-identity" ,python-service-identity)
- ("python-setproctitle" ,python-setproctitle)
- ("python-six" ,python-six)
- ("python-twisted" ,python-twisted)
- ("python-zope-interface" ,python-zope-interface)))
+ (list gtk+
+ libtorrent-rasterbar
+ python-pycairo
+ python-chardet
+ python-dbus
+ python-mako
+ python-pygobject
+ python-pillow
+ python-pyopenssl
+ python-pyxdg
+ python-rencode
+ python-service-identity
+ python-setproctitle
+ python-six
+ python-twisted
+ python-zope-interface))
(native-inputs
(list intltool python-wheel
(if (string-prefix? "x86_64-" (%current-system))
--
2.34.0
From fb5e55f909922872f51d93d7b8527888bc54d3e1 Mon Sep 17 00:00:00 2001
From: Brice Waegeneire <brice@waegenei.re>
Date: Sun, 16 Jan 2022 22:23:18 +0100
Subject: [PATCH 3/3] gnu: deluge: Add explanation about wrap phase.

* gnu/packages/bittorrent.scm (deluge)[arguments]: Add comment
explaining the filtering of "librsvg" from the wrapper.
---
gnu/packages/bittorrent.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (16 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index ca0cc0dc5b..59ae6ac2f2 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -568,6 +568,9 @@ (define-public deluge
(add-after 'install 'wrap
(lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ ;; "librsvg" input is only needed at build time and it
+ ;; conflit with the "librsvg" propageted by "gtk+", so we
+ ;; make sure there is no reference to it in the wrapper.
(gi-typelib-path
(string-join (filter
(lambda (x) (not (string-prefix?
--
2.34.0
From 2540268b519156c1bf235d507f5d80adf2f81eb6 Mon Sep 17 00:00:00 2001
From: Brice Waegeneire <brice@waegenei.re>
Date: Sun, 16 Jan 2022 10:58:20 +0100
Subject: [PATCH 1/3] gnu: deluge: Update to 2.0.5.

* gnu/packages/bittorrent.scm (deluge): Update to 2.0.5.
[arguments]: Remove 'fix-gettext-warning' phase.
---
gnu/packages/bittorrent.scm | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index eac66713ea..e627cf1be6 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Josselin Poiret <josselin.poiret@protonmail.ch>
+;;; Copyright © 2022 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -521,7 +522,7 @@ (define-public qbittorrent
(define-public deluge
(package
(name "deluge")
- (version "2.0.3")
+ (version "2.0.5")
(source
(origin
(method url-fetch)
@@ -530,7 +531,7 @@ (define-public deluge
(version-major+minor version) "/deluge-" version ".tar.xz"))
(sha256
(base32
- "14d8kn2pvr1qv8mwqrxmj85jycr73vwfqz12hzag0ararbkfhyky"))))
+ "1n15dzfnz1gvb4cf046yhi404i3gs933qgz0ichna6r1znmh9gf4"))))
(build-system python-build-system)
(propagated-inputs
`(("gtk+" ,gtk+)
@@ -562,13 +563,6 @@ (define-public deluge
`(#:tests? #f
#:phases
(modify-phases %standard-phases
- ;; Remove this phase when upgrading to version 2.0.4 or beyond, as
- ;; the issue is fixed upstream.
- (add-after 'unpack 'fix-gettext-warning
- (lambda _
- (substitute* "deluge/i18n/util.py"
- (("names='ngettext'") "names=['ngettext']"))
- #t))
(add-after 'install 'wrap
(lambda* (#:key native-inputs inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
--
2.34.0
L
L
Leo Famulari wrote on 17 Jan 2022 20:56
(address . brice@waegenei.re)(address . 53308@debbugs.gnu.org)
YeXKCVgIj1aFAvNa@jasmine.lan
On Mon, Jan 17, 2022 at 08:34:18PM +0100, brice@waegenei.re wrote:
Toggle quote (2 lines)
> I had issue submitting the actual patches for the issue, so this time I'm trying to send them as attachment. I hope it works this time.

Thanks, these patches LGTM!
B
B
Brice Waegeneire wrote on 17 Jan 2022 22:54
Re: bug#53308: [PATCH 0/3] deluge: update to 2.0.5
(name . Leo Famulari)(address . leo@famulari.name)(address . 53308-done@debbugs.gnu.org)
878rvet4ee.fsf_-_@waegenei.re
Leo Famulari <leo@famulari.name> writes:

[...]

Toggle quote (2 lines)
> Thanks, these patches LGTM!

Thank you for the review, pushed as 31577d879dd6e9d78e21b842953a804e0bc3fe92.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53308@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53308
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch