[PATCH 0/2] Add rofi ROFI_PLUGIN_PATH search-path and rofi-calc

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Ludovic Courtès
Owner
unassigned
Submitted by
John Kehayias
Severity
normal
J
J
John Kehayias wrote on 15 Jan 2022 00:18
(name . Guix-patches)(address . guix-patches@gnu.org)
0TXkuQadzYQwj-0foNplpHZWW0BgPOtSnJ8rkZVBv41Y9wyWOIk4unT9d9nomiuoVcvoKK_P5JiXVvUNb7gIcJ-ro1jWuisYB8eEKxnbWGM=@protonmail.com
Hello,

My package submission spree continues. This short patch series adds rofi-calc, a plugin for the rofi launcher which allows you to do live calculations in rofi (including things like currency conversions) with qalculate's qalc.

The first patch adds a native-search-path for rofi, for the built-in variable ROFI_PLUGIN_PATH where it will search for plugins (libraries) by default.

The second adds rofi-calc.

I've tested everything builds and runs. Having rofi and rofi-calc installed sets the search-path and you can do 'rofi -show calc' to launch the plugin without needing to do anything else.

Thanks for looking!
John
J
J
John Kehayias wrote on 15 Jan 2022 00:20
[PATCH 1/2] gnu: rofi: Add a search path for plugins.
(name . 53274@debbugs.gnu.org)(address . 53274@debbugs.gnu.org)
hwDiLlvqfI72qMdNFijL9NP7mIgZuNM1lpRWhFNJtUuk3Rj529WFuY00Q5OVMAX1z1HnMNsI1ZGJ8C0uLm7bRPlUi90vnG2w3Bn3JUVe7R0=@protonmail.com
Empty Message
From bae5766b9c3eff33aa6ec069936e919cfe079f19 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 14 Jan 2022 17:28:54 -0500
Subject: [PATCH 1/2] gnu: rofi: Add a search path for plugins.

* gnu/packages/xdisorg.scm (rofi)[native-search-paths]: Add ROFI_PLUGIN_PATH.
---
gnu/packages/xdisorg.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 74a6ea38b8..65cb1c947c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -52,6 +52,7 @@
;;; Copyright © 2021 ikasero <ahmed@ikasero.com>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1718,6 +1719,11 @@ (define-public rofi
xcb-util-cursor
xcb-util-wm
xcb-util-xrm))
+ (native-search-paths
+ ;; This is where rofi will search for plugins by default.
+ (list (search-path-specification
+ (variable "ROFI_PLUGIN_PATH")
+ (files '("lib/rofi")))))
(arguments
`(#:parallel-tests? #f ; fails in some circumstances
#:phases
--
2.34.0
J
J
John Kehayias wrote on 15 Jan 2022 00:22
[PATCH 2/2] gnu: Add rofi-calc.
(name . 53274@debbugs.gnu.org)(address . 53274@debbugs.gnu.org)
xlVPWkluEVPI1CHhWqLfS07-WiMMV0FrTIYDZQXO5G4zKJW0PMsC6d5yWZVJ0SeqaiVEBJttT9eICs4jJD_nCiaI8Q0Xe3TW4KAHMj2Jw-I=@protonmail.com
Empty Message
From b7056b43e96109c907216ca1d17f68f2a1130d59 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Fri, 14 Jan 2022 18:13:08 -0500
Subject: [PATCH 2/2] gnu: Add rofi-calc.

* gnu/packages/xdisorg.scm (rofi-calc): New variable.
---
gnu/packages/xdisorg.scm | 46 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 46 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 65cb1c947c..cb291f4634 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -78,6 +78,7 @@ (define-module (gnu packages xdisorg)
#:use-module (guix build-system python)
#:use-module (guix build-system scons)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix hg-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -1741,6 +1742,51 @@ (define-public rofi
by name.")
(license license:expat)))
+(define-public rofi-calc
+ (package
+ (name "rofi-calc")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/svenstaro/rofi-calc")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1j23xwa6s27wyx6r0yb85cby6dggrcb103nqcfxr5li1mcqrgd9m"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Don't try to install directly to rofi, instead install
+ ;; to lib/rofi to match rofi's search-path ROFI_PLUGIN_PATH.
+ (add-after 'unpack 'patch-plugindir
+ (lambda _
+ (substitute* "Makefile.am"
+ (("plugindir=\\$\\{rofi_PLUGIN_INSTALL_DIR\\}\\/")
+ "plugindir=${libdir}/rofi/"))))
+ (add-after 'unpack 'patch-qalc-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/calc.c"
+ (("\"qalc\"")
+ (string-append "\""
+ (search-input-file inputs "bin/qalc")
+ "\""))))))))
+ (inputs
+ (list cairo libqalculate rofi))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (home-page
+ "https://github.com/svenstaro/rofi-calc")
+ (synopsis "Do live calculations in rofi with qalc")
+ (description
+ "@code{rofi-calc} is a rofi plugin that uses qalculate's @code{qalc} to parse
+natural language input and provide results.")
+ (license license:expat)))
+
(define-public tint2
(package
(name "tint2")
--
2.34.0
L
L
Ludovic Courtès wrote on 23 Jan 2022 23:26
Re: bug#53274: [PATCH 0/2] Add rofi ROFI_PLUGIN_PATH search-path and rofi-calc
(name . John Kehayias)(address . john.kehayias@protonmail.com)(address . 53274-done@debbugs.gnu.org)
87o842xf5t.fsf@gnu.org
Hi John,

John Kehayias <john.kehayias@protonmail.com> skribis:

Toggle quote (6 lines)
> My package submission spree continues. This short patch series adds rofi-calc, a plugin for the rofi launcher which allows you to do live calculations in rofi (including things like currency conversions) with qalculate's qalc.
>
> The first patch adds a native-search-path for rofi, for the built-in variable ROFI_PLUGIN_PATH where it will search for plugins (libraries) by default.
>
> The second adds rofi-calc.

Applied, thanks!

Ludo’.
Closed
?