[PATCH] Update libostree, simplify inputs for flatpak/libostree

  • Done
  • quality assurance status badge
Details
2 participants
  • kiasoc5
  • Mathieu Othacehe
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
MtPggdw--3-2@tutanota.com

From 1d45930b362cac3d7d136bcaa8d5130b985add2c Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Fri, 14 Jan 2022 17:04:06 -0500
Subject: [PATCH 1/2] gnu: libostree: Update to 2022.1.

* gnu/packages/package-management (libostree): Update to 2022.1.
[native-inputs, inputs]: Remove labels
---
gnu/packages/package-management.scm | 36 ++++++++++++++---------------
1 file changed, 18 insertions(+), 18 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index ba5736f851..9e37c44fdd 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1709,7 +1709,7 @@ (define-public msitools
(define-public libostree
(package
(name "libostree")
- (version "2021.6")
+ (version "2022.1")
(source
(origin
(method url-fetch)
@@ -1717,7 +1717,7 @@ (define-public libostree
"https://github.com/ostreedev/ostree/releases/download/v"
(version-major+minor version) "/libostree-" version ".tar.xz"))
(sha256
- (base32 "0cgmnjf4mr4wn4fliq6ncs0q9qwblrlizjfhx57p7m332g5k21p8"))))
+ (base32 "1mfakwm0sjvb1vvl3jhc451yyf723k7c4vv1yqs8law4arw0x823"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -1734,23 +1734,23 @@ (define-public libostree
;; tap-driver.sh: fatal: I/O or internal error
#:tests? #f))
(native-inputs
- `(("attr" ,attr) ; for tests
- ("bison" ,bison)
- ("glib:bin" ,glib "bin") ; for 'glib-mkenums'
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
+ (list attr ; for tests
+ bison
+ `(,glib "bin") ; for 'glib-mkenums'
+ gobject-introspection
+ pkg-config
+ libxslt))
(inputs
- `(("avahi" ,avahi)
- ("docbook-xml" ,docbook-xml-4.2)
- ("docbook-xsl" ,docbook-xsl)
- ("e2fsprogs" ,e2fsprogs)
- ("fuse" ,fuse)
- ("glib" ,glib)
- ("gpgme" ,gpgme)
- ("libarchive" ,libarchive)
- ("libsoup" ,libsoup-minimal-2) ; needs libsoup-2.4
- ("util-linux" ,util-linux)))
+ (list avahi
+ docbook-xml
+ docbook-xsl
+ e2fsprogs
+ fuse
+ glib
+ gpgme
+ libarchive
+ libsoup-minimal-2 ; needs libsoup-2.4
+ util-linux))
(home-page "https://ostree.readthedocs.io/en/latest/")
(synopsis "Operating system and container binary deployment and upgrades")
(description

base-commit: a9e45262465bffae8e9b5c58dca77b18b2962521
--
2.34.1
From 01e12448b31bf54bebc473605ca4b38e179e7730 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Fri, 14 Jan 2022 17:05:19 -0500
Subject: [PATCH 2/2] gnu: flatpak: Simplify inputs.

* gnu/packages/package-management.scm (flatpak)[native-inputs, inputs]: Remove labels.
[arguments]<#:phases>: Edit 'p11-kit-fix to use p11-kit instead of
p11-kit-next.
---
gnu/packages/package-management.scm | 58 ++++++++++++++---------------
1 file changed, 29 insertions(+), 29 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 9e37c44fdd..0cf6344cab 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1808,7 +1808,7 @@ (define-public flatpak
#t))
(add-after 'unpack 'p11-kit-fix
(lambda* (#:key inputs #:allow-other-keys)
- (let ((p11-path (string-append (assoc-ref inputs "p11-kit-next")
+ (let ((p11-path (string-append (assoc-ref inputs "p11-kit")
"/bin/p11-kit")))
(substitute* "session-helper/flatpak-session-helper.c"
(("\"p11-kit\",")
@@ -1824,37 +1824,37 @@ (define-public flatpak
(invoke "make" "check"
"TESTS=tests/test-basic.sh tests/test-config.sh testcommon"))))))
(native-inputs
- `(("bison" ,bison)
- ("dbus" ,dbus) ; for dbus-daemon
- ("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin") ; for glib-mkenums + gdbus-codegen
- ("glibc-utf8-locales" ,glibc-utf8-locales)
- ("gobject-introspection" ,gobject-introspection)
- ("libcap" ,libcap)
- ("pkg-config" ,pkg-config)
- ("python" ,python)
- ("python-pyparsing" ,python-pyparsing)
- ("socat" ,socat)
- ("which" ,which)))
+ (list bison
+ dbus ; for dbus-daemon
+ gettext-minimal
+ `(,glib "bin") ; for glib-mkenums + gdbus-codegen
+ glibc-utf8-locales
+ gobject-introspection
+ libcap
+ pkg-config
+ python
+ python-pyparsing
+ socat
+ which))
(propagated-inputs (list glib-networking gnupg-2.2.32
gsettings-desktop-schemas))
(inputs
- `(("appstream-glib" ,appstream-glib)
- ("bubblewrap" ,bubblewrap)
- ("dconf" ,dconf)
- ("fuse" ,fuse)
- ("gdk-pixbuf" ,gdk-pixbuf)
- ("gpgme" ,gpgme)
- ("json-glib" ,json-glib)
- ("libarchive" ,libarchive)
- ("libostree" ,libostree)
- ("libseccomp" ,libseccomp)
- ("libsoup" ,libsoup-minimal-2)
- ("libxau" ,libxau)
- ("libxml2" ,libxml2)
- ("p11-kit-next" ,p11-kit-next)
- ("util-linux" ,util-linux)
- ("xdg-dbus-proxy" ,xdg-dbus-proxy)))
+ (list appstream-glib
+ bubblewrap
+ dconf
+ fuse
+ gdk-pixbuf
+ gpgme
+ json-glib
+ libarchive
+ libostree
+ libseccomp
+ libsoup-minimal-2
+ libxau
+ libxml2
+ p11-kit-next
+ util-linux
+ xdg-dbus-proxy))
(home-page "https://flatpak.org")
(synopsis "System for building, distributing, and running sandboxed desktop
applications")
--
2.34.1
Mathieu Othacehe wrote 3 years ago
(address . kiasoc5@tutanota.com)(address . 53273-done@debbugs.gnu.org)
877dau34ac.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> - (let ((p11-path (string-append (assoc-ref inputs "p11-kit-next")
> + (let ((p11-path (string-append (assoc-ref inputs "p11-kit")
> "/bin/p11-kit")))

I used search-input-file here to stop relying on labels.

Pushed both patches.

Thanks,

Mathieu
Closed
Mathieu Othacehe wrote 3 years ago
(address . kiasoc5@tutanota.com)(address . 53273-done@debbugs.gnu.org)
875yqe34a5.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> - (let ((p11-path (string-append (assoc-ref inputs "p11-kit-next")
> + (let ((p11-path (string-append (assoc-ref inputs "p11-kit")
> "/bin/p11-kit")))

I used search-input-file here to stop relying on labels.

Pushed both patches.

Thanks,

Mathieu
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53273@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53273
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help