[PATCH] gnu: tree: Remove stddata feature.
(address . guix-patches@gnu.org)(name . Olivier Dion)(address . olivier.dion@polymtl.ca)
* gnu/packages/admin.scm (tree)
[arguments]: Add 'remove-stddata-feature phase after 'unpack phase.
Since version 2.0.0, there's a new feature call `stddata`.
From the ChangeLog:
--------------------------------------------------------------------------------
Output un-indented JSON on file descriptor 3 ("stddata") automatically if file
descriptor 3 is present (currently Linux only.) Maybe switch to BSON.
--------------------------------------------------------------------------------
This feature breaks some UNIX utilities. Fix it by disabling the feature.
---
gnu/packages/admin.scm | 8 ++++++++
1 file changed, 8 insertions(+)
Toggle diff (21 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index f11374a439..3d4909176a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2408,6 +2408,14 @@ (define-public tree
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-stddata-feature
+ (lambda _
+ (substitute* "tree.h"
+ (("# define STDDATA_FILENO 3")
+ ""))
+ (substitute* "tree.c"
+ (("#ifdef __linux__")
+ "#ifdef STDDATA_FILENO"))))
(delete 'configure)) ; No configure script.
#:tests? #f ; No check target.
#:make-flags
--
2.34.0