[PATCH 0/2] gnu: poetry: Fix inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
Tanguy Le Carrour wrote on 13 Jan 2022 10:45
(address . guix-patches@gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20220113094529.2709-1-tanguy@bioneland.org
Dear Guix,

Unfortunately, I messed up Poetry package in my last patch set!


Poetry depends on an outdated version of `python-msgpack`, so I re-added
the `python-msgpack-transitional`.

I tried adding a `python-msgpack-0.5.6` instead, but I ended up with a
Poetry package containing conflicting inputs, for `python-cachecontrol`
was depending on a more recent version of `python-msgpack`.

This issue has been reported upstream as mentioned in the second patch.

Again, sorry for the mess!


Tanguy Le Carrour (2):
Revert "gnu: Remove python-msgpack-transitional."
gnu: poetry: Fix inputs.

gnu/packages/python-xyz.scm | 38 ++++++++++++++++++++++++++++++++++++-
1 file changed, 37 insertions(+), 1 deletion(-)

--
2.34.0
T
T
Tanguy Le Carrour wrote on 13 Jan 2022 10:50
[PATCH 1/2] Revert "gnu: Remove python-msgpack-transitional."
(address . 53228@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20220113095034.3849-1-tanguy@bioneland.org
This reverts commit d5ae6739fdb4786c49d33de3fec9872c73d2e311.
---
gnu/packages/python-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e53ba67cdc..66ec26d142 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10923,6 +10923,40 @@ (define-public python-msgpack
(home-page "https://pypi.org/project/msgpack/")
(license license:asl2.0)))
+;; This msgpack library's name changed from "python-msgpack" to "msgpack" with
+;; release 0.5. Some packages like borg still call it by the old name for now.
+;; <https://bugs.gnu.org/30662>
+(define-public python-msgpack-transitional
+ (package
+ (inherit python-msgpack)
+ (name "python-msgpack-transitional")
+ (version "0.5.6")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "msgpack" version))
+ (sha256
+ (base32
+ "1hz2dba1nvvn52afg34liijsm7kn65cmn06dl0xbwld6bb4cis0f"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python-msgpack)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'configure-transitional
+ (lambda _
+ ;; Keep using the old name.
+ (substitute* "setup.py"
+ (("TRANSITIONAL = False")
+ "TRANSITIONAL = 1"))
+ ;; This old version is not compatible with Python 3.9
+ (substitute* '("test/test_buffer.py" "test/test_extension.py")
+ ((".tostring\\(") ".tobytes("))
+ (substitute* '("test/test_buffer.py" "test/test_extension.py")
+ ((".fromstring\\(") ".frombytes("))
+ #t))))))))
+
+(define-public python2-msgpack
+ (package-with-python2 python-msgpack))
+
(define-public python-netaddr
(package
(name "python-netaddr")
--
2.34.0
T
T
Tanguy Le Carrour wrote on 13 Jan 2022 10:50
[PATCH 2/2] gnu: poetry: Fix inputs.
(address . 53228@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20220113095034.3849-2-tanguy@bioneland.org
* gnu/packages/python-xyz.scm (poetry)[propagated-inputs]: Replace python-msgpack with python-msgpack-transitional.
---
gnu/packages/python-xyz.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66ec26d142..0091165d37 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16119,7 +16119,9 @@ (define-public poetry
python-entrypoints
python-html5lib
python-keyring
- python-msgpack
+ ; Use of deprecated version of msgpack reported upstream:
+ ; https://github.com/python-poetry/poetry/issues/3607
+ python-msgpack-transitional
python-packaging
python-pexpect
python-pip
--
2.34.0
L
L
Leo Famulari wrote on 13 Jan 2022 20:05
Re: [bug#53228] [PATCH 0/2] gnu: poetry: Fix inputs.
(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)(address . 53228-done@debbugs.gnu.org)
YeB3+JyLVYQH+fPM@jasmine.lan
On Thu, Jan 13, 2022 at 10:45:29AM +0100, Tanguy Le Carrour wrote:
Toggle quote (15 lines)
> Dear Guix,
>
> Unfortunately, I messed up Poetry package in my last patch set!
>
> https://debbugs.gnu.org/cgi/bugreport.cgi?bug=53054
>
> Poetry depends on an outdated version of `python-msgpack`, so I re-added
> the `python-msgpack-transitional`.
>
> I tried adding a `python-msgpack-0.5.6` instead, but I ended up with a
> Poetry package containing conflicting inputs, for `python-cachecontrol`
> was depending on a more recent version of `python-msgpack`.
>
> This issue has been reported upstream as mentioned in the second patch.

Thanks for taking care of this.

Toggle quote (4 lines)
> Tanguy Le Carrour (2):
> Revert "gnu: Remove python-msgpack-transitional."
> gnu: poetry: Fix inputs.

I tweaked the commit messages and pushed as
391f22fa3e34ac0ef0c31a422ccfb49c92f744ac
Closed
T
T
Tanguy LE CARROUR wrote on 14 Jan 2022 08:53
(name . Leo Famulari)(address . leo@famulari.name)(address . 53228-done@debbugs.gnu.org)
164214683882.3761.1920972822638126850@localhost
Hi Leo,


Quoting Leo Famulari (2022-01-13 20:05:28)
Toggle quote (18 lines)
> On Thu, Jan 13, 2022 at 10:45:29AM +0100, Tanguy Le Carrour wrote:
> > Dear Guix,
> >
> > Unfortunately, I messed up Poetry package in my last patch set!
> >
> > https://debbugs.gnu.org/cgi/bugreport.cgi?bug=53054
> >
> > Poetry depends on an outdated version of `python-msgpack`, so I re-added
> > the `python-msgpack-transitional`.
> >
> > I tried adding a `python-msgpack-0.5.6` instead, but I ended up with a
> > Poetry package containing conflicting inputs, for `python-cachecontrol`
> > was depending on a more recent version of `python-msgpack`.
> >
> > This issue has been reported upstream as mentioned in the second patch.
>
> Thanks for taking care of this.

Thanks!


--
Tanguy
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53228@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53228
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch