Python-matplotlib under aarch64 broken

  • Done
  • quality assurance status badge
Details
2 participants
  • Cayetano Santos
  • Cayetano Santos
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal
C
C
Cayetano Santos wrote on 12 Jan 2022 16:43
(address . bug-guix@gnu.org)
m15yqpt0ra.fsf@l2it.in2p3.fr
Hello,

When I do a

guix build python-matplotlib

under aarch64 I get the error below during the testing phase.

Note that

guix describe -f channels

gives

(list (channel
(name 'guix)
(branch "master")
(commit
"c7ef7a0f84bd19ef32e4cc5439ee4f332921eeb9")
(introduction
(make-channel-introduction
"9edb3f66fd807b096b48283debdcddccfea34bad"
(openpgp-fingerprint
"BBB0 2DDF 2CEA F6A8 0D1D E643 A2A0 6DF2 A33A
54FA")))))

Thanks,

C.


=================================== FAILURES
===================================
_________________________ test_warn_big_data_best_loc
__________________________

def test_warn_big_data_best_loc():
fig, ax = plt.subplots()
fig.canvas.draw() # So that we can call draw_artist
later.
for idx in range(1000):
ax.plot(np.arange(5000), label=idx)
with rc_context({'legend.loc': 'best'}):
legend = ax.legend()
with pytest.warns(UserWarning) as records:
Toggle quote (2 lines)
> fig.draw_artist(legend) # Don't bother drawing the
> lines -- it's slow.
E Failed: DID NOT WARN. No warnings of type (<class
'UserWarning'>,) was emitted. The list of emitted warnings is: [].

/gnu/store/fqlbc7ny3kf5hqwpq46wxnvf5223prxi-python-matplotlib-3.4.3/lib/python3.9/site-packages/matplotlib/tests/test_legend.py:677:
Failed
=========================== short test summary info
============================
FAILED test_legend.py::test_warn_big_data_best_loc - Failed: DID
NOT WARN. No...
==== 1 failed, 4905 passed, 2293 skipped, 1 deselected, 9 xfailed
in 53.61s ====
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "python" arguments:
("tests.py" "-v" "-m" "not network and not webagg") exit-status:
1 term-signal: #f stop-signal: #f>
phase `check' failed after 54.4 seconds
command "python" "tests.py" "-v" "-m" "not network and not webagg"
failed with status 1
builder for
`/gnu/store/6mf4z42cdg64kpzzhx9a1sjps3vhirrb-python-matplotlib-3.4.3.drv'
failed with exit code 1
C
C
Cayetano Santos wrote on 12 Dec 2023 17:38
Fixed
(address . 53211-done@debbugs.gnu.org)
87le9z2x5i.fsf@inventati.org

Closed
?