guix/ui.scm:203 requires guile-3.0.3

DoneSubmitted by Efraim Flashner.
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Severity
normal
E
E
Efraim Flashner wrote on 10 Jan 12:37 +0100
(address . bug-guix@gnu.org)
YdwalHGdP7UYnVyz@3900XT
I'm using ./pre-inst-env on my powerpc-linux machine, using guile-3.0.2
as provided by Debian. When I try to run the following command:
./pre-inst-env guix build -L /path/to/repo -m /path/to/manifest.scm -n
I get the following error:

guix/ui.scm:230:13: error: default-optimization-level: unbound variable

It doesn't make sense to gate this with (target-ppc32?) since it's due
to the guile version. If I had configured within 'guix shell -D guix' I
would be using guile-3.0.7.

configure.ac checks for guile 3.0.


(ins)efraim@g4:~$ apt-cache policy guile-3.0
guile-3.0:
Installed: 3.0.2-2be32
Candidate: 3.0.2-2be32
Version table:
*** 3.0.2-2be32 500
500 http://deb.debian.org/debian-portssid/main powerpc Packages
100 /var/lib/dpkg/status


--
Efraim Flashner <efraim@flashner.co.il> רנשלפ םירפא
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmHcGpQACgkQQarn3Mo9
g1GieRAAwtMiEzyjh3Vd06i/RK+hm8dZTv+6WAbJSmx7xw9+fNdHhe7WTtdp5irQ
mEGrWHZ1AkaDYLzR8m8nmE22CJXwYiGZox+hZBqZgJUOqbCxJ8wwIrpOhfGq4ay4
KKZXuDWgrzBWDalhNdzzf/QJDqpAtLZjziTpqzgI1yrlaZwlo8IoNf3YgQ74cxZk
dYy2wHkPLdrTsKLT7YgVRMXB05YrDmN7UCqxuxNB24o4dm3onUY6JxIzXZJ7u1XP
+WLNWZkf+vEW8j3+oclU89cg1OTOKEw/4Z+F5HzcUr9d5w+wYCRQSeec7P54+pRG
Qoc23Li6Saf9BXxe5C9htjD4F88z/ady8uAYCKNi8KVmIF9qIMdXm5bBOP4JYsjT
fieozXxbEa6I+gm9XshgoJ+LxqKs0mWrgsSdbHGjekF0ljIQeVBOlr11LI4HZrbn
wQimeWDQhU0FQmb5Jn5y5rf3HyrFpgz5ouZhnkHnLiARkcEzGehqF5MR/QK1Ti0k
dyxrcl43RmwibuYfocAjb9hIWrSTNCF6dVJANAzjBBdfYam7ScC6MiX1LOTjwWer
C0B5vaeR8aKQv+cK1HIDw/Zxl5m1RzLtZjsjSPVpufO6EjS2rRFZcyZGUkdCfWRt
BRKKSf2gJVwK9ZfRJFnyPey8BX4C43qHZY46Us2SOSFeHsnpvEU=
=nWoj
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 11 Jan 11:14 +0100
(address . bug-guix@gnu.org)
871r1ey3yi.fsf@gnu.org
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (13 lines)
> I'm using ./pre-inst-env on my powerpc-linux machine, using guile-3.0.2
> as provided by Debian. When I try to run the following command:
> ./pre-inst-env guix build -L /path/to/repo -m /path/to/manifest.scm -n
> I get the following error:
>
> guix/ui.scm:230:13: error: default-optimization-level: unbound variable
>
> It doesn't make sense to gate this with (target-ppc32?) since it's due
> to the guile version. If I had configured within 'guix shell -D guix' I
> would be using guile-3.0.7.
>
> configure.ac checks for guile 3.0.

I’m in favor of updating ‘configure.ac’ to check for Guile > 3.0.x
(we’ll have to check which value of ‘x’ works).

But…

Toggle quote (5 lines)
> (ins)efraim@g4:~$ apt-cache policy guile-3.0
> guile-3.0:
> Installed: 3.0.2-2be32
> Candidate: 3.0.2-2be32

… are you saying that requiring > 3.0.2 would cause problems when
porting to other architectures?

In general, we shouldn’t be tied to what Debian provides, but we can see
how much of a problem that would cause. If it really is a problem, we
can adjust that one reference to ‘default-optimization-level’ in (guix
ui).

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 25 Jan 23:58 +0100
87sftbjud1.fsf@gnu.org
Hi Efraim,

Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (18 lines)
> Efraim Flashner <efraim@flashner.co.il> skribis:
>
>> I'm using ./pre-inst-env on my powerpc-linux machine, using guile-3.0.2
>> as provided by Debian. When I try to run the following command:
>> ./pre-inst-env guix build -L /path/to/repo -m /path/to/manifest.scm -n
>> I get the following error:
>>
>> guix/ui.scm:230:13: error: default-optimization-level: unbound variable
>>
>> It doesn't make sense to gate this with (target-ppc32?) since it's due
>> to the guile version. If I had configured within 'guix shell -D guix' I
>> would be using guile-3.0.7.
>>
>> configure.ac checks for guile 3.0.
>
> I’m in favor of updating ‘configure.ac’ to check for Guile > 3.0.x
> (we’ll have to check which value of ‘x’ works).

As you suggested on IRC, I went ahead and did that in commit
d582b399781f6fd80c63d07746524196603972e4.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send email to 53157@debbugs.gnu.org