kiasoc5 wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
Unfortunately some tests fail because of missing locales, I've attached the test log. Help is appreciated.
From 83cd691bc4875373e84a1b4b77ffa25cf85e9136 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Wed, 5 Jan 2022 02:18:15 -0500
Subject: [PATCH] gnu: bubblewrap: Update to 0.5.0.
* gnu/packages/virtualization.scm (bubblewrap): Update to 0.5.0.
---
gnu/packages/virtualization.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (26 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 6a40955dbb..71c7178c6d 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1927,7 +1927,7 @@ (define-public python-vagrant
(define-public bubblewrap
(package
(name "bubblewrap")
- (version "0.4.1")
+ (version "0.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/containers/bubblewrap/"
@@ -1935,7 +1935,7 @@ (define-public bubblewrap
version ".tar.xz"))
(sha256
(base32
- "00ycgi6q2yngh06bnz50wkvar6r2jnjf3j158grhi9k13jdrpimr"))))
+ "0608l2sjwhnb1c0mslah1h6yjvqr17wk60by6i710qwxg4rszz8n"))))
(build-system gnu-build-system)
(arguments
`(#:phases
base-commit: 8860e9db560c5d9e74277b608071fbb93579db4f
--
2.34.1
========================================
bubblewrap 0.5.0: ./test-suite.log
========================================
# TOTAL: 25
# PASS: 19
# SKIP: 0
# XFAIL: 0
# FAIL: 0
# XPASS: 0
# ERROR: 6
.. contents:: :depth: 2
ERROR: tests/test-run.sh
========================
+++ dirname ./tests/test-run.sh
++ cd ./tests
++ pwd
+ srcd=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
+ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest.sh
++ set -e
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_srcdir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_builddir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest-core.sh
+++ type -p locale
++++ locale -a
++++ grep -iEe '^(C|en_US)\.(UTF-8|utf8)$'
++++ head -n1
++++ true
+++ export LC_ALL=
+++ LC_ALL=
+++ '[' -z '' ']'
+++ fatal 'Can'\''t find suitable UTF-8 locale'
+++ echo 'Can'\''t' find suitable UTF-8 locale
Can't find suitable UTF-8 locale
+++ exit 1
ERROR: tests/test-run.sh - missing test plan
ERROR: tests/test-run.sh - exited with status 1
ERROR: tests/test-specifying-userns.sh
======================================
+++ dirname ./tests/test-specifying-userns.sh
++ cd ./tests
++ pwd
+ srcd=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
+ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest.sh
++ set -e
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_srcdir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_builddir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest-core.sh
+++ type -p locale
++++ locale -a
++++ grep -iEe '^(C|en_US)\.(UTF-8|utf8)$'
++++ head -n1
++++ true
+++ export LC_ALL=
+++ LC_ALL=
+++ '[' -z '' ']'
+++ fatal 'Can'\''t find suitable UTF-8 locale'
+++ echo 'Can'\''t' find suitable UTF-8 locale
Can't find suitable UTF-8 locale
+++ exit 1
ERROR: tests/test-specifying-userns.sh - missing test plan
ERROR: tests/test-specifying-userns.sh - exited with status 1
ERROR: tests/test-specifying-pidns.sh
=====================================
+++ dirname ./tests/test-specifying-pidns.sh
++ cd ./tests
++ pwd
+ srcd=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
+ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest.sh
++ set -e
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_srcdir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_builddir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest-core.sh
+++ type -p locale
++++ locale -a
++++ grep -iEe '^(C|en_US)\.(UTF-8|utf8)$'
++++ head -n1
++++ true
+++ export LC_ALL=
+++ LC_ALL=
+++ '[' -z '' ']'
+++ fatal 'Can'\''t find suitable UTF-8 locale'
+++ echo 'Can'\''t' find suitable UTF-8 locale
Can't find suitable UTF-8 locale
+++ exit 1
ERROR: tests/test-specifying-pidns.sh - missing test plan
ERROR: tests/test-specifying-pidns.sh - exited with status 1