[PATCH] gnu: bubblewrap: Update to 0.5.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Josselin Poiret
  • kiasoc5
  • Ludovic Courtès
Owner
unassigned
Submitted by
kiasoc5
Severity
normal

Debbugs page

kiasoc5 wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
MsgRpG_--3-2@tutanota.com
Unfortunately some tests fail because of missing locales, I've attached the test log. Help is appreciated.
From 83cd691bc4875373e84a1b4b77ffa25cf85e9136 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Wed, 5 Jan 2022 02:18:15 -0500
Subject: [PATCH] gnu: bubblewrap: Update to 0.5.0.

* gnu/packages/virtualization.scm (bubblewrap): Update to 0.5.0.
---
gnu/packages/virtualization.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 6a40955dbb..71c7178c6d 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1927,7 +1927,7 @@ (define-public python-vagrant
(define-public bubblewrap
(package
(name "bubblewrap")
- (version "0.4.1")
+ (version "0.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/containers/bubblewrap/"
@@ -1935,7 +1935,7 @@ (define-public bubblewrap
version ".tar.xz"))
(sha256
(base32
- "00ycgi6q2yngh06bnz50wkvar6r2jnjf3j158grhi9k13jdrpimr"))))
+ "0608l2sjwhnb1c0mslah1h6yjvqr17wk60by6i710qwxg4rszz8n"))))
(build-system gnu-build-system)
(arguments
`(#:phases

base-commit: 8860e9db560c5d9e74277b608071fbb93579db4f
--
2.34.1
========================================
bubblewrap 0.5.0: ./test-suite.log
========================================

# TOTAL: 25
# PASS: 19
# SKIP: 0
# XFAIL: 0
# FAIL: 0
# XPASS: 0
# ERROR: 6

.. contents:: :depth: 2

ERROR: tests/test-run.sh
========================

+++ dirname ./tests/test-run.sh
++ cd ./tests
++ pwd
+ srcd=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
+ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest.sh
++ set -e
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_srcdir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_builddir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest-core.sh
+++ type -p locale
++++ locale -a
++++ grep -iEe '^(C|en_US)\.(UTF-8|utf8)$'
++++ head -n1
++++ true
+++ export LC_ALL=
+++ LC_ALL=
+++ '[' -z '' ']'
+++ fatal 'Can'\''t find suitable UTF-8 locale'
+++ echo 'Can'\''t' find suitable UTF-8 locale
Can't find suitable UTF-8 locale
+++ exit 1
ERROR: tests/test-run.sh - missing test plan
ERROR: tests/test-run.sh - exited with status 1

ERROR: tests/test-specifying-userns.sh
======================================

+++ dirname ./tests/test-specifying-userns.sh
++ cd ./tests
++ pwd
+ srcd=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
+ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest.sh
++ set -e
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_srcdir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_builddir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest-core.sh
+++ type -p locale
++++ locale -a
++++ grep -iEe '^(C|en_US)\.(UTF-8|utf8)$'
++++ head -n1
++++ true
+++ export LC_ALL=
+++ LC_ALL=
+++ '[' -z '' ']'
+++ fatal 'Can'\''t find suitable UTF-8 locale'
+++ echo 'Can'\''t' find suitable UTF-8 locale
Can't find suitable UTF-8 locale
+++ exit 1
ERROR: tests/test-specifying-userns.sh - missing test plan
ERROR: tests/test-specifying-userns.sh - exited with status 1

ERROR: tests/test-specifying-pidns.sh
=====================================

+++ dirname ./tests/test-specifying-pidns.sh
++ cd ./tests
++ pwd
+ srcd=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
+ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest.sh
++ set -e
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_srcdir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
++ test_builddir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
++ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest-core.sh
+++ type -p locale
++++ locale -a
++++ grep -iEe '^(C|en_US)\.(UTF-8|utf8)$'
++++ head -n1
++++ true
+++ export LC_ALL=
+++ LC_ALL=
+++ '[' -z '' ']'
+++ fatal 'Can'\''t find suitable UTF-8 locale'
+++ echo 'Can'\''t' find suitable UTF-8 locale
Can't find suitable UTF-8 locale
+++ exit 1
ERROR: tests/test-specifying-pidns.sh - missing test plan
ERROR: tests/test-specifying-pidns.sh - exited with status 1
Ludovic Courtès wrote 3 years ago
(address . kiasoc5@tutanota.com)(address . 53040@debbugs.gnu.org)
87a6g41svn.fsf@gnu.org
Hi,

kiasoc5@tutanota.com skribis:

Toggle quote (18 lines)
> ERROR: tests/test-specifying-pidns.sh
> =====================================
>
> +++ dirname ./tests/test-specifying-pidns.sh
> ++ cd ./tests
> ++ pwd
> + srcd=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
> + . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest.sh
> ++ set -e
> ++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
> ++ test_srcdir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
> ++ '[' -n /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0 ']'
> ++ test_builddir=/tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests
> ++ . /tmp/guix-build-bubblewrap-0.5.0.drv-0/bubblewrap-0.5.0/tests/libtest-core.sh
> +++ type -p locale
> ++++ locale -a
> ++++ grep -iEe '^(C|en_US)\.(UTF-8|utf8)$'

The ‘en_US.utf8’ locale is available; however, the ‘locale -a’ command
won’t list it, for obscure reasons.

I suggest patching libtest-core.sh so that it unconditionally uses
en_US.utf8 instead of running ‘locale -a’.

HTH!

Ludo’.
kiasoc5 wrote 3 years ago
Re: [PATCH] gnu: bubblewrap: Update to 0.5.0.
(name . Guix Patches)(address . guix-patches@gnu.org)(address . ludo@gnu.org)
Mt4VcpI--3-2@tutanota.com
Fixed locale in tests, thanks Ludo for the suggestion via email. Also fixed more test substitutions and simplified inputs.
Ludovic Courtès wrote 3 years ago
Re: bug#53040: [PATCH] gnu: bubblewrap: Update to 0.5.0.
(address . kiasoc5@tutanota.com)(address . 53040@debbugs.gnu.org)
87iluqtb11.fsf_-_@gnu.org
Hi,

kiasoc5@tutanota.com skribis:

Toggle quote (15 lines)
> Fixed locale in tests, thanks Ludo for the suggestion via email. Also fixed more test substitutions and simplified inputs.
>
>>From f5c56100d62d315c3ed860898998a7c8afc78d50 Mon Sep 17 00:00:00 2001
> From: kiasoc5 <kiasoc5@tutanota.com>
> Date: Mon, 10 Jan 2022 17:58:35 -0500
> Subject: [PATCH] gnu: bubblewrap: Update to 0.5.0.
>
> * gnu/packages/patches/bubblewrap-fix-locale-in-tests.patch: Add it.
> * gnu/local.mk (dist_patch_DATA): Add it.
> * gnu/packages/virtualization.scm (bubblewrap): Update to 0.5.0.
> [source]: Add patch.
> [arguments]: Adjust test substitutions.
> [inputs]: Remove labels.
> [native-inputs]: Remove labels.

That LGTM. I tested direct dependents as shown by:

./pre-inst-env guix graph -M1 -t reverse-package bubblewrap | xdot -f fdp -

Unfortunately, the update breaks flatpak (both 1.12.1 and 1.12.2):

Toggle snippet (18 lines)
make[3]: Nothing to be done for 'tests/org.flatpak.Authenticator.test.service.in'.
rm -rf tests/runtime-repo
PATH=/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2:${PATH} ./tests/make-test-runtime.sh tests/runtime-repo org.test.Platform master "" ""
guix
error: Writing content object: min-free-space-percent '3%' would be exceeded, at least 36.9 kB requested
make[3]: *** [Makefile:7804: tests/runtime-repo] Error 1
make[3]: Leaving directory '/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2'
make[2]: *** [Makefile:7063: check-am] Error 2
make[2]: Leaving directory '/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2'
make[1]: *** [Makefile:6255: check-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2'
make: *** [Makefile:7067: check] Error 2
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("check" "TESTS=tests/test-basic.sh tests/test-config.sh testcommon") exit-status: 2 term-signal: #f stop-signal: #f>
phase `check' failed after 17.2 seconds
command "make" "check" "TESTS=tests/test-basic.sh tests/test-config.sh testcommon" failed with status 2

Could you take a look?

Apologies for the extra work!

Thanks,
Ludo’.
kiasoc5 wrote 3 years ago
MtA4ks9--B-2@tutanota.com
I rebased the patch onto today's Guix commits, and Flatpak 1.12.1 and 1.12.2 passes the tests on my machine. But I'm currently running Guix on Arch and don't have a Guix system available to test further.

All dependent packages except wpewebkit build successfully. wpewebkit build log complains during cmake configuration that a required package is not found, but it seems unrelated to bubblewrap, and it won't build on master anyways.

Jan 11, 2022, 17:52 by ludo@gnu.org:

Toggle quote (53 lines)
> Hi,
>
> kiasoc5@tutanota.com skribis:
>
>> Fixed locale in tests, thanks Ludo for the suggestion via email. Also fixed more test substitutions and simplified inputs.
>>
> >>From f5c56100d62d315c3ed860898998a7c8afc78d50 Mon Sep 17 00:00:00 2001
>
>> From: kiasoc5 <kiasoc5@tutanota.com>
>> Date: Mon, 10 Jan 2022 17:58:35 -0500
>> Subject: [PATCH] gnu: bubblewrap: Update to 0.5.0.
>>
>> * gnu/packages/patches/bubblewrap-fix-locale-in-tests.patch: Add it.
>> * gnu/local.mk (dist_patch_DATA): Add it.
>> * gnu/packages/virtualization.scm (bubblewrap): Update to 0.5.0.
>> [source]: Add patch.
>> [arguments]: Adjust test substitutions.
>> [inputs]: Remove labels.
>> [native-inputs]: Remove labels.
>>
>
> That LGTM. I tested direct dependents as shown by:
>
> ./pre-inst-env guix graph -M1 -t reverse-package bubblewrap | xdot -f fdp -
>
> Unfortunately, the update breaks flatpak (both 1.12.1 and 1.12.2):
>
> --8<---------------cut here---------------start------------->8---
> make[3]: Nothing to be done for 'tests/org.flatpak.Authenticator.test.service.in'.
> rm -rf tests/runtime-repo
> PATH=/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2:${PATH} ./tests/make-test-runtime.sh tests/runtime-repo org.test.Platform master "" ""
> guix
> error: Writing content object: min-free-space-percent '3%' would be exceeded, at least 36.9 kB requested
> make[3]: *** [Makefile:7804: tests/runtime-repo] Error 1
> make[3]: Leaving directory '/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2'
> make[2]: *** [Makefile:7063: check-am] Error 2
> make[2]: Leaving directory '/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2'
> make[1]: *** [Makefile:6255: check-recursive] Error 1
> make[1]: Leaving directory '/tmp/guix-build-flatpak-1.12.2.drv-0/flatpak-1.12.2'
> make: *** [Makefile:7067: check] Error 2
> error: in phase 'check': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("check" "TESTS=tests/test-basic.sh tests/test-config.sh testcommon") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `check' failed after 17.2 seconds
> command "make" "check" "TESTS=tests/test-basic.sh tests/test-config.sh testcommon" failed with status 2
> --8<---------------cut here---------------end--------------->8---
>
> Could you take a look?
>
> Apologies for the extra work!
>
> Thanks,
> Ludo’.
>
Josselin Poiret wrote 3 years ago
Re: [bug#53040] [PATCH] gnu: bubblewrap: Update to 0.5.0.
(address . 53040@debbugs.gnu.org)
87wnj4aos2.fsf@jpoiret.xyz
Hello Ludovic and kiasoc5,

Ludovic Courtès <ludo@gnu.org> writes:
Toggle quote (6 lines)
> The ‘en_US.utf8’ locale is available; however, the ‘locale -a’ command
> won’t list it, for obscure reasons.
>
> I suggest patching libtest-core.sh so that it unconditionally uses
> en_US.utf8 instead of running ‘locale -a’.

I am a bit late to the party, but the official locale name is
en_US.UTF-8. utf8 is not a registered IANA name. UTF-8 is converted to
utf8 by glibc internally, but I remember having issues when I had
mistakenly set LC_ALL to en_US.utf8 in the past, so better be safe than
sorry.

--
Josselin Poiret
Ludovic Courtès wrote 3 years ago
Re: bug#53040: [PATCH] gnu: bubblewrap: Update to 0.5.0.
(address . kiasoc5@tutanota.com)(address . 53040-done@debbugs.gnu.org)
87a6fz7132.fsf_-_@gnu.org
Hi,

kiasoc5@tutanota.com skribis:

Toggle quote (2 lines)
> I rebased the patch onto today's Guix commits, and Flatpak 1.12.1 and 1.12.2 passes the tests on my machine. But I'm currently running Guix on Arch and don't have a Guix system available to test further.

Indeed, I tried on a newer machine and it went fine (the one I was
building on previously is really old and I suspect an odd
hardware-related issue.)

Toggle quote (2 lines)
> All dependent packages except wpewebkit build successfully. wpewebkit build log complains during cmake configuration that a required package is not found, but it seems unrelated to bubblewrap, and it won't build on master anyways.

Noted.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53040@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53040
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help