[PATCH] gnu: syncthing-gtk: Fix autostart.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Kehayias
  • Leo Famulari
Owner
unassigned
Submitted by
John Kehayias
Severity
normal

Debbugs page

John Kehayias wrote 3 years ago
(name . Guix-patches)(address . guix-patches@gnu.org)
10YAD-y_pZJkNBM4uVrklp03YiJtBVRcxPqDLGaJJ8R5PSHg6p21iH8A6NjoKR7uxnPCRUA9ELWS1MPYRoOo3v1nylz0VJfG6J3mF6AwZE8=@protonmail.com
Hello,

This is a simple fix/workaround for https://issues.guix.gnu.org/50789

As discussed there, there is not a perfect solution for syncthing-gtk writing ~/.config/autostart/Syncthing-GTK.desktop with the Exec line pointing to the store path of ".syncthing-gtk-real". I've opted for a simple fix that won't break upon changes to the syncthing-gtk store path that was done similarly to e.g. the desktop files Flatpak writes in 9c4244cc73db4d5c3adf6f8342f6b08b39dd3628: just use plain "syncthing-gtk". While this means different syncthing-gtk could conflict (whatever is first in PATH wins), that seems unlikely given this package is just a frontend to syncthing. Anyway, seems like the best option right now so that the autostart file is usable and won't break.

Thanks,
John
From 1d62676b2b507f67103110c3fce5d8c6dc483f8b Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Wed, 5 Jan 2022 14:09:42 -0500
Subject: [PATCH] gnu: syncthing-gtk: Fix autostart.

* gnu/packages/syncthing.scm (syncthing-gtk)[#:phases]: Add autostart-path
phase to use "syncthing-gtk" (rather than a store path to
".syncthing-gtk-real") as the exec command for the autostart desktop file
written by syncthing-gtk.
---
gnu/packages/syncthing.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 7125e70117..f356b24844 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -171,6 +172,13 @@ (define-public syncthing-gtk
(substitute* "syncthing_gtk/configuration.py"
(("/usr/bin/syncthing") (string-append syncthing
"/bin/syncthing"))))))
+ (add-after 'unpack 'autostart-path
+ ;; Change the autostart desktop file Exec command to just be
+ ;; syncthing-gtk, rather than the store path to
+ ;; .syncthing-gtk-real
+ (lambda _
+ (substitute* "syncthing_gtk/tools.py"
+ (("return executable") "return \"syncthing-gtk\""))))
(add-after 'unpack 'remove-windows.py
(lambda _
;; A Windows-specific module that fails to load with
--
2.34.1
Leo Famulari wrote 3 years ago
(name . John Kehayias via Guix-patches via)(address . guix-patches@gnu.org)(address . 53036-done@debbugs.gnu.org)
YdYJ3LxdBjPVw/F8@jasmine.lan
On Wed, Jan 05, 2022 at 07:20:14PM +0000, John Kehayias via Guix-patches via wrote:
Toggle quote (10 lines)
> From 1d62676b2b507f67103110c3fce5d8c6dc483f8b Mon Sep 17 00:00:00 2001
> From: John Kehayias <john.kehayias@protonmail.com>
> Date: Wed, 5 Jan 2022 14:09:42 -0500
> Subject: [PATCH] gnu: syncthing-gtk: Fix autostart.
>
> * gnu/packages/syncthing.scm (syncthing-gtk)[#:phases]: Add autostart-path
> phase to use "syncthing-gtk" (rather than a store path to
> ".syncthing-gtk-real") as the exec command for the autostart desktop file
> written by syncthing-gtk.

Thanks! I pushed as c37559e81979232feee07aa1eb39faacb093c5ca with the
following changes:

1) I renamed the phase to 'fix-autostart-path'. It's not very important
but typically build phases are named imperatively.

2) I rewrote the commit message and code comment to be more clear about
what the change does. I found it a bit confusing and had to reread the
previous discussion to remind myself. Hopefully this is an improvement.

Thanks again for taking care of this package!
?
Your comment

This issue is archived.

To comment on this conversation send an email to 53036@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 53036
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help