(address . guix-patches@gnu.org)(name . Manolis Ragkousis)(address . manolis837@gmail.com)
From: Manolis Ragkousis <manolis837@gmail.com>
* gnu/packages/networking.scm (arp-scan): New variable.
---
gnu/packages/networking.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cc9cc61164..ac67d58541 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -47,6 +47,7 @@
;;; Copyright © 2021 Milkey Mouse <milkeymouse@meme.institute>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4143,3 +4144,32 @@ (define-public putty
implementations.")
(home-page "https://www.chiark.greenend.org.uk/~sgtatham/putty/")
(license license:expat)))
+
+(define-public arp-scan
+ (package
+ (name "arp-scan")
+ (version "1.9.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/royhills/arp-scan/"
+ "archive/refs/tags/" version ".tar.gz"))
+ (sha256
+ (base32 "0ff0c43rw1b4cm52rx7s6q0wsix3ahjjfhd8wk85nr9wjgj3cg70"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "autoreconf" "-vfi"))))))
+ (inputs
+ (list libpcap))
+ (native-inputs
+ (list autoconf automake libtool pkg-config))
+ (propagated-inputs
+ (list perl-libwww))
+ (home-page "https://github.com/royhills/arp-scan")
+ (synopsis "Dscover and fingerprint IP hosts on the local network using ARP")
+ (description "A tool that uses ARP to discover and fingerprint IP hosts on the local network")
+ (license license:gpl3)))
--
2.33.1