[PATCH] gnu: Add yadm.

  • Open
  • quality assurance status badge
Details
One participant
  • Disseminate Dissent
Owner
unassigned
Submitted by
Disseminate Dissent
Severity
normal
D
D
Disseminate Dissent wrote on 4 Jan 2022 01:28
(name . Guix Patches)(address . guix-patches@gnu.org)
tOF54o2ItAc_QA9Ufl7XWi3-syhC9cK9UhbK1i0JjbFafeLIvGrM-roaMzMzDbrwuX5urzJXAnMh9yun3sC7VzdwSRmmZz93ozPioXrNt9Y=@protonmail.com
Disseminate,
Peace
From df48241d3b4be19110dad216c34b67b9aa0a2c9f Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Mon, 3 Jan 2022 19:26:02 -0500
Subject: [PATCH] gnu: Add yadm.

---
gnu/packages/configuration-management.scm | 31 +++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/configuration-management.scm b/gnu/packages/configuration-management.scm
index c64b937fe5..f9e08b87e4 100644
--- a/gnu/packages/configuration-management.scm
+++ b/gnu/packages/configuration-management.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +20,7 @@
(define-module (gnu packages configuration-management)
#:use-module (gnu packages)
#:use-module (guix build-system go)
+ #:use-module (guix build-system gnu)
#:use-module (guix git-download)
#:use-module (gnu packages golang)
#:use-module (gnu packages version-control)
@@ -103,3 +105,32 @@ (define-public chezmoi
(description "This package helps to manage personal configuration files
across multiple machines.")
(license license:expat)))
+
+(define-public yadm
+ (package
+ (name "yadm")
+ (version "3.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TheLocehiliosan/yadm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1s80l405w001var72pw5k3d88dqlm52njghdh6s3m344b839223f"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (delete 'build))))
+ (synopsis "Yet Another Dotfiles Manager")
+ (description
+ "yadm is like having a version of Git, that only operates on your dotfiles.
+If you know how to use Git, you already know how to use yadm.")
+ (home-page "https://yadm.io/")
+ (license license:gpl3+)))
--
2.34.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 52996@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52996
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch