gimagereader: build failure: undefined references

  • Open
  • quality assurance status badge
Details
One participant
  • Christopher Howard
Owner
unassigned
Submitted by
Christopher Howard
Severity
normal

Debbugs page

Christopher Howard wrote 3 years ago
(name . Bug Guix)(address . bug-guix@gnu.org)
YdNFL3E+sS7atbjU@theoden
gimagereader fails to build, giving a lot of undefined reference errors during building of qt sources. E.g.:

```
ld: CMakeFiles/gimagereader.dir/qt/src/scanner/ScannerSane.cc.o: in function `ScannerSane::doCompletePage()':
/tmp/guix-build-gimagereader-3.3.1.drv-0/gimagereader-3.3.1/qt/src/scanner/ScannerSane.cc:521: undefined reference to `Scanner::pageAvailable(QString const&)'
ld: CMakeFiles/gimagereader.dir/qt/src/scanner/ScannerSane.cc.o: in function `ScannerSane::run()':
/tmp/guix-build-gimagereader-3.3.1.drv-0/gimagereader-3.3.1/qt/src/scanner/ScannerSane.cc:66: undefined reference to `Scanner::initFailed()'
ld: CMakeFiles/gimagereader.dir/qt/src/scanner/ScannerSane.cc.o: in function `ScannerSane::setState(Scanner::State)':
/tmp/guix-build-gimagereader-3.3.1.drv-0/gimagereader-3.3.1/qt/src/scanner/ScannerSane.cc:117: undefined reference to `Scanner::scanStateChanged(Scanner::State)'
ld: CMakeFiles/gimagereader.dir/qt/src/scanner/ScannerSane.cc.o: in function `ScannerSane::failScan(QString const&)':
/tmp/guix-build-gimagereader-3.3.1.drv-0/gimagereader-3.3.1/qt/src/scanner/ScannerSane.cc:122: undefined reference to `Scanner::scanFailed(QString const&)'
collect2: error: ld returned 1 exit status
```

My system:

```
christopher@theoden ~$ neofetch --stdout
christopher@theoden
-------------------
OS: Guix System d422848146f4b7d6aaec20776daaac8964416a0f x86_64
Host: OptiPlex 9020 00
Kernel: 5.15.5-gnu
Uptime: 13 days, 1 hour, 12 mins
Packages: 91 (guix-system), 150 (guix-user)
Shell: bash 5.0.16
Resolution: 1920x1080
DE: GNOME
Theme: Adwaita [GTK2/3]
Icons: Adwaita [GTK2/3]
Terminal: .emacs-27.2-rea
CPU: Intel i5-4570 (4) @ 3.600GHz
GPU: Intel HD Graphics
GPU: AMD ATI Radeon HD 8490 / R5 235X OEM
Memory: 3356MiB / 7869MiB
```

--
馃摏 Christopher Howard
馃殌 gemini://gem.librehacker.com

讘专讗砖讬转 讘专讗 讗诇讛讬诐 讗转 讛砖诪讬诐 讜讗转 讛讗专抓
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 52984@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52984
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help