kiasoc5 wrote 3 years ago
(name . Guix Patches)(address . guix-patches@gnu.org)
From cbd6bb2745f33c568ae359f08389b68728866598 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Sun, 2 Jan 2022 16:08:29 -0500
Subject: [PATCH 1/2] gnu: xsnow: Update to 3.4.2.
* gnu/packages/toys.scm (xsnow): Update to 3.4.2.
---
gnu/packages/toys.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
Toggle diff (36 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 80928474aa..a7dd2bc50f 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -228,15 +228,15 @@ (define-public filters
(define-public xsnow
(package
(name "xsnow")
- (version "2.0.22")
+ (version "3.4.2")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://www.ratrabbit.nl/ratrabbit/system/files/xsnow/xsnow-"
+ "https://nav.dl.sourceforge.net/project/xsnow/xsnow-"
version ".tar.gz"))
(sha256
- (base32 "1880643fal6l7bskqbm4zfbr2s719698mkx4pchrxkjpb240sj0z"))))
+ (base32 "17pxc955jgkjan8ax0lw3b3sibw7aikc7p9qbxsp0w7g7jkxf666"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -256,7 +256,7 @@ (define-public xsnow
("libxxml2" ,libxml2)))
(native-inputs
(list pkg-config))
- (home-page "https://www.ratrabbit.nl/ratrabbit/content/xsnow/introduction")
+ (home-page "https://www.ratrabbit.nl/ratrabbit/xsnow/index.html")
(synopsis "Let it snow on the desktop")
(description "@code{Xsnow} animates snowfall and Santa with reindeer on
the desktop background. Additional customizable effects include wind, stars
base-commit: 01ec5efff7cf95cae69493bd4ccfdd21a38770ae
--
2.34.1
From 39e54183912c29019484fae214a015cb53386fc1 Mon Sep 17 00:00:00 2001
From: kiasoc5 <kiasoc5@tutanota.com>
Date: Sun, 2 Jan 2022 16:09:17 -0500
Subject: [PATCH 2/2] gnu: xsnow: Simplify inputs.
* gnu/packages/toys.scm (xsnow)[inputs]: Remove labels.
---
gnu/packages/toys.scm | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
Toggle diff (19 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index a7dd2bc50f..a1386d2298 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -249,11 +249,7 @@ (define-public xsnow
(string-append prefix "bin")))
#t)))))
(inputs
- `(("gtk+" ,gtk+)
- ("libx11" ,libx11)
- ("libxpm" ,libxpm)
- ("libxt" ,libxt)
- ("libxxml2" ,libxml2)))
+ (list gtk+ libx11 libxpm libxt libxml2))
(native-inputs
(list pkg-config))
(home-page "https://www.ratrabbit.nl/ratrabbit/xsnow/index.html")
--
2.34.1