[PATCH] gnu: darktable: update to 3.8.0

  • Done
  • quality assurance status badge
Details
3 participants
  • Alex Devaure
  • John Kehayias
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alex Devaure
Severity
normal
Merged with
A
A
Alex Devaure wrote on 2 Jan 2022 10:43
(address . guix-patches@gnu.org)
875yr24glr.fsf@gmail.com
---
gnu/packages/photo.scm | 76 +++++++++++++++++++++---------------------
1 file changed, 38 insertions(+), 38 deletions(-)

Toggle diff (103 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index e6f26c3b72..a229897f08 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -460,7 +460,7 @@ (define-public lensfun
(define-public darktable
(package
(name "darktable")
- (version "3.6.1")
+ (version "3.8.0")
(source
(origin
(method url-fetch)
@@ -468,7 +468,7 @@ (define-public darktable
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "051dwhdqa9q3zyrvr78g0cfzl1zhaagfvgx9axa9895q0g0wggx2"))))
+ (base32 "01gp9dg5wr2rg1k8cqs0l3s7ism8a4q8qypgwccd4jh7ip3wfr9f"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBINARY_PACKAGE_BUILD=On"
@@ -521,42 +521,42 @@ (define-public darktable
("python" ,python-wrapper)
("ruby" ,ruby)))
(inputs
- `(("cairo" ,cairo)
- ("colord-gtk" ,colord-gtk) ;optional, for color profile support
- ("cups" ,cups) ;optional, for printing support
- ("curl" ,curl)
- ("dbus-glib" ,dbus-glib)
- ("exiv2" ,exiv2)
- ("freeimage" ,freeimage)
- ("gmic" ,gmic) ;optional, for HaldcLUT support
- ("graphicsmagick" ,graphicsmagick)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtk+" ,gtk+)
- ("imath" ,imath)
- ("iso-codes" ,iso-codes) ;optional, for language names in the preferences
- ("json-glib" ,json-glib)
- ("lcms" ,lcms)
- ("lensfun" ,lensfun) ;optional, for the lens distortion plugin
- ("libgphoto2" ,libgphoto2) ;optional, for camera tethering
- ("libavif" ,libavif) ;optional, for AVIF support
- ("libjpeg" ,libjpeg-turbo)
- ("libomp" ,libomp)
- ("libpng" ,libpng)
- ("librsvg" ,librsvg)
- ("libsecret" ,libsecret) ;optional, for storing passwords
- ("libsoup" ,libsoup-minimal-2)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp) ;optional, for WebP support
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("lua" ,lua) ;optional, for plugins
- ("opencl-icd-loader" ,opencl-icd-loader) ;optional, for OpenCL support
- ("openexr" ,openexr) ;optional, for EXR import/export
- ("openjpeg" ,openjpeg) ;optional, for JPEG2000 export
- ("osm-gps-map" ,osm-gps-map) ;optional, for geotagging view
- ("pugixml" ,pugixml)
- ("python-jsonschema" ,python-jsonschema)
- ("sqlite" ,sqlite)))
+ (list cairo
+ colord-gtk ;optional, for color profile support
+ cups ;optional, for printing support
+ curl
+ dbus-glib
+ exiv2
+ freeimage
+ gmic ;optional, for HaldcLUT support
+ graphicsmagick
+ gsettings-desktop-schemas
+ gtk+
+ imath
+ iso-codes ;optional, for language names in the preferences
+ json-glib
+ lcms
+ lensfun ;optional, for the lens distortion plugin
+ libgphoto2 ;optional, for camera tethering
+ libavif ;optional, for AVIF support
+ libjpeg-turbo
+ libomp
+ libpng
+ librsvg
+ libsecret ;optional, for storing passwords
+ libsoup-minimal-2
+ libtiff
+ libwebp ;optional, for WebP support
+ libxml2
+ libxslt
+ lua ;optional, for plugins
+ opencl-icd-loader ;optional, for OpenCL support
+ openexr ;optional, for EXR import/export
+ openjpeg ;optional, for JPEG2000 export
+ osm-gps-map ;optional, for geotagging view
+ pugixml
+ python-jsonschema
+ sqlite))
(home-page "https://www.darktable.org")
(synopsis "Virtual lighttable and darkroom for photographers")
(description "Darktable is a photography workflow application and RAW
--
2.34.0
J
J
John Kehayias wrote on 2 Jan 2022 18:21
(name . 52956@debbugs.gnu.org)(address . 52956@debbugs.gnu.org)
ZWOcJvwJLFSM-TjPkFv6gCAopoW3uxbj-TjJZOJuSRdVhizNxipt37q1Sxq6etyZyww_pQ0Oz2kXXrxVf2cPJh-dJlyf5jY1LcnqZ4yciA8=@protonmail.com
Hello,

Thanks for the update to darktable. However, I noticed in the release notes that darktable now requires Lua 5.4 (we only have 5.3.5). When I tried my own update locally I could see that Lua support, needed for plugins, was disabled at configure due to the missing Lua 5.4 version.


I think it would be best to have the newer Lua version so we don't lose plugin support. Is there a patch for Lua 5.4 for Guix (my quick search didn't fine one)?

John
L
L
Ludovic Courtès wrote on 8 Jan 2022 22:59
Re: bug#52956: [PATCH] gnu: darktable: update to 3.8.0
(name . John Kehayias)(address . john.kehayias@protonmail.com)
87h7ad3n44.fsf_-_@gnu.org
Hi John and Alex,

John Kehayias <john.kehayias@protonmail.com> skribis:

Toggle quote (6 lines)
> Thanks for the update to darktable. However, I noticed in the release notes that darktable now requires Lua 5.4 (we only have 5.3.5). When I tried my own update locally I could see that Lua support, needed for plugins, was disabled at configure due to the missing Lua 5.4 version.
>
> Release notes: https://www.darktable.org/2021/12/darktable-3.8.0-released/
>
> I think it would be best to have the newer Lua version so we don't lose plugin support. Is there a patch for Lua 5.4 for Guix (my quick search didn't fine one)?

Indeed. I don’t see Lua 5.4 in the patch queue at issues.guix.gnu.org.
Does one of you want to give it a try?

Thanks,
Ludo’.
J
J
John Kehayias wrote on 8 Jan 2022 23:54
(name . Ludovic Courtès)(address . ludo@gnu.org)
foNs-rC4Sspfcler7BcTlQXzSzqxMF4u30DrSSYQF8YW81u1sb9RkYNNIeM7CmcRgqnCNsj2poK-3iwI4o4wtThAs6ZqhFTnxig26eUpxIA=@protonmail.com
Hello,

??????? Original Message ???????

On Saturday, January 8th, 2022 at 4:59 PM, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (13 lines)
> Hi John and Alex,
>
> John Kehayias john.kehayias@protonmail.com skribis:
>
> > Thanks for the update to darktable. However, I noticed in the release notes that darktable now requires Lua 5.4 (we only have 5.3.5). When I tried my own update locally I could see that Lua support, needed for plugins, was disabled at configure due to the missing Lua 5.4 version.
> >
> > Release notes: https://www.darktable.org/2021/12/darktable-3.8.0-released/
> >
> > I think it would be best to have the newer Lua version so we don't lose plugin support. Is there a patch for Lua 5.4 for Guix (my quick search didn't fine one)?
>
> Indeed. I don’t see Lua 5.4 in the patch queue at issues.guix.gnu.org.
> Does one of you want to give it a try?
>
I just tried a guix build lua --with-latest=lua and it built version 5.4.3 without any issue (even with the patches it has). I don't know anything to test with Lua, but in a guix shell it reported the correct version and the interpreter ran (I looked up a simple print statement which did work).

If there's nothing in particular I should look for, I can submit a quick patch for this. Should the package be lua-5.4 or maybe lua-next? And should the current lua now inherit from this latest version?

I'm assuming for the lua system to be updated would need a staging or core-updates cycle, with guix refresh lua -l reporting "408 packages would ensure 782 dependent packages are rebuilt". So we wouldn't want to replace "lua" with 5.4.3 yet.

John
A
A
Alex Devaure wrote on 9 Jan 2022 12:56
(name . John Kehayias)(address . john.kehayias@protonmail.com)
87sftxdshj.fsf@gmail.com
Hi John and Ludovic,

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (38 lines)
> Hello,
>
> ??????? Original Message ???????
>
> On Saturday, January 8th, 2022 at 4:59 PM, Ludovic Courtès <ludo@gnu.org> wrote:
>
>> Hi John and Alex,
>>
>> John Kehayias john.kehayias@protonmail.com skribis:
>>
>> > Thanks for the update to darktable. However, I noticed in the
>> > release notes that darktable now requires Lua 5.4 (we only have
>> > 5.3.5). When I tried my own update locally I could see that Lua
>> > support, needed for plugins, was disabled at configure due to the
>> > missing Lua 5.4 version.
>> >
>> > Release notes: https://www.darktable.org/2021/12/darktable-3.8.0-released/
>> >
>> > I think it would be best to have the newer Lua version so we don't lose plugin support. Is there a patch for Lua 5.4 for Guix (my quick search didn't fine one)?
>>
>> Indeed. I don’t see Lua 5.4 in the patch queue at issues.guix.gnu.org.
>> Does one of you want to give it a try?
>>
> I just tried a guix build lua --with-latest=lua and it built version
> 5.4.3 without any issue (even with the patches it has). I don't know
> anything to test with Lua, but in a guix shell it reported the correct
> version and the interpreter ran (I looked up a simple print statement
> which did work).
>
> If there's nothing in particular I should look for, I can submit a quick patch for this. Should the package be lua-5.4 or maybe lua-next? And should the current lua now inherit from this latest version?
>
> I'm assuming for the lua system to be updated would need a staging or
> core-updates cycle, with guix refresh lua -l reporting "408 packages
> would ensure 782 dependent packages are rebuilt". So we wouldn't want
> to replace "lua" with 5.4.3 yet.
>
> John

I managed to build darktable with the last lua version (4.5.3) but I
needed to update the patched for that version.
During that process, I came to the same question than John's: what is
the best and least disturbing way to add lua 4.5.3?

Kind regards,
Alex
J
J
John Kehayias wrote on 9 Jan 2022 19:35
(name . Alex Devaure)(address . ajadevaure@gmail.com)
k8r4z2cDy3Wo5a6GciJ-94u1qUrpBvo93r-JHlXyf1MZLqUcGybd3zujmHURNai7v7vO4JpcVcaaf9gRrad2bvRObsTsAakbavpRsD-i0Wg=@protonmail.com
Hi Alex and Ludo’,

??????? Original Message ???????

On Sunday, January 9th, 2022 at 6:56 AM, Alex Devaure wrote:

Toggle quote (6 lines)
> I managed to build darktable with the last lua version (4.5.3) but I
> needed to update the patched for that version.
> During that process, I came to the same question than John's: what is
> the best and least disturbing way to add lua 4.5.3?
>

Glad to hear darktable builds with the newer version of Lua.

However, I realized belatedly that the --with-latest transformation will not inherit the patches of the original package. And, as I would have expected, those patches don't apply cleanly to the new 5.4.3 source. I haven't had a chance to investigate, and likely won't be able to for a bit (still catching up on other patches I have).

As for how to introduce the new version, my guess (now that the patches needed to be updated) would be to have a lua-5.4 (or called lua-next) package. If it is just the patches that need to be updated, lua (the 5.3 version) could inherit from lua-5.4 adjusting the source field for that version and using the original patches. Assuming this doesn't cause rebuilds of the lua packages, that is. If more changes are needed, then lua-5.4 would just stand separate from the lua <= 5.3 version set.

John
A
A
Alex Devaure wrote on 9 Jan 2022 22:14
(name . John Kehayias)(address . john.kehayias@protonmail.com)
87zgo4ppx9.fsf@gmail.com
Hi John and Ludo,

John Kehayias <john.kehayias@protonmail.com> writes:

Toggle quote (20 lines)
> Hi Alex and Ludo’,
>
> ??????? Original Message ???????
>
> On Sunday, January 9th, 2022 at 6:56 AM, Alex Devaure wrote:
>
>> I managed to build darktable with the last lua version (4.5.3) but I
>> needed to update the patched for that version.
>> During that process, I came to the same question than John's: what is
>> the best and least disturbing way to add lua 4.5.3?
>>
>
> Glad to hear darktable builds with the newer version of Lua.
>
> However, I realized belatedly that the --with-latest transformation
> will not inherit the patches of the original package. And, as I would
> have expected, those patches don't apply cleanly to the new 5.4.3
> source. I haven't had a chance to investigate, and likely won't be
> able to for a bit (still catching up on other patches I have).
>
I modified lua.scm to integrate the version 4.5.3, creating new patches
as the current ones didn't work for that version.

Toggle quote (8 lines)
> As for how to introduce the new version, my guess (now that the
> patches needed to be updated) would be to have a lua-5.4 (or called
> lua-next) package. If it is just the patches that need to be updated,
> lua (the 5.3 version) could inherit from lua-5.4 adjusting the source
> field for that version and using the original patches. Assuming this
> doesn't cause rebuilds of the lua packages, that is. If more changes
> are needed, then lua-5.4 would just stand separate from the lua <= 5.3
> version set.
I should be able to send a patch with a new package names lua-5.4
tomorrow (UK time).

Toggle quote (3 lines)
>
> John

Best regards,
Alex
A
A
Alex Devaure wrote on 11 Jan 2022 13:25
(name . John Kehayias)(address . john.kehayias@protonmail.com)
87czkypiey.fsf@gmail.com
Hi John and Ludo,
I just submitted a patch to add the new version of lua.
Kind regards,
Alex

Alex Devaure <ajadevaure@gmail.com> writes:

Toggle quote (43 lines)
> Hi John and Ludo,
>
> John Kehayias <john.kehayias@protonmail.com> writes:
>
>> Hi Alex and Ludo’,
>>
>> ??????? Original Message ???????
>>
>> On Sunday, January 9th, 2022 at 6:56 AM, Alex Devaure wrote:
>>
>>> I managed to build darktable with the last lua version (4.5.3) but I
>>> needed to update the patched for that version.
>>> During that process, I came to the same question than John's: what is
>>> the best and least disturbing way to add lua 4.5.3?
>>>
>>
>> Glad to hear darktable builds with the newer version of Lua.
>>
>> However, I realized belatedly that the --with-latest transformation
>> will not inherit the patches of the original package. And, as I would
>> have expected, those patches don't apply cleanly to the new 5.4.3
>> source. I haven't had a chance to investigate, and likely won't be
>> able to for a bit (still catching up on other patches I have).
>>
> I modified lua.scm to integrate the version 4.5.3, creating new patches
> as the current ones didn't work for that version.
>
>> As for how to introduce the new version, my guess (now that the
>> patches needed to be updated) would be to have a lua-5.4 (or called
>> lua-next) package. If it is just the patches that need to be updated,
>> lua (the 5.3 version) could inherit from lua-5.4 adjusting the source
>> field for that version and using the original patches. Assuming this
>> doesn't cause rebuilds of the lua packages, that is. If more changes
>> are needed, then lua-5.4 would just stand separate from the lua <= 5.3
>> version set.
> I should be able to send a patch with a new package names lua-5.4
> tomorrow (UK time).
>
>>
>> John
>
> Best regards,
> Alex
L
L
Ludovic Courtès wrote on 11 Jan 2022 14:28
control message for bug #52956
(address . control@debbugs.gnu.org)
87r19etn9g.fsf@gnu.org
merge 52956 53152
quit
L
L
Ludovic Courtès wrote on 16 Jan 2022 23:21
Re: bug#52956: [PATCH] gnu: darktable: update to 3.8.0
(name . Alex Devaure)(address . ajadevaure@gmail.com)
87pmorz5ik.fsf_-_@gnu.org
Hi,

Alex Devaure <ajadevaure@gmail.com> skribis:

Toggle quote (2 lines)
> I just submitted a patch to add the new version of lua.

Nice. Now that the newer Lua is committed, could you update the
Darktable patch accordingly? And then I think we’ll be done.

Thanks in advance,
Ludo’.
A
A
Alex Devaure wrote on 17 Jan 2022 22:08
(name . Ludovic Courtès)(address . ludo@gnu.org)
87wniyxe2f.fsf@gmail.com
Hi Ludo,
I attached the updated patch for darktable using lua 5.4.3.
Kind regards,
Alex
Toggle diff (101 lines)
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 913e1070f7..14da5cf5fb 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -457,7 +457,7 @@ (define-public lensfun
(define-public darktable
(package
(name "darktable")
- (version "3.6.1")
+ (version "3.8.0")
(source
(origin
(method url-fetch)
@@ -465,7 +465,7 @@ (define-public darktable
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "051dwhdqa9q3zyrvr78g0cfzl1zhaagfvgx9axa9895q0g0wggx2"))))
+ (base32 "01gp9dg5wr2rg1k8cqs0l3s7ism8a4q8qypgwccd4jh7ip3wfr9f"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBINARY_PACKAGE_BUILD=On"
@@ -518,42 +518,42 @@ (define-public darktable
("python" ,python-wrapper)
("ruby" ,ruby)))
(inputs
- `(("cairo" ,cairo)
- ("colord-gtk" ,colord-gtk) ;optional, for color profile support
- ("cups" ,cups) ;optional, for printing support
- ("curl" ,curl)
- ("dbus-glib" ,dbus-glib)
- ("exiv2" ,exiv2)
- ("freeimage" ,freeimage)
- ("gmic" ,gmic) ;optional, for HaldcLUT support
- ("graphicsmagick" ,graphicsmagick)
- ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
- ("gtk+" ,gtk+)
- ("imath" ,imath)
- ("iso-codes" ,iso-codes) ;optional, for language names in the preferences
- ("json-glib" ,json-glib)
- ("lcms" ,lcms)
- ("lensfun" ,lensfun) ;optional, for the lens distortion plugin
- ("libgphoto2" ,libgphoto2) ;optional, for camera tethering
- ("libavif" ,libavif) ;optional, for AVIF support
- ("libjpeg" ,libjpeg-turbo)
- ("libomp" ,libomp)
- ("libpng" ,libpng)
- ("librsvg" ,librsvg)
- ("libsecret" ,libsecret) ;optional, for storing passwords
- ("libsoup" ,libsoup-minimal-2)
- ("libtiff" ,libtiff)
- ("libwebp" ,libwebp) ;optional, for WebP support
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("lua" ,lua) ;optional, for plugins
- ("opencl-icd-loader" ,opencl-icd-loader) ;optional, for OpenCL support
- ("openexr" ,openexr) ;optional, for EXR import/export
- ("openjpeg" ,openjpeg) ;optional, for JPEG2000 export
- ("osm-gps-map" ,osm-gps-map) ;optional, for geotagging view
- ("pugixml" ,pugixml)
- ("python-jsonschema" ,python-jsonschema)
- ("sqlite" ,sqlite)))
+ (list cairo
+ colord-gtk ;optional, for color profile support
+ cups ;optional, for printing support
+ curl
+ dbus-glib
+ exiv2
+ freeimage
+ gmic ;optional, for HaldcLUT support
+ graphicsmagick
+ gsettings-desktop-schemas
+ gtk+
+ imath
+ iso-codes ;optional, for language names in the preferences
+ json-glib
+ lcms
+ lensfun ;optional, for the lens distortion plugin
+ libgphoto2 ;optional, for camera tethering
+ libavif ;optional, for AVIF support
+ libjpeg-turbo
+ libomp
+ libpng
+ librsvg
+ libsecret ;optional, for storing passwords
+ libsoup-minimal-2
+ libtiff
+ libwebp ;optional, for WebP support
+ libxml2
+ libxslt
+ lua-5.4 ;optional, for plugins
+ opencl-icd-loader ;optional, for OpenCL support
+ openexr ;optional, for EXR import/export
+ openjpeg ;optional, for JPEG2000 export
+ osm-gps-map ;optional, for geotagging view
+ pugixml
+ python-jsonschema
+ sqlite))
(home-page "https://www.darktable.org")
(synopsis "Virtual lighttable and darkroom for photographers")
(description "Darktable is a photography workflow application and RAW
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (11 lines)
> Hi,
>
> Alex Devaure <ajadevaure@gmail.com> skribis:
>
>> I just submitted a patch to add the new version of lua.
>
> Nice. Now that the newer Lua is committed, could you update the
> Darktable patch accordingly? And then I think we’ll be done.
>
> Thanks in advance,
> Ludo’.
L
L
Ludovic Courtès wrote on 19 Jan 2022 21:44
(name . Alex Devaure)(address . ajadevaure@gmail.com)
87tudza20o.fsf@gnu.org
Hi,

Alex Devaure <ajadevaure@gmail.com> skribis:

Toggle quote (16 lines)
> Hi Ludo,
> I attached the updated patch for darktable using lua 5.4.3.
> Kind regards,
> Alex
>
> diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
> index 913e1070f7..14da5cf5fb 100644
> --- a/gnu/packages/photo.scm
> +++ b/gnu/packages/photo.scm
> @@ -457,7 +457,7 @@ (define-public lensfun
> (define-public darktable
> (package
> (name "darktable")
> - (version "3.6.1")
> + (version "3.8.0")

Applied with a commit log. Thanks!

Ludo’.
Closed
?