Traceback when reloading services

  • Open
  • quality assurance status badge
Details
One participant
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 2 Jan 2022 13:51
(address . bug-guix@gnu.org)
e737cf55082093ff210a823174ffbf686f8c5f82.camel@gmail.com
Hi Guix,

today I got the attached traceback while trying to reconfigure Guix.
It turns out that 145:12 tries to check which services are currently
running and ignores that (eval exp) might return #f.

I'm not sure which point would be the correct one to guard against this
case, but a naïve approach would be to just check inside the (return
...) statement. WDYT?
guix system: Bootloader erfolgreich auf „(/boot/efi)“ installiert
Backtrace:
In guix/scripts/system.scm:
1248:4 19 (_)
In ice-9/boot-9.scm:
1752:10 18 (with-exception-handler _ _ #:unwind? _ # _)
In guix/store.scm:
658:37 17 (thunk)
1320:8 16 (call-with-build-handler _ _)
1320:8 15 (call-with-build-handler _ _)
1320:8 14 (call-with-build-handler _ _)
1320:8 13 (call-with-build-handler _ _)
1320:8 12 (call-with-build-handler #<procedure 7f015bf8f900 at g…> …)
2123:24 11 (run-with-store #<store-connection 256.99 7f015bc599b0> …)
In ice-9/boot-9.scm:
1747:15 10 (with-exception-handler #<procedure 7f0136028e40 at ic…> …)
In ice-9/exceptions.scm:
406:15 9 (_)
In ice-9/boot-9.scm:
1752:10 8 (with-exception-handler _ _ #:unwind? _ # _)
In guix/scripts/system.scm:
865:15 7 (_)
In guix/store.scm:
2123:24 6 (run-with-store #<store-connection 256.99 7f015b2ff960> …)
In guix/scripts/system.scm:
865:15 5 (_ _)
In guix/scripts/system/reconfigure.scm:
145:12 4 (_ _)
In srfi/srfi-1.scm:
241:2 3 (map _ _)
In ice-9/boot-9.scm:
1685:16 2 (raise-exception _ #:continuable? _)
1683:16 1 (raise-exception _ #:continuable? _)
1685:16 0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
In procedure map: Wrong type argument: #f
?