[PATCH 0/2] gnu: Add odio-sacd.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arjan Adriaanse
  • Leo Famulari
Owner
unassigned
Submitted by
Arjan Adriaanse
Severity
normal

Debbugs page

Arjan Adriaanse wrote 3 years ago
(address . guix-patches@gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
cover.1641078255.git.arjan@adriaan.se
This patch series adds te odio-sacd package. The first patch adds the library
it depends on.

Arjan Adriaanse (2):
gnu: Add libodiosacd.
gnu: Add odio-sacd.

gnu/packages/audio.scm | 59 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 59 insertions(+)


base-commit: 637dec9d45db4df2a3e6aa565fa2c5cf6bb77768
--
2.34.0
Arjan Adriaanse wrote 3 years ago
[PATCH 1/2] gnu: Add libodiosacd.
(address . 52942@debbugs.gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
7246c3dae9b5ba53491695a529b60ec7ac2abbde.1641078255.git.arjan@adriaan.se
* gnu/packages/audio.scm (libodiosacd): New variable.
---
gnu/packages/audio.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index e10ee31b12..309d0024e6 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5560,3 +5561,36 @@ (define-public mda-lv2
"MDA-LV2 is an LV2 port of the MDA plugins. It includes effects and a few
instrument plugins.")
(license license:gpl3+)))
+
+(define-public libodiosacd
+ (package
+ (name "libodiosacd")
+ (version "21.8.30")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tari01/libodiosacd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0iamf7wksbql0qfigdv5ahaax53ms2yligdav8dw6x0ay88x4lhi"))
+ (modules '((guix build utils)))
+ (snippet
+ '(substitute* "Makefile"
+ (("\\$\\(DESTDIR\\)/usr") "\\$(DESTDIR)")))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:make-flags
+ (list (string-append "DESTDIR=" %output))))
+ (synopsis "Odio SACD (library)")
+ (description
+ "The Odio SACD shared library is a decoding engine which takes a Super
+Audio CD source and extracts a 24-bit high resolution wave file. It handles
+both DST and DSD streams.")
+ (home-page "https://tari.in/www/software/libodiosacd/")
+ (license license:gpl3)))
--
2.34.0
Arjan Adriaanse wrote 3 years ago
[PATCH 2/2] gnu: Add odio-sacd.
(address . 52942@debbugs.gnu.org)(name . Arjan Adriaanse)(address . arjan@adriaan.se)
a45fd582d15a41d6c6cff4d44d34b326f7f86d39.1641078255.git.arjan@adriaan.se
* gnu/packages/audio.scm (odio-sacd): New variable.
---
gnu/packages/audio.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 309d0024e6..ffe737c940 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -5594,3 +5594,28 @@ (define-public libodiosacd
both DST and DSD streams.")
(home-page "https://tari.in/www/software/libodiosacd/")
(license license:gpl3)))
+
+(define-public odio-sacd
+ (package
+ (name "odio-sacd")
+ (version "21.1.9")
+ (source (origin
+ (inherit (package-source libodiosacd)) ; needs same snippet
+ (uri (git-reference
+ (url "https://github.com/tari01/odio-sacd")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0314srqk0r4qv292qiaply619l2fw04nkdwvqhj3q1dqzv41g4qk"))))
+ (inputs (list libodiosacd))
+ ;; Build system and arguments for libodiosacd are identical.
+ (build-system (package-build-system libodiosacd))
+ (arguments (package-arguments libodiosacd))
+ (synopsis "Odio SACD (application)")
+ (description
+ "Odio SACD is a command-line application which takes a Super Audio CD
+source and extracts a 24-bit high resolution wave file. It handles both DST
+and DSD streams.")
+ (home-page "https://tari.in/www/software/odio-sacd/")
+ (license license:gpl3)))
--
2.34.0
Leo Famulari wrote 3 years ago
Re: [bug#52942] [PATCH 0/2] gnu: Add odio-sacd.
(name . Arjan Adriaanse)(address . arjan@adriaan.se)(address . 52942-done@debbugs.gnu.org)
YdE6eBf+41LFi0MN@jasmine.lan
On Sun, Jan 02, 2022 at 12:14:50AM +0100, Arjan Adriaanse wrote:
Toggle quote (7 lines)
> This patch series adds te odio-sacd package. The first patch adds the library
> it depends on.
>
> Arjan Adriaanse (2):
> gnu: Add libodiosacd.
> gnu: Add odio-sacd.

Thank you for these patches! I pushed as
0e4a23098ac274c79351a423410867e549729794 with the following changes:

I changed the license to gpl3+. Looking at the source file headers, I
see they all seem to say "either version 3 of the License, or (at your
option) any later version", so we pass the option on to our users as
well. For example:


I also changed "wave" to "WAV" in the descriptions, since I found the
former to be ambiguous, and I also tweaked the synopses to be less
self-referential and (hopefully!) more useful for readers.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52942@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52942
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help