(address . bug-guix@gnu.org)
The 0ad package checks the version of mozjs and throws an error if it is
not exactly the version it expects. This check is done in
"source/scriptinterface/ScriptTypes.h" and it currently requires version
78.6 of mozjs. As Guix has mozjs 78.15 instead, 0ad fails to build.
Patching "ScriptTypes.h" to remove the check and compile with mozjs 78.15
doesn't work, the build phase fails with:
Toggle snippet (49 lines)
../../../source/scriptinterface/ScriptContext.cpp: In member function ‘void ScriptContext::UnRegisterRealm(JS::Realm*)’:
../../../source/scriptinterface/ScriptContext.cpp:146:39: error: cannot convert ‘JS::Zone*’ to ‘JSContext*’
146 | JS::PrepareZoneForGC(js::GetRealmZone(realm));
| ~~~~~~~~~~~~~~~~^~~~~~~
| |
| JS::Zone*
In file included from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/Value.h:25,
from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/CallArgs.h:74,
from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/jsapi.h:31,
from ../../../source/scriptinterface/ScriptTypes.h:63,
from ../../../source/scriptinterface/ScriptContext.h:21,
from ../../../source/scriptinterface/ScriptContext.cpp:20:
/gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/GCAPI.h:539:55: note: initializing argument 1 of ‘void JS::PrepareZoneForGC(JSContext*, JS::Zone*)’
539 | extern JS_PUBLIC_API void PrepareZoneForGC(JSContext* cx, Zone* zone);
| ~~~~~~~~~~~^~
In file included from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/TraceKind.h:12,
from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/jspubtd.h:18,
from ../../../source/scriptinterface/ScriptTypes.h:62,
from ../../../source/scriptinterface/ScriptContext.h:21,
from ../../../source/scriptinterface/ScriptContext.cpp:20:
/gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/TypeDecls.h:55:21: note: class type ‘JS::Zone’ is incomplete
55 | class JS_PUBLIC_API Zone;
| ^~~~
../../../source/scriptinterface/ScriptContext.cpp: In member function ‘void ScriptContext::PrepareZonesForIncrementalGC() const’:
../../../source/scriptinterface/ScriptContext.cpp:264:40: error: cannot convert ‘JS::Zone*’ to ‘JSContext*’
264 | JS::PrepareZoneForGC(js::GetRealmZone(realm));
| ~~~~~~~~~~~~~~~~^~~~~~~
| |
| JS::Zone*
In file included from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/Value.h:25,
from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/CallArgs.h:74,
from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/jsapi.h:31,
from ../../../source/scriptinterface/ScriptTypes.h:63,
from ../../../source/scriptinterface/ScriptContext.h:21,
from ../../../source/scriptinterface/ScriptContext.cpp:20:
/gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/GCAPI.h:539:55: note: initializing argument 1 of ‘void JS::PrepareZoneForGC(JSContext*, JS::Zone*)’
539 | extern JS_PUBLIC_API void PrepareZoneForGC(JSContext* cx, Zone* zone);
| ~~~~~~~~~~~^~
In file included from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/TraceKind.h:12,
from /gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/jspubtd.h:18,
from ../../../source/scriptinterface/ScriptTypes.h:62,
from ../../../source/scriptinterface/ScriptContext.h:21,
from ../../../source/scriptinterface/ScriptContext.cpp:20:
/gnu/store/gzsa3jrlhgcr3mr6i170lhgfsxsmpcps-mozjs-78.15.0/include/mozjs-78/js/TypeDecls.h:55:21: note: class type ‘JS::Zone’ is incomplete
55 | class JS_PUBLIC_API Zone;
| ^~~~
make[1]: *** [scriptinterface.make:146: obj/scriptinterface_Release/ScriptContext.o] Error 1
What would be the best way to fix this?
- keep a mozjs-78.6 package around just for 0ad
- patch 0ad to fix the compatibility issues with mozjs 78.15
- use the mozjs version bundled in the 0ad sources
WDYT?
-----BEGIN PGP SIGNATURE-----
iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYc7Oxw8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/KBwD/QRG086d0GsQcaPtmF9XknAi63U5m3nnrocJw
9X8NaqIA+wb0gAz34Lg1aj44VJHxGo+NEADlnRoRQRH1bvIIXxB0
=qyc9
-----END PGP SIGNATURE-----