[PATCH] gnu: libfido2: install udev rules

  • Done
  • quality assurance status badge
Details
4 participants
  • dan
  • John Kehayias
  • Christopher Baines
  • Nicolas Graves
Owner
unassigned
Submitted by
dan
Severity
normal
D
(address . guix-patches@gnu.org)
20211230170032.20683-1-igaryhe@gmail.com
[arguments]: Add a configure flag specifying the installation directory of the
udev rule.

---
gnu/packages/security-token.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 6a3e2d9179..719515e3ea 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -777,7 +777,9 @@ (define-public libfido2
("openssl" ,openssl)))
(build-system cmake-build-system)
(arguments
- '(#:phases
+ '(#:configure-flags
+ (list (string-append "-DUDEV_RULES_DIR=" %output "/lib/udev/rules.d"))
+ #:phases
(modify-phases %standard-phases
;; regress tests enabled only for debug builds
(delete 'check))))
--
2.34.0
D
Update cover letter
(address . 52900@debbugs.gnu.org)
87o84ykobi.fsf@gmail.com
For some reason the cover letter was not shown up properly. The
following is the missing line:

* gnu/packages/security-token.scm(libfido2): Install udev rules.
--
dan
J
J
John Kehayias wrote on 15 Jun 2022 18:13
Re: [PATCH] gnu: libfido2: install udev rules
(name . 52900@debbugs.gnu.org)(address . 52900@debbugs.gnu.org)
WwRc02NMqUlMpNqQd4Ti7uhaceYEI1e2e18S5UGDG5grudxZicVzTWh6Qx1B2SZXDqAv1AHm56VWXFTpnhJSlEFS5_fw4PL8Kd9q1WH7FK0=@protonmail.com
Hello,

Thanks for the patch. Could you update it to match the current package definition of libfido2 (and you may want to add your copyright line to the top)?

Since libu2f is deprecated, we should rely on libfido2, so we need the udev rules that this patch makes available. I tested a local version which just needed to add the (string-append...) s-expression to the #:configure-flags that are currently present. I tested that it built and did have the udev rules.

Thanks!
John
N
N
Nicolas Graves wrote on 6 Oct 2022 19:07
[PATCH] gnu: libfido2: install udev rules.
(address . 52900@debbugs.gnu.org)
87a668nanj.fsf@ngraves.fr
[arguments]: Add a configure flag specifying the installation directory of the
udev rule.
---
gnu/packages/security-token.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (14 lines)
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 447a7a582d..5f10b5592a 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -909,7 +909,8 @@ (define-public libfido2
"-DPKG_CONFIG_EXECUTABLE="
(search-input-file %build-inputs
(string-append
- "/bin/" ,(pkg-config-for-target)))))
+ "/bin/" ,(pkg-config-for-target))))
+ (string-append "-DUDEV_RULES_DIR=" %output "/lib/udev/rules.d"))
#:phases
(modify-phases %standard-phases
;; regress tests enabled only for debug builds
--
2.37.3

--
Best regards,
Nicolas Graves
C
C
Christopher Baines wrote on 13 Oct 2022 13:44
(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87o7ug6j7d.fsf@cbaines.net
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (6 lines)
> [arguments]: Add a configure flag specifying the installation directory of the
> udev rule.
> ---
> gnu/packages/security-token.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)

Thanks all, I've gone ahead and pushed this to master as.
33f56db65498b75ad0a55b780ce501d2b3532044.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmNH+kZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XdUeg/9EpNoH42qkfeAMYf+nGrEJiVEy0q8mkg0
VAncZFUhY8vCoqRi3unYVarVJNDSkA47xBMw9axuADdB8LDXZRDlfYrRS3c/YSad
CZppar3Ye4bcZtyD9aAOcijwyzNmzxs2A3qdwJkXHol9xgETsDDutczIY9jZSv40
fKQYMeMY+6iX2AnbscwgKuuWZT/aU3PiXVHiy6sHPzNbOE5sGc1XACRiFrPv7tAs
1V9oAFxmYJZeYwmHkLJPJ4lca/8uYFqZ64qRwQQEypsdNHhO5M9bZCYjGK4BaY5U
4fRfn+eaah/4agAYEOJ/Sh7vmrLfpAQlWyzf9O6VQxAdY6oKwrEv9iL1l3mqBVK2
bCIC7WQBM9m7MZd7RQc1s4jk4Ny2ZbxCftuLZRVqztvAp3eG57YO0FLpyKLeg4F1
WbM8akFLy6jas4YqLtyMmQ7u5vqjlZbV1ojKu6rMoxY9WV8tGWqr45o8comomnTs
rFmXNMvsu12IwDNxHJR3OHgLcoRuWb0SMP7F2AOWhNRdeGgHcfU63nQA1SmDyPTB
hkzBoX8klBn3J5HvV0VB/DSp7eC87oqc6sORM+u8ukB03Nj5Ljg+DrsjZkIk58n9
qCefB8NS5F3n4F4CC72DPo6qsJUlOb7tJzbssLD3Ni/3dlOXQs3XG/iqromiiDTu
KbtA3j8isKM=
=hQtg
-----END PGP SIGNATURE-----

Closed
?