Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
From: Morgan Smith <Morgan.J.Smith@outlook.com>
* gnu/packages/python-web.scm (python-cssselect2)
[phases]: Add disable-linters phase. Make check phase respect #:tests?
[native-inputs]: Remove python-pytest-flake8 and python-pytest-isort
---
gnu/packages/python-web.scm | 15 ++++++++++++---
1 file changed, 12 insertions(+), 3 deletions(-)
Toggle diff (32 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 61a34bfc63..f424c6a103 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4582,13 +4582,22 @@ (define-public python-cssselect2
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-linters
+ ;; Their check fails; none of our business.
+ (lambda _
+ (substitute* '("setup.py" "pyproject.toml")
+ (("'pytest-flake8',") "")
+ (("'pytest-isort',") "")
+ (("--flake8") "")
+ (("--isort") ""))))
(replace 'check
- (lambda _ (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (lambda _ (invoke "pytest"))))))))
(propagated-inputs
(list python-tinycss2))
(native-inputs
- (list python-pytest-cov python-pytest-flake8 python-pytest-isort
- python-pytest-runner))
+ (list python-pytest-cov python-pytest-runner))
(home-page "https://cssselect2.readthedocs.io/")
(synopsis "CSS selectors for Python ElementTree")
(description "@code{cssselect2} is a straightforward implementation of
--
2.34.0