[PATCH] gnu: python-cssselect2: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan.J.Smith
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Morgan.J.Smith
Severity
normal

Debbugs page

Morgan.J.Smith wrote 3 years ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
BYAPR05MB402375652FA66BCD03C044DBC5439@BYAPR05MB4023.namprd05.prod.outlook.com
From: Morgan Smith <Morgan.J.Smith@outlook.com>

* gnu/packages/python-web.scm (python-cssselect2)
[phases]: Add disable-linters phase. Make check phase respect #:tests?
[native-inputs]: Remove python-pytest-flake8 and python-pytest-isort
---
gnu/packages/python-web.scm | 15 ++++++++++++---
1 file changed, 12 insertions(+), 3 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 61a34bfc63..f424c6a103 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4582,13 +4582,22 @@ (define-public python-cssselect2
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-linters
+ ;; Their check fails; none of our business.
+ (lambda _
+ (substitute* '("setup.py" "pyproject.toml")
+ (("'pytest-flake8',") "")
+ (("'pytest-isort',") "")
+ (("--flake8") "")
+ (("--isort") ""))))
(replace 'check
- (lambda _ (invoke "pytest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (lambda _ (invoke "pytest"))))))))
(propagated-inputs
(list python-tinycss2))
(native-inputs
- (list python-pytest-cov python-pytest-flake8 python-pytest-isort
- python-pytest-runner))
+ (list python-pytest-cov python-pytest-runner))
(home-page "https://cssselect2.readthedocs.io/")
(synopsis "CSS selectors for Python ElementTree")
(description "@code{cssselect2} is a straightforward implementation of
--
2.34.0
Nicolas Goaziou wrote 3 years ago
(address . Morgan.J.Smith@outlook.com)(address . 52861-done@debbugs.gnu.org)
874k6r80j9.fsf@nicolasgoaziou.fr
Hello,

Morgan.J.Smith@outlook.com writes:
Toggle quote (5 lines)
>
> * gnu/packages/python-web.scm (python-cssselect2)
> [phases]: Add disable-linters phase. Make check phase respect #:tests?
> [native-inputs]: Remove python-pytest-flake8 and python-pytest-isort

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52861@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52861
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help