(address . bug-guix@gnu.org)
Hi there,
rav1e failed to compile with error:
starting phase `build'
Error: CliError { error: Some(failed to select a version for `clang-sys`.
... required by package `bindgen v0.58.1`
... which is depended on by `dav1d-sys v0.3.4`
... which is depended on by `rav1e v0.4.1 (/tmp/guix-build-rav1e-0.4.1.drv-0/rav1e-0.4.1)`
versions that meet the requirements `^1` are: 1.0.0
the package `clang-sys` links to the native library `clang`, but it conflicts with a previous package which links to `clang` as well:
package `clang-sys v0.29.3`
... which is depended on by `bindgen v0.54.1`
... which is depended on by `aom-sys v0.2.1`
... which is depended on by `rav1e v0.4.1 (/tmp/guix-build-rav1e-0.4.1.drv-0/rav1e-0.4.1)`
The issue caused by commit ad1e8a0906c. Possible fix:
Toggle diff (15 lines)
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index e4cd01fadf..269bd991ab 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -208,7 +208,7 @@ (define-public rust-aom-sys-0.2
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
- (("rust-bindgen" ,rust-bindgen-0.54)
+ (("rust-bindgen" ,rust-bindgen-0.58)
("rust-metadeps" ,rust-metadeps-1))))
(native-inputs
(list pkg-config))
--