Update nheko and (some of) its dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • raingloom
Owner
unassigned
Submitted by
raingloom
Severity
normal
R
R
raingloom wrote on 26 Dec 2021 11:28
(name . Guix Patches)(address . guix-patches@gnu.org)
20211226112849.27140d58@riseup.net
This is very belated.

As far as I know all dependency updates are necessary, especially the
qtkeychain one, due to a bug:
From bc12726a5b697d52bea400b843394425938b306f Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Sun, 26 Dec 2021 08:16:24 +0100
Subject: [PATCH 1/6] gnu: spdlog: Build shared library.

* gnu/packages/logging.scm (spdlog)[arguments]: Enable SPDLOG_BUILD_SHARED flag.
---
gnu/packages/logging.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 7e07f4dd67..13dd74dadb 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -193,6 +193,7 @@ (define-public spdlog
(arguments
'(#:configure-flags
(list "-DSPDLOG_BUILD_BENCH=OFF"
+ "-DSPDLOG_BUILD_SHARED=ON"
"-DSPDLOG_BUILD_TESTS=ON")))
(home-page "https://github.com/gabime/spdlog")
(synopsis "Fast C++ logging library")
--
2.34.0
From ae1b5d3038d815f8b252a2324648d8857a4b7067 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Sun, 26 Dec 2021 08:39:07 +0100
Subject: [PATCH 2/6] gnu: Add coeurl.

* gnu/packages/curl.scm (coeurl): New variable.
---
gnu/packages/curl.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (52 lines)
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 9a9d788ceb..38f27e7c72 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -40,11 +40,15 @@ (define-module (gnu packages curl)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
+ #:use-module (guix build-system meson)
#:use-module (gnu packages)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages golang)
#:use-module (gnu packages guile)
#:use-module (gnu packages kerberos)
+ #:use-module (gnu packages logging)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages libidn)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -333,3 +337,29 @@ (define-public h2c
"Provided a set of HTTP request headers, h2c outputs how to invoke
curl to obtain exactly that HTTP request.")
(license license:expat)))
+
+(define-public coeurl
+ (package
+ (name "coeurl")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://nheko.im/nheko-reborn/coeurl")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0sqciagagyc0qv90g0qw8fkyvy4l8h7nbaz04chiz9gnv89hg28p"))))
+ (build-system meson-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("doctest" ,doctest) ;; for tests
+ ("spdlog" ,spdlog)
+ ("libevent" ,libevent)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://nheko.im/nheko-reborn/coeurl")
+ (synopsis "Simple async wrapper around CURL for C++")
+ (description "Simple library to do http requests asynchronously via CURL in C++.")
+ (license license:expat)))
--
2.34.0
From 7f172a931e077f6a471be25aa1c3446afac8e562 Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Sun, 26 Dec 2021 08:20:06 +0100
Subject: [PATCH 4/6] gnu: Update qtkeychain to 0.13.2.

* gnu/packages/qt.scm (qtkeychain): Update 0.13.2.
---
gnu/packages/qt.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 01bf961bbf..4c971aa51d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -70,6 +70,7 @@ (define-module (gnu packages qt)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphics)
@@ -2402,7 +2403,7 @@ (define-public python-pyqt+qscintilla
(define-public qtkeychain
(package
(name "qtkeychain")
- (version "0.9.1")
+ (version "0.13.2")
(source
(origin
(method git-fetch)
@@ -2412,12 +2413,12 @@ (define-public qtkeychain
(file-name (git-file-name name version))
(sha256
(base32
- "0h4wgngn2yl35hapbjs24amkjfbzsvnna4ixfhn87snjnq5lmjbc"))))
+ "1zk6r2vc1q48qs7mw2h47bpgrfbb9r7lf9cwq4sb1a4nls87zznk"))))
(build-system cmake-build-system)
(native-inputs
(list pkg-config qttools))
(inputs
- (list qtbase-5))
+ (list libsecret qtbase-5))
(arguments
`(#:tests? #f ; No tests included
#:phases
--
2.34.0
From d03f147a0d6a8952049a72f2ed1628f30754944d Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Fri, 10 Dec 2021 02:40:25 +0100
Subject: [PATCH 5/6] gnu: nheko: Update to 0.9.0.

* gnu/packages/messaging.scm (nheko): Update to 0.9.0.
[inputs]: Add coeurl, curl, libevent and xcb-util-wm.
---
gnu/packages/messaging.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 81bc9533b5..9e0f797996 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2334,7 +2334,7 @@ (define-public mtxclient
(define-public nheko
(package
(name "nheko")
- (version "0.8.2")
+ (version "0.9.0")
(source
(origin
(method git-fetch)
@@ -2343,7 +2343,7 @@ (define-public nheko
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0362hkbprc6jqlgmvzwxyvify4b1ldjakyqdz55m25xsypbpv2f3"))
+ (base32 "1akhnngxkxbjwjkg5ispl6j5s2ylbcj92r3zxqqry4gbfxbjpx8k"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -2392,10 +2392,13 @@ (define-public nheko
("blurhash" ,blurhash)
("cpp-httplib" ,cpp-httplib)
("cmark" ,cmark)
+ ("coeurl" ,coeurl)
+ ("curl" ,curl)
("gst-plugins-base" ,gst-plugins-base)
("gst-plugins-bad" ,gst-plugins-bad) ; sdp & webrtc for voip
("gst-plugins-good" ,gst-plugins-good) ; rtpmanager for voip
("json-modern-cxx" ,json-modern-cxx)
+ ("libevent" ,libevent)
("libnice" ,libnice) ; for voip
("libolm" ,libolm)
("lmdb" ,lmdb)
@@ -2411,6 +2414,7 @@ (define-public nheko
("qtsvg" ,qtsvg)
("spdlog" ,spdlog)
("single-application" ,single-application-qt5)
+ ("xcb-util-wm" ,xcb-util-wm)
("zlib" ,zlib)))
(native-inputs
`(("doxygen" ,doxygen)
--
2.34.0
R
R
raingloom wrote on 27 Dec 2021 06:04
(name . Guix Patches)(address . guix-patches@gnu.org)
20211227060456.09f772c1@riseup.net
On Sun, 26 Dec 2021 11:28:49 +0100
raingloom <raingloom@riseup.net> wrote:

Toggle quote (6 lines)
> This is very belated.
>
> As far as I know all dependency updates are necessary, especially the
> qtkeychain one, due to a bug:
> https://github.com/Nheko-Reborn/nheko/issues/715#issuecomment-914463594

Accidentally left a commented line in the mtxclient patch that is not
needed. The problem turned out to be earlyoom killing gcc. Here is the
same patch without that line.
N
N
Nicolas Goaziou wrote on 21 Jan 2022 22:37
Re: [bug#52802] Update nheko and (some of) its dependencies
(name . raingloom)(address . raingloom@riseup.net)(address . 52802-done@debbugs.gnu.org)
875yqcsrc9.fsf@nicolasgoaziou.fr
Hello,

raingloom <raingloom@riseup.net> writes:

Toggle quote (4 lines)
> As far as I know all dependency updates are necessary, especially the
> qtkeychain one, due to a bug:
> https://github.com/Nheko-Reborn/nheko/issues/715#issuecomment-914463594

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52802@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52802
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch