Thanks for the fast implementation in guile-netlink! Didn't know how to
use `--with-latest=guile-netlink` in that context so I updated the package:
Toggle diff (147 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 74567830e6..dcb1041136 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4602,37 +4602,39 @@ (define-public guile-fslib
(license license:agpl3+)))
(define-public guile-netlink
- (package
- (name "guile-netlink")
- (version "1.1.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.lepiller.eu/git/guile-netlink")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0jcl6mzqy04if5drflmygmggbgzsxa42mlmskqb3cfqmksq0zj0y"))))
- (build-system gnu-build-system)
- (inputs
- (list guile-3.0))
- (native-inputs
- (list automake
- autoconf
- pkg-config
- guile-3.0 ;for 'guild compile' + guile.m4
- texinfo))
- (home-page "https://git.lepiller.eu/guile-netlink")
- (synopsis "Netlink protocol implementation for Guile")
- (description "Guile Netlink is a GNU Guile library providing an
implementation
+ (let ((commit "b7aa2be9476e0f1b6cc4a7b22ba070c6411cb0ae")
+ (revision "1"))
+ (package
+ (name "guile-netlink")
+ (version (git-version "1.1.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.lepiller.eu/git/guile-netlink")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03f9ads2qj3lj8frlg3pmh0nx4qikqpkhy0fvfy12qivlrfdbvcm"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list guile-3.0))
+ (native-inputs
+ (list automake
+ autoconf
+ pkg-config
+ guile-3.0 ;for 'guild compile' + guile.m4
+ texinfo))
+ (home-page "https://git.lepiller.eu/guile-netlink")
+ (synopsis "Netlink protocol implementation for Guile")
+ (description "Guile Netlink is a GNU Guile library providing an
implementation
of the netlink protocol.
It provides a generic library for writing implementations of a netlink
protocol, a low-level rtnetlink implementation that uses that library
and a
high-level API for network management that uses rtnetlink.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public guile-gitlab
(package
That was the easy part. The part in gnu/services/base.scm seems to be a
bit over my Guile/gexp skills. And I couldn't find a proper source to
copy-and-paste-and-adapt :P