[PATCH] gnu: sdl2: Update to 2.0.18.

  • Done
  • quality assurance status badge
Details
2 participants
  • dan
  • Nicolas Goaziou
Owner
unassigned
Submitted by
dan
Severity
normal
D
(address . guix-patches@gnu.org)
20211223165956.28448-1-igaryhe@gmail.com
* gnu/packages/sdl.scm(sdl2): Update to 2.0.18.

[inputs]: Update with new syntax.

---
gnu/packages/sdl.scm | 27 +++++++++++++++------------
1 file changed, 15 insertions(+), 12 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index 4c38e2f055..071697c125 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -113,7 +113,7 @@ (define-public sdl
(define-public sdl2
(package (inherit sdl)
(name "sdl2")
- (version "2.0.14")
+ (version "2.0.18")
(source (origin
(method url-fetch)
(uri
@@ -121,7 +121,7 @@ (define-public sdl2
version ".tar.gz"))
(sha256
(base32
- "1g1jahknv5r4yhh1xq5sf0md20ybdw1zh1i15lry26sq39bmn8fq"))))
+ "073iwmggkvvl82fssqb7xzbb4awraprjig6zxav0p8dz7pbhrm4l"))))
(arguments
(substitute-keyword-arguments (package-arguments sdl)
((#:configure-flags flags)
@@ -141,16 +141,19 @@ (define-public sdl2
;; experience a bug where input events are doubled.
;;
;; For more information, see: https://dev.solus-project.com/T1721
- (append `(("dbus" ,dbus)
- ("eudev" ,eudev) ; for discovering input devices
- ("fcitx" ,fcitx) ; helps with CJK input
- ("glib" ,glib)
- ("ibus" ,ibus)
- ("libxkbcommon" ,libxkbcommon)
- ("libxcursor" ,libxcursor) ; enables X11 cursor support
- ("wayland" ,wayland)
- ("wayland-protocols" ,wayland-protocols))
- (package-inputs sdl)))
+ (list dbus
+ eudev ; for discovering input devices
+ fcitx ; helps with CJK input
+ glib
+ ibus
+ libxkbcommon
+ libxcursor ; enables X11 cursor support
+ wayland
+ wayland-protocols
+ libxrandr
+ glu
+ alsa-lib
+ pulseaudio))
(license license:bsd-3)))
(define-public libmikmod
--
2.34.0
N
N
Nicolas Goaziou wrote on 25 Jan 2022 18:56
(name . dan)(address . igaryhe@gmail.com)(address . 52757-done@debbugs.gnu.org)
871r0vbsxy.fsf@nicolasgoaziou.fr
Hello,

dan <igaryhe@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/sdl.scm(sdl2): Update to 2.0.18.
> [inputs]: Update with new syntax.

Thank you.

I applied it on core-updates branch.

Toggle quote (24 lines)
> - (append `(("dbus" ,dbus)
> - ("eudev" ,eudev) ; for discovering input devices
> - ("fcitx" ,fcitx) ; helps with CJK input
> - ("glib" ,glib)
> - ("ibus" ,ibus)
> - ("libxkbcommon" ,libxkbcommon)
> - ("libxcursor" ,libxcursor) ; enables X11 cursor support
> - ("wayland" ,wayland)
> - ("wayland-protocols" ,wayland-protocols))
> - (package-inputs sdl)))
> + (list dbus
> + eudev ; for discovering input devices
> + fcitx ; helps with CJK input
> + glib
> + ibus
> + libxkbcommon
> + libxcursor ; enables X11 cursor support
> + wayland
> + wayland-protocols
> + libxrandr
> + glu
> + alsa-lib
> + pulseaudio))

I used the modify-inputs macros instead.

Regards,
--
Nicolas Goaziou
Closed
?