[PATCH] self: Add guile-lzma as a dependency.

  • Done
  • quality assurance status badge
Details
One participant
  • Timothy Sample
Owner
unassigned
Submitted by
Timothy Sample
Severity
normal
T
T
Timothy Sample wrote on 23 Dec 2021 00:16
(address . guix-patches@gnu.org)
878rwcp6x8.fsf@ngyro.com
Hello,

This patch fixes an omission in my previous Disarchive patch.


-- Tim
From 47053d6250a7fb3fa0f33b2df308200cf5f1e4a6 Mon Sep 17 00:00:00 2001
From: Timothy Sample <samplet@ngyro.com>
Date: Wed, 22 Dec 2021 17:35:56 -0500
Subject: [PATCH] self: Add guile-lzma as a dependency.

This is a follow-up to 35ce3e5de6d39d4959ecae31e8f8ce2bbb645e0a, fixing
Disarchive recovery when the download script is run from a 'guix pull'
profile.

* guix/self.scm (specification->package): Add "guile-lzma".
(compiled-guix): Add GUILE-LZMA to DEPENDENCIES in
the #:dependencies argument to 'guix-command'.
---
guix/self.scm | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)

Toggle diff (35 lines)
diff --git a/guix/self.scm b/guix/self.scm
index bd9a71de45..943bb0b498 100644
--- a/guix/self.scm
+++ b/guix/self.scm
@@ -64,6 +64,7 @@ (define specification->package
("guile-gcrypt" (ref '(gnu packages gnupg) 'guile-gcrypt))
("gnutls" (ref '(gnu packages tls) 'gnutls))
("disarchive" (ref '(gnu packages backup) 'disarchive))
+ ("guile-lzma" (ref '(gnu packages guile) 'guile-lzma))
("gzip" (ref '(gnu packages compression) 'gzip))
("bzip2" (ref '(gnu packages compression) 'bzip2))
("xz" (ref '(gnu packages compression) 'xz))
@@ -789,6 +790,9 @@ (define* (compiled-guix source #:key
(define disarchive
(specification->package "disarchive"))
+ (define guile-lzma
+ (specification->package "guile-lzma"))
+
(define dependencies
(append-map transitive-package-dependencies
(list guile-gcrypt gnutls guile-git guile-avahi
@@ -1009,7 +1013,9 @@ (define* (compiled-guix source #:key
(command (guix-command modules
#:source source
#:dependencies
- (cons disarchive dependencies)
+ (cons* disarchive
+ guile-lzma
+ dependencies)
#:guile guile-for-build
#:guile-version guile-version)))
(whole-package name modules dependencies
--
2.34.0
T
T
Timothy Sample wrote on 23 Dec 2021 15:15
(address . 52742-done@debbugs.gnu.org)
874k6zpfua.fsf@ngyro.com
Timothy Sample <samplet@ngyro.com> writes:

Toggle quote (7 lines)
> This patch fixes an omission in my previous Disarchive patch.
>
> From 47053d6250a7fb3fa0f33b2df308200cf5f1e4a6 Mon Sep 17 00:00:00 2001
> From: Timothy Sample <samplet@ngyro.com>
> Date: Wed, 22 Dec 2021 17:35:56 -0500
> Subject: [PATCH] self: Add guile-lzma as a dependency.

Pushed after some IRC review.


-- Tim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 52742@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 52742
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch